Jump to content

Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore


Recommended Posts

  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 Donation with ETH 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05 Donation with LTC MTmk

a verdade é uma. essas telas do s145 são ruins demais. estou com um da 10th Gen, é a mesma coisa. horrível.

-- Update - New folder for Big Sur Beta 5+ -- -Fix Trackpad "RiP" after wake -New minimal USB Injector -Last BIOS/UEFI version -New DSDT full patched from last BIOS/UEFI version

  • Administrators
3 hours ago, LeBaldi said:

Alguem arriscou atualizar pro 11.1? :work:

tá na hora de migrar pro opencore. bigsur funciona como o catalina. o clover ainda tem uns problemas

Link to post
Share on other sites
18 hours ago, MaLd0n said:

tá na hora de migrar pro opencore. bigsur funciona como o catalina. o clover ainda tem uns problemas

Eu já estou no Opencore hehehehe... nem tentei mais no Clover. Mas falo mais pela questão de quebrar algo e tal. Pq da última vez no Catalina quebrou o HDMI :poke

Link to post
Share on other sites
  • Administrators
4 hours ago, LeBaldi said:

Eu já estou no Opencore hehehehe... nem tentei mais no Clover. Mas falo mais pela questão de quebrar algo e tal. Pq da última vez no Catalina quebrou o HDMI :poke

atualiza kexts e bootloader e manda ver

Link to post
Share on other sites
  • Administrators
1 hour ago, Josinei Araujo said:

Hi! i'm using the levono s145 i7 8th. I installed Big Sur 11.1, but I'm having the following problem: For some reason the startup takes a long time, and it displays this error: IOKit Daemon (kernelManagerd) :: X86PlatformPlugin. Would you help me?

update kexts and bootloader

33 minutes ago, Thrpod0 said:

Does trackpad works on wake from now ? New voodooI2C 2.6 ?

for me with icelake the problem stay there 😆

Link to post
Share on other sites

Olá pessoal,

Instalei o Catalina com a última versão disponível aqui no site, em seguida fiz o procedimento de cópia da pasta EFI conforme indicado na primeira página, porém notei que o dispositivo de audio não foi reconhecido. Nas propriedades do sistema indica "No Output Device". Alguém pode me ajudar?

Link to post
Share on other sites
  • Administrators
On 12/21/2020 at 8:56 AM, leandrobasso said:

Olá pessoal,

https://www.olarila.com/topic/10296-olarila-repair-app/

2 hours ago, n0t_luke27 said:

a partição EFI e o som funcionam somente se eu reiniciar várias vezes e quando eu desligo e ligo novamente o som para de funcionar e a EFI não monta tbm

atualiza kexts e bootloader. use opencore

Link to post
Share on other sites

Só dando uma atualizada aqui, saiu novas versões do Voodooi2C, e quem tinha o trackpad ELAN acabou tendo que ficar travado na 2.4.4, porém esta nova versão está funcionando novamente! Ele ainda da alguns pulos mas está mais firme do que na 2.4.4 no Big Sur, podem atualizar!

AH e ele funciona OK no retorno do sleep aqui, mas lembrando, track ELAN :classic_laugh:

  • Like 1
Link to post
Share on other sites
On 12/24/2020 at 7:38 PM, LeBaldi said:

Só dando uma atualizada aqui, saiu novas versões do Voodooi2C, e quem tinha o trackpad ELAN acabou tendo que ficar travado na 2.4.4, porém esta nova versão está funcionando novamente! Ele ainda da alguns pulos mas está mais firme do que na 2.4.4 no Big Sur, podem atualizar!

AH e ele funciona OK no retorno do sleep aqui, mas lembrando, track ELAN :classic_laugh:

Bom dia!

Excelente noticia.

@LeBaldi, fiquei um tempo sem acompanhar essa thread e notei que aconteceu bastante coisa. Gostaria de testar o Big Sur, poderia me instruir em como proceder? Uso Clover ou OpenCore? Atualizo do Catalina diretamente ou faço uma instalação limpa?

Vejo algumas pessoas falando do OpenCore, mas eu particularmente não sei como funciona.

As funcionalidades no Big Sur estão funcionando corretamente? Tipo: HDMI, Sleep, Som, Trackpad, etc...

Link to post
Share on other sites
On 12/28/2020 at 8:41 AM, leandrobasso said:

Bom dia!

Excelente noticia.

@LeBaldi, fiquei um tempo sem acompanhar essa thread e notei que aconteceu bastante coisa. Gostaria de testar o Big Sur, poderia me instruir em como proceder? Uso Clover ou OpenCore? Atualizo do Catalina diretamente ou faço uma instalação limpa?

Vejo algumas pessoas falando do OpenCore, mas eu particularmente não sei como funciona.

As funcionalidades no Big Sur estão funcionando corretamente? Tipo: HDMI, Sleep, Som, Trackpad, etc...

Cara se possivel sempre faça limpa, eu aqui aproveitei e fiz tudo num HD externo... e quando ficou tudo OK clonei ele pro SSD. Aqui funciona tudo! Tudo o q rodava no Catalina ta rodando de boa no Big Sur... porém tive que partir pro Open Core.. pastei muito... xinguei... muita birra mas meio q peguei um pouco do jeito dele hehehe

No inicio o Sleep tava quebrado, mas o Maldon foi ajudando a gente a deixar bem redondinho e hoje funciona tudo certinho.

Faz o seguinte, baixa a imagem do Big Sur daqui do Olarila... e substitui a pasta EFI inteira do pendrive pela minha que vou passar, ela inclusive quando testei já habilitava o track pra instalação hahahaha.. depois q vc instalar baixa o OpenCore Configurator.. monta a EFI que obviamente não vai ter nada lá dentro e cola a pasta EFI inteira lá.. e já era! Ele ta com o ultimo Open Core e todas as minhas configs com o meu CPUFriend personalizado e tudo mais

https://mega.nz/file/A0sUHZ4Q#O7NU3REUsvXec3TPIywyQ7bqVlkKol6HiFqfWx5rogU

Link to post
Share on other sites
12 hours ago, LeBaldi said:

Cara se possivel sempre faça limpa, eu aqui aproveitei e fiz tudo num HD externo... e quando ficou tudo OK clonei ele pro SSD. Aqui funciona tudo! Tudo o q rodava no Catalina ta rodando de boa no Big Sur... porém tive que partir pro Open Core.. pastei muito... xinguei... muita birra mas meio q peguei um pouco do jeito dele hehehe

No inicio o Sleep tava quebrado, mas o Maldon foi ajudando a gente a deixar bem redondinho e hoje funciona tudo certinho.

Faz o seguinte, baixa a imagem do Big Sur daqui do Olarila... e substitui a pasta EFI inteira do pendrive pela minha que vou passar, ela inclusive quando testei já habilitava o track pra instalação hahahaha.. depois q vc instalar baixa o OpenCore Configurator.. monta a EFI que obviamente não vai ter nada lá dentro e cola a pasta EFI inteira lá.. e já era! Ele ta com o ultimo Open Core e todas as minhas configs com o meu CPUFriend personalizado e tudo mais

https://mega.nz/file/A0sUHZ4Q#O7NU3REUsvXec3TPIywyQ7bqVlkKol6HiFqfWx5rogU

Obrigado pelo retorno e pelas dicas, tentarei fazer conforme sua recomendação.

Espero que com OpenCore e Big Sur resolva o problema que tenho no meu trackpad. Ele está "pulando" o cursor do teclado de forma intermitente e isso está atrapalhando bastante. Não tenho esse comportamento quando o desativo nas configurações de acessibilidade. Mas enfim, isso é assunto para uma próxima discussão.

De qualquer forma, obrigado novamente pelo apoio.

12 hours ago, LeBaldi said:

Cara se possivel sempre faça limpa, eu aqui aproveitei e fiz tudo num HD externo... e quando ficou tudo OK clonei ele pro SSD. Aqui funciona tudo! Tudo o q rodava no Catalina ta rodando de boa no Big Sur... porém tive que partir pro Open Core.. pastei muito... xinguei... muita birra mas meio q peguei um pouco do jeito dele hehehe

No inicio o Sleep tava quebrado, mas o Maldon foi ajudando a gente a deixar bem redondinho e hoje funciona tudo certinho.

Faz o seguinte, baixa a imagem do Big Sur daqui do Olarila... e substitui a pasta EFI inteira do pendrive pela minha que vou passar, ela inclusive quando testei já habilitava o track pra instalação hahahaha.. depois q vc instalar baixa o OpenCore Configurator.. monta a EFI que obviamente não vai ter nada lá dentro e cola a pasta EFI inteira lá.. e já era! Ele ta com o ultimo Open Core e todas as minhas configs com o meu CPUFriend personalizado e tudo mais

https://mega.nz/file/A0sUHZ4Q#O7NU3REUsvXec3TPIywyQ7bqVlkKol6HiFqfWx5rogU

Eu só não entendi uma coisa. O OpenCore e o Clover são coisas distintas né? me desculpe pela ignorância, rsrsrs.

Existe a imagem Big Sur para OpenCore e a Big Sur com Clover?

 

Link to post
Share on other sites
5 hours ago, leandrobasso said:

Obrigado pelo retorno e pelas dicas, tentarei fazer conforme sua recomendação.

Espero que com OpenCore e Big Sur resolva o problema que tenho no meu trackpad. Ele está "pulando" o cursor do teclado de forma intermitente e isso está atrapalhando bastante. Não tenho esse comportamento quando o desativo nas configurações de acessibilidade. Mas enfim, isso é assunto para uma próxima discussão.

De qualquer forma, obrigado novamente pelo apoio.

Eu só não entendi uma coisa. O OpenCore e o Clover são coisas distintas né? me desculpe pela ignorância, rsrsrs.

Existe a imagem Big Sur para OpenCore e a Big Sur com Clover?

 

eles são bootloaders que cada um tem seus sistemas e peculiaridades. O Clover não tava dando jeito de bootar o Big Sur com as kexts ou algo assim pelo que eu entendi, e o Open Core é um bootloader novo que ta tentando simplificar um pouco as coisas e deixar mais parecido com um Mac de verdade, então o Clover meio que pegou algumas coisas emprestadas do OpenCore e parece que hoje boota também. Eu não consegui bootar, tentei umas 3x e algo sempre dava errado, e como o OP já bootava e só faltava umas coisinhas, acabei fuçando nele em si hehehe

Uma das coisas mais drasticas entre ambos é que o Clover vc mexe e ele se vira em bootar, já o OP tem toda uma árvore de boot com cada tempo de cada coisa que tem se respeitar, por exemplo as kexts, dependendo de como vc deixa a ordem delas, elas simplesmente não carregam. Ou seja, ele é um pouco mais enjoado pra personalizar, mas depois de feito funciona bem

Link to post
Share on other sites
4 minutes ago, LeBaldi said:

eles são bootloaders que cada um tem seus sistemas e peculiaridades. O Clover não tava dando jeito de bootar o Big Sur com as kexts ou algo assim pelo que eu entendi, e o Open Core é um bootloader novo que ta tentando simplificar um pouco as coisas e deixar mais parecido com um Mac de verdade, então o Clover meio que pegou algumas coisas emprestadas do OpenCore e parece que hoje boota também. Eu não consegui bootar, tentei umas 3x e algo sempre dava errado, e como o OP já bootava e só faltava umas coisinhas, acabei fuçando nele em si hehehe

Uma das coisas mais drasticas entre ambos é que o Clover vc mexe e ele se vira em bootar, já o OP tem toda uma árvore de boot com cada tempo de cada coisa que tem se respeitar, por exemplo as kexts, dependendo de como vc deixa a ordem delas, elas simplesmente não carregam. Ou seja, ele é um pouco mais enjoado pra personalizar, mas depois de feito funciona bem

Excelente explicação, obrigado!

Ainda sou novo nesse mundo, rsrs.

Resumindo, com bootlooder Open Core no Big Sur tá funcionando liso então?

Já baixei a midia, jaja tento a instalação do Big Sur.

 

Obrigado.

Link to post
Share on other sites
1 hour ago, leandrobasso said:

Excelente explicação, obrigado!

Ainda sou novo nesse mundo, rsrs.

Resumindo, com bootlooder Open Core no Big Sur tá funcionando liso então?

Já baixei a midia, jaja tento a instalação do Big Sur.

 

Obrigado.

Bom, aqui eu não tenho nenhum problema hehehe... unica coisa chatinha é o trackpad q é o ELAN.. as vezes não reconhece o click duplo... ou mesmo ao clicar não reconhece e quando bota o dedo ele da um pulo... mas te falar que nessa ultima VoodooI2C a coisa ta bem melhor.. só o click duplo q as vezes não reconhece... mas melhorou bem em relação ao 2.4.4

Ah! E tbm uso outra placa wifi aki.. uso a DW1560 da Fenvi que comprei pela China

Link to post
Share on other sites
  • Administrators
9 minutes ago, Eduardo Eduardo said:

Olá pessoal

atualiza o opencore e o config.plist de acordo com a versão do opencore

Link to post
Share on other sites

Existe algum jeito de amplificar o som do note? Eu pra assistir series no VLC geralmente uso 140-170% pra ficar bom... porém pro YouTube fica meio baixo... eu acho... já tentei no OpenCore mas parece que não mudou nada

Link to post
Share on other sites
  • MaLd0n changed the title to Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap