Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
MaLd0n

Hackintosh Guide - Sierra / High Sierra / Mojave / Catalina on Sky/Kaby/CoffeeLake Notebooks with Clover Bootloader

Recommended Posts

using current clover(not replace with 100.200.300)

the problem is inject kexts


the best is use all kexts in clover/kexts/other and option InjectKexts in config.plist

Share this post


Link to post
Share on other sites

the problem is inject kexts


the best is use all kexts in clover/kexts/other and option InjectKexts in config.plist

yes,

I checked kexts, all in clover/kexts/other

and option InjectKexts is 'Yes' in config.plist

1179417377_2019-03-068_56_21.png.41accf0a2711fde235d9afd481b297e5.png

Share this post


Link to post
Share on other sites

sorry, I'm confused.

what u use for install kexts? don't use nothing, just put kexts in clover/kexts/other and reboot


kexts folder

1SvUsJr.png


config.plist

0p0fgG7.png

Share this post


Link to post
Share on other sites

what u use for install kexts? don't use nothing, just put kexts in clover/kexts/other and reboot

yes

I checked kexts, all in clover/kexts/other

and option InjectKexts is 'Yes' in config.plist

Share this post


Link to post
Share on other sites

InjectKexts is 'Yes' in config.plist

but if u have kexts in system folder like l/e or s/l/e, use "detect"

nC7tdit.png

Share this post


Link to post
Share on other sites

but if u have kexts in system folder like l/e or s/l/e, use "detect"

 

I just put 3rd kext in Others directory, Not putting them into system folder :frantics

Share this post


Link to post
Share on other sites

any suggestion else?

u need check library/extensions and system/library/extensions

Share this post


Link to post
Share on other sites

u need check library/extensions and system/library/extensions

 

no 3rd kext in l/e and s/l/e

do you mean I must put kext into L/E or S/L/E?

Share this post


Link to post
Share on other sites

no 3rd kext in l/e and s/l/e

do you mean I must put kext into L/E or S/L/E?

no, the problem appears if u use kexts in clover folder and system folder


best is use all in clover folder and system stay clean

Share this post


Link to post
Share on other sites

no, the problem appears if u use kexts in clover folder and system folder


best is use all in clover folder and system stay clean

 

yes, I just use kexts in clover folder, no one 3rd kext in system folder

Share this post


Link to post
Share on other sites

yes, I just use kexts in clover folder, no one 3rd kext in system folder

 

Delete those FakePCIID kexts...

Share this post


Link to post
Share on other sites

I have a lenovo ThinkPad T470s with Intel i7-7500U (Intel64 Family 6 Model 142 Stepping 9 GenuineIntel ~2703MHz)

Hey how I can know what I need beetween :


-Chipset Series 5, 6, 7, 8, 9

-SkyLake, KabyLake, CoffeLake

-SkyLake, KabyLake, CoffeLake Notebooks

-LGA775


THANK YOU ! :)

Share this post


Link to post
Share on other sites

[ref]GroYOO[/ref], -SkyLake, KabyLake, CoffeLake Notebooks

Share this post


Link to post
Share on other sites

Hi finally managed to install high sierra following your guide, but when i boot the installed OS i get this kernel error. Already tried the xhci kext with no luck. with the exception of the xhci kext my clover folder is exactly the same you provided on the first post.


thank you already


zRWVVYu.jpg

Share this post


Link to post
Share on other sites

Hi MaLdon, How are you doing? I followed your tutorial and I was able to install the latest macOS Mojave on my Lenovo Ideapad 300 15isk laptop. I used CCC in order to run it in HFS instead of APFS. Now there are only a few minor post-install issues:


a) Since I copied the EFI folder from the USB install stick to the EFI on my HD, the very beginning of the boot process is visually very noisy, so how can I have it boot more quietly? Is it possible?


b) Could you please point me in the right direction to get my Function keys working?


c) Wi-Fi doesn't work yet. I'm waiting for my Broadcom card to arrive.


Thank you very much for all the time and effort you invest in helping the Hackintosh comunnity. Your work is greatly respected and appreciated.


Best regards,


Jay Cee. :)

Share this post


Link to post
Share on other sites

EC0 to EC patch was already enabled in my config.plist. I installed your DSDT.aml to EFI... ACPI/Patched and I notice that now I have battery management and the brightness slider under system preferences works - this is a great improvement. Now, is there a way to make the brightness keys - and + work? Thanks a lot. I owe you a beer! ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...