Jump to content

Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore


Recommended Posts

  • Administrators
9 minutes ago, Thiago Henrique Santos said:

O sistema subiu mas meu wifi não encontra rede nenhuma.

se for dw1560 não funciona mais nativa, precisa de um pequeno patch

Link to post
Share on other sites
  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 Donation with ETH 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05 Donation with LTC MTmk

a verdade é uma. essas telas do s145 são ruins demais. estou com um da 10th Gen, é a mesma coisa. horrível.

-- Update - New folder for Big Sur Beta 5+ -- -Fix Trackpad "RiP" after wake -New minimal USB Injector -Last BIOS/UEFI version -New DSDT full patched from last BIOS/UEFI version

23 hours ago, MaLd0n said:

se for dw1560 não funciona mais nativa, precisa de um pequeno patch

Como verifico? Comprei aquela indicada pelo vídeo do Gabriel de Pinho no YouTube num video já meio antigo. Não sei exatamente o modelo. 

Acho que é BCM943224

EDIT: resolvi por enquanto instalando aqueles drivers de wifi para placa Intel. Funciona, mas é lento. Alguém recomenda uma placa ainda suportada e com bom desempenho?

Estranho que eu cheguei usar essa placa com o Big Sur antes. Mas agora ela parou, não sei se por alguma atualização nova ou por queimar, ou coisa assim.

 

EDIT 2: @MaLd0n notei outro probleminha aqui. Às vezes, ao reiniciar, a tela liga, o verbose do OpenCore aparece e quando vai pular pra parte gráfica a tela desliga. Daí tenho que desligar segurando o botão e ligar novamente. Não reinicio com frequência e o problema é só meio chato, mas se vc souber alguma cosia agradeço.

EDIT 3 (RESOLVIDO): O problema com minha BCM943224 foi resolvido. Encontrei um vídeo no Youtube que explicava como fazer. Pra quem precisar, segue o vídeo. O procedimento é super fácil.

 

Edited by Thiago Henrique Santos
Link to post
Share on other sites
20 minutes ago, Kadmiel said:

o CPU Friend Friend funciona com big sur e opencore?

Funciona sim. Você precisa incluir manualmente as kexts no config.plist do OpenCore. Dá para fazer usando o OpenCore configurator ou o ProperTree. 

Penso que via ProperTree é mais fácil, se você assistir o vídeo que postei acima ele mostra como usar o ProperTree.

Basicamente você joga as kexts do CPUFriend na pasta de kexts do OC e depois usa o ProperTree para incluir automaticamente na Config.plist. 

Estou usando o CPUFriend, com Opencore no Big Sur e tudo ok.

Link to post
Share on other sites
28 minutes ago, Thiago Henrique Santos said:

Funciona sim. Você precisa incluir manualmente as kexts no config.plist do OpenCore. Dá para fazer usando o OpenCore configurator ou o ProperTree. 

Penso que via ProperTree é mais fácil, se você assistir o vídeo que postei acima ele mostra como usar o ProperTree.

Basicamente você joga as kexts do CPUFriend na pasta de kexts do OC e depois usa o ProperTree para incluir automaticamente na Config.plist. 

Estou usando o CPUFriend, com Opencore no Big Sur e tudo ok.

desculpe a pergunta pode ser coisa boba. mais o que faço para incluir manualmente as kexts no config.plist. Os comandos no caso. nunca usei o opencore, e fazia um tempo que estava longe do mac

Link to post
Share on other sites
2 hours ago, Kadmiel said:

muito obrigado, vou estudar. Agradeço a atenção.

Vc pode usar o Opencore configurator pra montar a partição EFI do pendrive ou hd (é sempre bom ter uma no pendrive pra testes e, dando tudo certo vc cópia pro HD). Depois é só copiar as kexts pra pasta do Opencore. 

O link que o @MaLd0n mandou ajuda muito. Mas o vídeo que linkei tb mostra direitinho. O vídeo não é sobre o CPUFriend, mas todo o processo demonstrado no vídeo é muito parecido com o que vc vai ter que fazer. 

Link to post
Share on other sites
7 hours ago, Thiago Henrique Santos said:

Vc pode usar o Opencore configurator pra montar a partição EFI do pendrive ou hd (é sempre bom ter uma no pendrive pra testes e, dando tudo certo vc cópia pro HD). Depois é só copiar as kexts pra pasta do Opencore. 

O link que o @MaLd0n mandou ajuda muito. Mas o vídeo que linkei tb mostra direitinho. O vídeo não é sobre o CPUFriend, mas todo o processo demonstrado no vídeo é muito parecido com o que vc vai ter que fazer. 

Muito obrigado. Vou ver o vídeo também. Todo conhecimento é bem vindo. 

7 hours ago, Thiago Henrique Santos said:

Vc pode usar o Opencore configurator pra montar a partição EFI do pendrive ou hd (é sempre bom ter uma no pendrive pra testes e, dando tudo certo vc cópia pro HD). Depois é só copiar as kexts pra pasta do Opencore. 

O link que o @MaLd0n mandou ajuda muito. Mas o vídeo que linkei tb mostra direitinho. O vídeo não é sobre o CPUFriend, mas todo o processo demonstrado no vídeo é muito parecido com o que vc vai ter que fazer. 

eu fiz o procedimento todo certinho, como faço para ter certeza que esta funcionando nas configurações que configurei?

Link to post
Share on other sites
49 minutes ago, Kadmiel said:

Muito obrigado. Vou ver o vídeo também. Todo conhecimento é bem vindo. 

eu fiz o procedimento todo certinho, como faço para ter certeza que esta funcionando nas configurações que configurei?

Eu uso o Intel Power Gadgets pra verificar clock e temperatura. 

Joga no Google que ele aparece. Vc baixa donsite da Intel mesmo. 

Única coisa é que o Big Sur vai bloquear o programa. Quando ele abrir vai aparecer uma mensagem pra vc dar um comando no terminal, mas vc ainda vai ter que ir em ajustes -> segurança e autorizar o programa lá. 

Link to post
Share on other sites
2 hours ago, Thiago Henrique Santos said:

Eu uso o Intel Power Gadgets pra verificar clock e temperatura. 

Joga no Google que ele aparece. Vc baixa donsite da Intel mesmo. 

Única coisa é que o Big Sur vai bloquear o programa. Quando ele abrir vai aparecer uma mensagem pra vc dar um comando no terminal, mas vc ainda vai ter que ir em ajustes -> segurança e autorizar o programa lá. 

Obrigado, vou baixar e ir acompanhando 

Link to post
Share on other sites
On 1/27/2021 at 9:12 AM, Kadmiel said:

bom dia galera, estou voltando ao hackintosh. Gostaria de usar o bigsur, tenho o lenovo s145 com i5 8geração tela HD. @LeBaldi você ainda está com big sur na sua maquina?

Sim continuo usando ele, porém não atualizei ainda pro 11.1

On 1/28/2021 at 2:33 PM, MaLd0n said:

se for dw1560 não funciona mais nativa, precisa de um pequeno patch

Foi nessa ultima atualização Maldon? que isso mudou?

  • Like 1
Link to post
Share on other sites
  • Administrators
3 minutes ago, LeBaldi said:

Foi nessa ultima atualização Maldon? que isso mudou?

bigsur e acho que no último catalina 10.15.7. temos de usar a kext brcmfix e injetar dev id 43a0

  • Like 1
Link to post
Share on other sites
3 hours ago, LeBaldi said:

Sim continuo usando ele, porém não atualizei ainda pro 11.1

On 1/28/2021 at 2:33 PM, MaLd0n said:

entendi, estou estudando o lance de cpufriendfriend, consegui fazer funcionar mais ainda não achei um valor bacana. o pc ainda ta consumindo uma bateria meio alta, e esquentando. Tem alguma forma de ativar o cooler para a temperatura ficar baixa e não subir o clock muito alto para a bateria ficar com uma duração maior?

Link to post
Share on other sites

Bom dia,

Gostaria de tirar duas duvidas. existe como ativar o uso da GPU Nvidia MX 110 no Lenovo Ideapad S145 com hackintosh Big Sur? Segundo como particionei meu HD principal não estou achando onde colocar a pasta EFI para que o dual boot funcione sem o pendrive de instalação, conseguem me ajudar?

Link to post
Share on other sites
4 minutes ago, cleniolima said:

Gostaria de tirar duas duvidas. existe como ativar o uso da GPU Nvidia MX 110 no Lenovo Ideapad S145 com hackintosh Big Sur?

Infelizmente não.

 

4 minutes ago, cleniolima said:

Segundo como particionei meu HD principal não estou achando onde colocar a pasta EFI para que o dual boot funcione sem o pendrive de instalação, conseguem me ajudar?

A partição EFI não é montada no sistema. Você precisa usar um app que faça isso. No pendrive das imagens aqui do fórum tem uma pasta "files". Nela vc encontra o Clover Configurator e o OpenCore Configurator. Ambos conseguem montar a pasta EFI. 

Pelo Opencore Conigurator quando você abre o programa ele coloca um ícona na tray, próximo ao relógio. É só clicar nesse ícone e escolher a partição EFI da sua HD.

Link to post
Share on other sites

@LeBaldi boa noite parceiro, quais configurações do voltageshift me recomenda para economia de bateria. E lembro que você algum tempo atrás comentou sobre uma pasta termica, qual é a que usou tenho que trocar a do meu notebook. obrigado desde já.

Link to post
Share on other sites
9 hours ago, Josinei Araujo said:

My trackpad stops working after the hackintosh wakes up. Please help me!

That's is a know issue without a fix for now. 

12 minutes ago, Kadmiel said:

@LeBaldi boa noite parceiro, quais configurações do voltageshift me recomenda para economia de bateria. E lembro que você algum tempo atrás comentou sobre uma pasta termica, qual é a que usou tenho que trocar a do meu notebook. obrigado desde já.

Aqui vou um pouco de teste. Cada sistema tem suas particularidades, mesmo quando os processadores são do mesmo tipo. 

Vá testando, reduzindo aos poucos. Acho seguro reduzir o core pra -150 e a gpu pra -50, depois ir puxando pra baixo de 10 em 10 ou 15 em 15. O mais instável é o cpu cache. Acho que -50 tb deve ser seguro pra ir testando. Aqui (s145 com i7 de 8th geração) eu não consigo reduzir o cache pra além de -100, sendo o valor mais estável -90. 

Se não me engano o @LeBaldi usou um Artic MX-4. Eu usei essa aqui, ótimo resultado. 

9 hours ago, KaioApeles said:

After installation, my mackintosh is rebooting, any tip? 

 

Opencore or Clover? Are you using the newest EFI folder that @MaLd0n posted?

Link to post
Share on other sites
On 31/01/2021 at 8:41 AM, Thiago Henrique Santos said:

Infelizmente não.

 

A partição EFI não é montada no sistema. Você precisa usar um app que faça isso. No pendrive das imagens aqui do fórum tem uma pasta "files". Nela vc encontra o Clover Configurator e o OpenCore Configurator. Ambos conseguem montar a pasta EFI. 

Pelo Opencore Conigurator quando você abre o programa ele coloca um ícona na tray, próximo ao relógio. É só clicar nesse ícone e escolher a partição EFI da sua HD.

Bom dia, muito obrigado fiz o procedimento, mas acho que cometi um erro ao inves de mesclar a pasta EFI do windows com a do BigSur sibstitui agora não aparece o windows como opção de boot, tem como corrigir alguem consegue me ajudar?

  • Like 1
Link to post
Share on other sites
1 hour ago, cleniolima said:

Bom dia, muito obrigado fiz o procedimento, mas acho que cometi um erro ao inves de mesclar a pasta EFI do windows com a do BigSur sibstitui agora não aparece o windows como opção de boot, tem como corrigir alguem consegue me ajudar?

Cagada corrigida com o modo recovery do windows e comandos no prompt de comando

  • Like 1
Link to post
Share on other sites
Há 18 horas Thiago Henrique Santos disse:

Esse é um problema conhecido, sem solução por enquanto. 

Aqui vou um pouco de teste. Cada sistema tem suas particularidades, mesmo quando eles são definidos do mesmo tipo. 

Vá testando, existem aos poucos. Acho seguro reduzir o core pra -150 e a GPU pra -50, depois ir puxando pra baixo de 10 em 10 ou 15 em 15. O mais instável é o cache da cpu. Acho que tb deve ser seguro pra ir testando -50. Aqui (s145 com i7 de 8ª geração) eu não consigo reduzir o cache pra além de -100, sendo o valor mais estável -90. 

Se não me engano o @LeBaldi comprou um Artic MX-4. Eu usei essa aqui, ótimo resultado. 

Opencore ou Clover? Você está usando a pasta EFI mais recente que@ MaLd0n publicado?

o meu já estou usando um valor baixo. CPU -200, GPU -60, Cache -90. Então to pensando que o calor pode ser por conta da pasta termica já estar ruim. Não consigo ficar para da tomada por muito tempo (4 horas no maximo), isso com turbo power transformar por cima ainda. Intel Core i5 8265U

Edited by Kadmiel
Link to post
Share on other sites
  • MaLd0n changed the title to Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap