Jump to content

AppleHDA Patcher General Discussion


Recommended Posts

a3dc38713045d1ae3e226bb91e582bcc_1024.png

 

Download the application 

 

This topic has the purpose of discussing problems

related to the Application AppleHDA Patcher, such as difficulty in

use it or some error found, requests patch for some codec specified will be ignored and deleted , there is less that the same is a completely different version from that found in the application, questions off topic will be deleted without notice.

Suggestions for improvements to the application are welcome.

 

Only English language here.

  • Like 2
Link to post
Share on other sites
  • 4 weeks later...
  • Replies 144
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Download the application    This topic has the purpose of discussing problems related to the Application AppleHDA Patcher, such as difficulty in use it or some error found, reques

Posted Images

i am using IDT92HD87B2/4 (111D:76D9) before mojave i used to use layout id=3 but now i see that on mojave that layout had been depreciated. my question is, is there a workaround to get audio in 10.14?


NB: i saw the patch of your beautiful APPLEHDA PAtcher but it didn't do justice.

Link to post
Share on other sites

Hello Guys!

Thank you for providing the patcher! I used it on high Sierra, however I struggle now on Mojave after clean install. I use modified plist and dummy kext (or try to use) but it doesn't work. Layout id 2 is injected, but as seen in screenshot id 8 is set. I noticed that my appleHDA itself is not loaded (HPET fix already tried)

AppleHDAController and AppleHDAHardwareConfigDriver are however loaded. I don't know what to do.

Appreciate any help.

all my files are in zip

debug_22822.zip

1185493671_Screenshot2018-10-27at01_43_36.png.1f66c20dbd81ea04f26d34a68782d840.png

Link to post
Share on other sites

Hi

I install the aDummyHDA.kext, and patch the config file, inject the layout id 3, it works in the 10.13.6.

But when I come to upgrade to macOS Mojave 10.14. The audio fails.

Here is my config file and IO.

Any ideas, thank you very much in advance.


Best Regards,

 

Hi!


As what I know, layout 3 is not supported anymore in Mojave. You have to switch to layout 2


Greetings

Link to post
Share on other sites
  • 3 weeks later...

Hi,

Thanks for your app.

I tried to make audio work on Mojave 10.14 without success I tried many thing it just does not work.

could you help me fix it .

it's an ALC236

i'm attaching my config.plist + codec_dump .

here is what I tried and did not work :

- install full patched AppleHDA + HDAenabler . set audio layout-id=2 .

- install aDummy to /S/L/E + config.plist + native AppleHDA

-full patched AppleHDA + DSDT patched .

none of them works.

I tried AppleALC it did not work either

I tried VooodooHDA only the headphone Worked .

Thanks in advance .

edit:forgot to attach Ioreg

Linux_codec0_dump.txt

config.plist.zip

IOREG.zip

Link to post
Share on other sites

[ref]bahha[/ref], u try a applealc? u have some options

MaLd0n 2018-11-13 às 18.33.10.png

thanks,

I already tried AppleALCwith different layout-ids. it didn't work.

thought hda patcher would fix it.

since when I use the full patched AppleHDA It shows the correct device id in ioreg. with AppleALC the AppleHDA does not get loaded.

Link to post
Share on other sites
  • 3 weeks later...

Hi all,


Can you please help me with the AppleHDA patcher v1.9? I installed it on my Capitan to patch ALC255, but when i run it i get only a blue mountain screen without patch options. Please help me getting the patch options. As i understand there should be a laptop, desktop and jarvis option in the AppleHDA patcher window.


Thanks in advance!!!

Link to post
Share on other sites

Installed Mojave and managed to open applehda 1.9. followed the instructions but still no sound. did the clover install and put both aDummyHDA.kext and CodecCommander.kext in S/L/E Folder. updated clover plist restart but still no audio device. Attached jarvis dump wit ioreg an clover plist ( all in the zip). can you guide me through?

jarvis.zip

Link to post
Share on other sites

[ref]Mirone[/ref], [ref]MaLd0n[/ref], Hi, my audio still not working after applying AppleHDA.kext patched and HDAEnabler.kext to S/L/E and tried clover method too but aDummyHDA does not get loaded after booting when using Clover method, my audio is ALC256 i can use AppleALC for audio but the microphone is not working with AppleALC, please give me solution and feedbck sir, thanks in advance

Send me Dekis-MBP.zip

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker and Support Our Forum-:cap