Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
MaLd0n

Hackintosh Guide - Sierra / High Sierra / Mojave / Catalina on Sky/Kaby/CoffeeLake Notebooks with Clover Bootloader

Recommended Posts

não tem patch no dsdt pro wifi

DSDT.aml.zip

 

Para o Wifi sei que não, mas ele está funcionando perfeitamente bem, o problema está no Brilho que não funciona mais, nem com esta DSDT que vc mandou agora, esta bem estranho, pois antes de o Wifi funcionar ele funcionou bem. De qual quer forma muito obrigado pela ajuda.

Share this post


Link to post
Share on other sites

Para o Wifi sei que não, mas ele está funcionando perfeitamente bem, o problema está no Brilho que não funciona mais, nem com esta DSDT que vc mandou agora, esta bem estranho, pois antes de o Wifi funcionar ele funcionou bem. De qual quer forma muito obrigado pela ajuda.

BRIGHTNESS.zip

Share this post


Link to post
Share on other sites
BRIGHTNESS.zip

 

Então tivemos uma evolução, vou explicar o que fiz...

Instalei a kext na pasta do clover, joguei a DSDT-PNLF na pasta do patch, e joguei os dados do txt dentro da config.plist e sucesso, porem desativou o WIfi novamente, to achando que ta rolando um conflito ou estou fazendo alguma besteira.

Share this post


Link to post
Share on other sites

Então tivemos uma evolução, vou explicar o que fiz...

Instalei a kext na pasta do clover, joguei a DSDT-PNLF na pasta do patch, e joguei os dados do txt dentro da config.plist e sucesso, porem desativou o WIfi novamente, to achando que ta rolando um conflito ou estou fazendo alguma besteira.

essa kext do brightness use na pasta library/extensions


nunca me deparei com esse erro, bem estranho

Share this post


Link to post
Share on other sites

essa kext do brightness use na pasta library/extensions


nunca me deparei com esse erro, bem estranho

 

Rapaz, se você que é catedrático em hackintosh eu só tenho a chorar :cry::cry: Nem sei mais o que fazer, tentei até jogar o conteúdo da "DSDT-PNLF" dentro da DSDT.aml mas nada adiantou...

Share this post


Link to post
Share on other sites

Rapaz, se você que é catedrático em hackintosh eu só tenho a chorar Nem sei mais o que fazer, tentei até jogar o conteúdo da "DSDT-PNLF" dentro da DSDT.aml mas nada adiantou...

o seu dsdt não tem o device de vídeo @2, ele está em uma ssdt OEM, vc pode usar essa ssdt sem problemas, talvez seja um conflito de teclas da kext voodoops2, não?

Share this post


Link to post
Share on other sites

o seu dsdt não tem o device de vídeo @2, ele está em uma ssdt OEM, vc pode usar essa ssdt sem problemas, talvez seja um conflito de teclas da kext voodoops2, não?

 

Então não sei se chega a ser isso pois se tiro o DSDT-PNLF de lá ele habilita o Wifi e desabilita as teclas de brilho, se coloco ele desabilita mas habilita as teclas de brilho e desabilita o Wifi, por exemplo agora voltei ao conteúdo original da DSDT.aml original, mantive os parâmetros do txt no config.plist e mantive a kext nas pastas do clover e na library/extensions e o wifi voltou a funcionar mas as teclas do brilho nada... cara to ficando doido com isso kkkk to quase te pedindo pra conectar no teamvier e ver se to fazendo merda kkkk, mas seria mta petulância da minha parte... rs


E em usar somente esta DSDT-PNLF sozinha sem a outra, acontece a mesma coisa, desabilita o wifi e o brilho ok! =/

Share this post


Link to post
Share on other sites

tenta com o pnlf do próprio clover

 

Mano, desisto de verdade, vlw mesmo a ajuda mas não consigo mais nem pensar, to desde quarta tentando fazer isso! :oops:


Pedi por mensagem inbox ao @ultraman se ele pode me passar um bkp da maquina dele (DSDT, Kexts...) para ver onde estou errado, pq to ficando louco já rs. Se eu tiver algum sucesso eu posto depois.

Share this post


Link to post
Share on other sites
MACH Reboot
I had the same problem. It was caused by the Lapic Kernel (it tells you this just at the end screen ["thread already waiting on 0xffffff8113680810"@/BuildRoot/.....osfmk/i386/lapic_native.c:776]) because my notebook is also HP with 81EE motherboard. Tried to do things with "cpus=1" boot argument, dropping tables with MATS signature and whatnot. However, this only allowed me to boot into the system but trackpad and keyboard didn't work and I couldn't get past the install screen.


Then I followed this guide (from Windows using Win32DiskImager to put the image onto my USB and then transferred to VMware Sierra to install the EFI partition using Clover) and now everything (audio, Intel graphics 620, keyboard, trackpad) is fine expect for the fact that I have to buy the USB Wi-Fi adapter because Realtek RTL8723BE 802.11 bgn Wi-Fi adapter doesn't work on Hackintosh.

Share this post


Link to post
Share on other sites

Hey Maldon, New laptop. Almost all is working except battery shows "not installed" and Display Brightness Crashes when touched. Attached are my debugging file. Your help would be most appreciated

Attachments

Send me Pauls-MacBook-Pro-111.zip

(4.99 MiB) Not downloaded yet

Dell Inspiron 7559 i7-6700HQ, HD 530/Nvidia 960M, 3840x2160 4K, Touch

16 GB 1600Mhz, 480GB SSD, Windows 10 Prox64/Mojave 10.14, CloverUEFI

DSDT.aml.zip

battery check rehabman repo

battery use patch in config.plist+kext, u can remove ssdt pnlf, have patch in dsdt

Share this post


Link to post
Share on other sites

DSDT.aml.zip

(31.4 KiB) Downloaded 1 time

battery check rehabman repo

battery use patch in config.plist+kext, u can remove ssdt pnlf, have patch in dsdt

 

Awesome! System Boots with this DSDT. PCI devices all show. Battery still shows 0% Trackpad works but does not show in system preferences. What patch do i need in my config for battery? Im currently using the usual ACPIBatteryManager.kext. Sorry for my ignorance..

1803531067_ScreenShot2018-09-29at12_52_49PM.thumb.png.749321e7ef9b201c3a7048b28a30fa74.png

config.plist.zip

Share this post


Link to post
Share on other sites

Well i seemed to get battery status working. Rehabs patch for dsdt seemed to work. Battery now shows charging correct info. Only thing left is brightness. I can see the brightness display scale in system preferences, But if i try to click on the slider the screen goes black instantly and its not easy to get back working again lol. Nor does the display brightness keys on my keyboard work. Keyboard backlighting work fine. Any ideas?

Share this post


Link to post
Share on other sites

@Maldon ,

I have a new Dell 5570 (intel 15-8250u, Intel UHD 620, 8gb ram ,QUALCOMM QCA9377 wifi/bt).

Can you help me with ddst, ssd and clover folder , please?

Thanks in advance.

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Also , what SMbios should I use?

 

Id use MacBookPro 14,1 for your SmBios. I have a dell with almost that same setup and never could get QE/CI to work with my UHD620. Mine has the i7 8550u is the only difference. Anyways i wish you luck :)

Share this post


Link to post
Share on other sites

Can you recheck ?

No audio , no bridgness slider.


Also , what SMbios should I use?

Attachments

Send me Mac-Dell.zip

(3.42 MiB) Not downloaded yet

@MaLdOn ?

Share this post


Link to post
Share on other sites

The computer screen stops here: +++++++++++. Please help me!

Dell Vostro 5568

CPU: Intel Core i5-7200U

GPU: Nvidia Geforce 940MX

IMG_20181001_005708.thumb.jpg.7087507e64bb286f799631a525af81a5.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...