Jump to content
oldnapalm

Drivers para nVidia GeForce

Recommended Posts

Muitos perguntam onde baixar kexts para placas de vídeo nVidia, a resposta é que elas já estão instaladas, fazem parte do Mac OS X. O problema é que elas não foram carregadas porque a placa não foi reconhecida.


Para que a placa seja reconhecida é necessário injetar algumas propriedades nela. O bootloader Chameleon faz isso automaticamente, basta ativar a opção GraphicsEnabler e configurar o PciRoot (apenas se não for zero).


No arquivo org.chameleon.Boot.plist

	<key>GraphicsEnabler</key>
<string>Yes</string>
<key>PciRoot</key>
<string>1</string>

 

Para saber o valor correto do PciRoot rode no terminal

ioreg -l | grep -15 "AppleACPIPCI\ " | grep UID

 

Você pode usar o Chameleon Wizard

http://Olarila.com/forum/viewtopic.php?f=9&t=398



Existem kexts para isso (NVenabler, NVinject, EvoEnabler, entre várias outras) mas elas fazem a mesma coisa, injetam propriedades, elas não são os drivers em si.

http://www.projectosx.com/forum/index.php?showtopic=370



Também é possível passar as propriedades manualmente para o Chameleon.


No arquivo org.chameleon.Boot.plist

	<key>device-properties</key>
<string>[hexadecimal EFI string]</string>

 

Para obter as propriedades injetadas automaticamente pelo Chameleon rode o comando

ioreg -lw0 -p IODeviceTree -n efi -r -x | grep device-properties | sed 's/.*<//;s/>.*//;' > device-properties.hex

 

Para converter o arquivo device-properties.hex (hexadecimal EFI string) para plist (property list file) você pode usar o GFXUtil (http://forum.netkas.org/index.php?topic=64.0)

gfxutil -s -n -i hex -o xml device-properties.hex device-properties.plist

 

Também pode usar o OSX86Tools (http://code.google.com/p/osx86tools/).


O OSX86Tools também pode ser usado para criar uma EFI string.



Outra forma de injetar as propriedades é pela DSDT, veja nesse tópico

http://Olarila.com/forum/viewtopic.php?f=7&t=39



Para algumas placas pode ser necessário adicionar o device ID nas kexts NVDAResman, NVDANV40Hal (séries 6xxx e 7xxx), NVDANV50Hal (série 8xxx em diante) e NVDAGF100Hal (série 4xx em diante).


Edite o arquivo Info.plist das kexts e adicione o ID da sua placa (0xDeviceIDVendorID) na chave IOPCIPrimaryMatch ou IOPCIMatch

IOPCIPrimaryMatch
0x[color=#FF0000]06e4[/color][color=#008000]10de[/color]

 

Como encontrar o device ID

http://Olarila.com/forum/viewtopic.php?f=6&t=25


Como editar o Info.plist

http://Olarila.com/forum/viewtopic.php?f=3&t=69

Link to comment
Share on other sites

AMIGO, JA TENTEI DE TUDO E NÃO CONSIGO INSTALAR MINHA PLACA GEFORCE 8400 GS, TEM COMO ME AJUDAR?


MINHA PLACA MÃE É Intel Buffalo Creek DG33BU TENHO VARIAS VERSÕES DO MAC OSX


ATUALMENTE ESTOU COM A 10.6.3


PRECISO DA RESOLUÇÃO 1280 X 800 PARA O FINALCUT.


DESDE JA AGRADEÇO.

Link to comment
Share on other sites

Olá

Amigo, não consegui :cry:

Um dos quadros (opções) "GENERAL", que vc descreve no inicio da sua explicação (do programa que vc indicou para usar)não aparece no meu programa

Vou te enviar um anexo, do relatório da minha placa mãe - Se for possível, após vc ler o relatório da minha placa, vc me enviar uma imagem com as opções da instalação do MAC 10.6.3 ficarei imansamente grato.....

http://www.4shared.com/document/kbPkWIZJ/relatorio_da_placa.html



Tem como falar com vc, por outro método? fone, msn, e-mail


Obrigado

Link to comment
Share on other sites

Nao estou conseguindo fazer o Snow Leopard reconhecer minha GTX560Ti, teria como alguem me ajudar?

Instale os drivers Fermi (link no primeiro post), uma versão recente do Chameleon RC5 e use o GraphicsEnabler.


lizard.png


Na seção downloads tem o Chameleon e o Lizard.

Link to comment
Share on other sites

nada.... só entro no sistema com o cd de boot, quando tento pelo chameleon trava na tela cinza com o logo da apple, e quando entro com -v carrega algumas coisas e logo depois a tela fica preta.

configuracao:


MOBO ASROCK P67 EXTREME6 B3

CPU I7 2600K (over 4.0/4.5/5.0)

MEMÓRIA 2X4GB G.SKILL RIPAJAWS-X 1600MHZ

HD 1TB WD BLACK CAVIAR SATAIII 64MB

VGA GTX 560Ti

Link to comment
Share on other sites

Possuo placa de video geforce 8400 gs (nvidia), por[em, alguns aplicativos que tenho instalado ocorre mensagem como essa :


The installed graphics card does not meet the minimum requirements for Aperture.Ou seja:

A placa gráfica instalada não atende os requisitos mínimos para o Aperture.


Teriam o drive dessa placa?

Link to comment
Share on other sites

  • Administrators
o que chama de método?

 

método

s. m.

s. m.

1. Ordem pedagógica na educação.

2. Tratado elementar.

3. Processo racional para chegar a determinado fim.

4. Maneira de proceder.

5. Processo racional para chegar ao conhecimento ou demonstração da verdade.

6. Obra que contém disposta numa ordem de progressão lógica os principais elementos de uma ciência, de uma arte.

7. [Figurado] [Figurado] Prudência; ponderação.

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

aplausos ! rsrsrs :D / O fato é que continua com o mesmo erro mencionado acima e quando perguntei sobre método, não esperava uma TAMANHA intolerancia a um leigo ! Pois, além de estar iniciando no processo, imaginei que poderia haver outro procesimento para que erro acima mencionado pudesse ser resolvido ! De qq forma felicito os expert no assunto e na falta de tolerancia ! É por isso que nosso país está uma maravilha, sabemos significados disso ou daquilo, mas não sabemos votar !

Link to comment
Share on other sites

  • Administrators
aplausos ! rsrsrs :D / O fato é que continua com o mesmo erro mencionado acima e quando perguntei sobre método, não esperava uma TAMANHA intolerancia a um leigo ! Pois, além de estar iniciando no processo, imaginei que poderia haver outro procesimento para que erro acima mencionado pudesse ser resolvido ! De qq forma felicito os expert no assunto e na falta de tolerancia ! É por isso que nosso país está uma maravilha, sabemos significados disso ou daquilo, mas não sabemos votar !

basta vc ler o primeiro post e usar uma das "Maneira de proceder"=Método ou nos dizer qual método vc usou, vc que entendeu errado

Não tem mistério


e em relação ao Brasil...tá uma merda pq nem os presidentes sabem ou não gostam de ler

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

o que chama de método?

Antes de reclamar de falta de tolerância ou divagar sobre a situação do país, veja o que você está perguntando. Se ler o tópico vai perceber que são mostradas várias formas de ativar os drivers de vídeo. Eu perguntei qual delas você usou. Se não usou nenhuma, acho que a pergunta inicial está respondida.

Link to comment
Share on other sites

Pessoal, estou com um novo Hackintosh, acabei de fazer a instalação, mas o sistema sobe somente em "Safe Mode", minha máquina é um Pentium G6950, mobo DFI MI P55-T36, VGA 9500 GT, acredito ser um problema entre o GraphicsEnabler e o NullCPUPowerManagement, mas não consegui testar, alguma idéia?


Abraço


alfalco

Link to comment
Share on other sites

Em safe mode os drivers de vídeo não são carregados. Tente fazer boot normal (sem -x) com verbose (-v) e veja qual o erro.

 

Obrigado pelo retorno oldnapalm!


Em modo verbose o boot fica parado em uma tela preta, com uma faixa branca de uma linha, do lado esquerdo superior no monitor.

Estou testando outras versões do Chameleon para tentar resolver, obrigado novamente.


Abraço.


alfalco

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...