Jump to content
Guest plckdck

HDMI não funciona na Intel HD 620

Recommended Posts

Guest plckdck

Aqui está um exemplo de alguém ter tido sucesso com o meu equipamento, o Dell Inspiron 5378, usando Clover, e lá existe uma pasta EFI inclusive.

https://www.tonymacx86.com/threads/guide-dell-inspiron-13-5378-2-in-1-macos-10-12-6.230009/

Foram seguidos as seguintes dicas para correção, porém não funcionaram:

https://dortania.github.io/OpenCore-Post-Install/gpu-patching/intel-patching/connector.html

Nestas dicas eles citam a chave "PciRoot(0x0)/Pci(0x2,0x0)" que não existe no meu config.plist, então adicionei essas chaves manualmente. O trecho do meu config.plist está no zip em anexo.

Captura de Tela 2021-02-14 às 17.05.06.zip

Captura de Tela 2021-02-14 às 17.24.36.zip

OpenCore 0.6.6

Link to comment
Share on other sites

6 hours ago, plckdck said:

Aqui está um exemplo de alguém ter tido sucesso com o meu equipamento, o Dell Inspiron 5378, usando Clover, e lá existe uma pasta EFI inclusive.

https://www.tonymacx86.com/threads/guide-dell-inspiron-13-5378-2-in-1-macos-10-12-6.230009/

Foram seguidos as seguintes dicas para correção, porém não funcionaram:

https://dortania.github.io/OpenCore-Post-Install/gpu-patching/intel-patching/connector.html

Nestas dicas eles citam a chave "PciRoot(0x0)/Pci(0x2,0x0)" que não existe no meu config.plist, então adicionei essas chaves manualmente. O trecho do meu config.plist está no zip em anexo.

Captura de Tela 2021-02-14 às 17.05.06.zip 51.85 kB · 2 downloads

Captura de Tela 2021-02-14 às 17.24.36.zip 150.58 kB · 4 downloads

OpenCore 0.6.6

Usou o Hackintool para gerar o seu patch de video? E sim a localização do seu patch de video é no endereço PciRoot(0x0)/Pci(0x2,0x0). Dê uma olhada no seguinte link.

-Mobile Video Solution - https://tinyurl.com/y954utg3

OS: macOS Big Sur 11.1 (20C69) - Dell Inspiron 5468 - Processador: i5 7200U 2.5ghz - Mem: 8 GB DDR4 - SSD: 240 GB - Big Sur - SSD: 120 GB - Windows 10 - Rede: Realtek RTL8102E - Vídeo: Intel HD 620 Full+HDMI audio- WiFi: Dell DW1020a (Broadcom)

OpenCore Vanilla Guide - https://tinyurl.com/ycvcnp8h  

Clover Vanilla Guide - https://tinyurl.com/ydhgntcz

EFI folders for all Chipsets - https://tinyurl.com/ybr968w3 

Olarila Vanilla Images - https://tinyurl.com/y3vz4z6x

 

Link to comment
Share on other sites

Guest plckdck

Usei o Hackintool pra consultar na guia PCI e vi que essa GPU fica nesse endereço, só que alimentando o config.plist não resolveu!

O link "Mobile Vídeo Solution" que você colocou aponta para o mesmo tópico em que estamos, tem como mandar o de exemplo certo?

Link to comment
Share on other sites

  • Administrators

qual a geração do processador?

 

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

use smbios macbookpro14,1 e esse patch

Quote

<key>PciRoot(0)/Pci(0x02,0)</key>
<dict>
<key>AAPL,ig-platform-id</key>
<data>AADAhw==</data>
<key>device-id</key>
<data>FlkAAA==</data>
<key>framebuffer-con1-alldata</key>
<data>AQUJAAAIAACHAQAA</data>
<key>framebuffer-con1-enable</key>
<data>AQAAAA==</data>
<key>framebuffer-con2-alldata</key>
<string>&lt;02040a00 00080000 87010000&gt;</string>
<key>framebuffer-con2-enable</key>
<data>AQAAAA==</data>
<key>framebuffer-fbmem</key>
<data>AACQAA==</data>
<key>framebuffer-patch-enable</key>
<data>AQAAAA==</data>
<key>framebuffer-stolenmem</key>
<data>AAAwAQ==</data>
</dict>

 

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Guest plckdck

Funcionou!! ;-)

A SMBIOS já estava macbookpro14,1!

Só notei um problema, como que o monitor não é detectado desde a inicialização, é necessário fazer o login pela tela do notebook.

Obrigado!:)

 

Link to comment
Share on other sites

  • Administrators

adiciona igfxonln=1 e agdpmod=vit9696

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

On 2/16/2021 at 1:37 PM, MaLd0n said:

adiciona igfxonln=1 e agdpmod=vit9696

olá Mald0n.. esse códigos vão no junto com os parmetros (<key>PciRoot(0)/Pci(0x02,0)</key>
<dict>) na linha de comando ou vão na SMbios? onde colocamos  -v alcid=1 .....

Link to comment
Share on other sites

  • Administrators
11 hours ago, safsprin said:

Usei aqui e funcionou a HDMI no notebook Dell 5378, porém a TV 4K não fica em resolução máxima, somente em 1080 😕

-cdfon

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

4 hours ago, MaLd0n said:

-cdfon

Infelizmente não funcionou, mas não me preocupo com isso. Raramente uso a função, foi só pra testar a HDMI mesmo.

O que observei é: se o HDMI Ultra HD Deep color está ativo na tv (CX 55"), aparece a resolução de 2560x1080 (muito ruim, imagem estranha). Se desativo, aparece 1080p e com possibilidade de ativar os 120Hz (o que já está ótimo).

Link to comment
Share on other sites

On 4/4/2021 at 1:22 PM, safsprin said:

Infelizmente não funcionou, mas não me preocupo com isso. Raramente uso a função, foi só pra testar a HDMI mesmo.

O que observei é: se o HDMI Ultra HD Deep color está ativo na tv (CX 55"), aparece a resolução de 2560x1080 (muito ruim, imagem estranha). Se desativo, aparece 1080p e com possibilidade de ativar os 120Hz (o que já está ótimo).

Checa se nas propiedades da placa de video "<key>PciRoot(0)/Pci(0x02,0)</key>" (na patch, tipo na que o maldon mandou) ta com enable HDMI 2.0

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...