Jump to content
ūüéČ [ IMPORTANT ] Premium and Donators users ūüéČ √ó

Olarila HackBeast Z490 VISION D - Thunderbolt - Full DSDT patches - Clover or OpenCore - Guide and Discussion


Recommended Posts

  • Administrators

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX¬†@[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

 

A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements. 

 

- Useful Links -
https://tinyurl.com/43t5m6d4

 

-OpenCore Vanilla TUTORIAL-

 

 

-USB Port Mapping TUTORIAL-

 

 

-Bios/UEFI Settings-

Serial Port = Disable

CFG Lock = Disable

-Thunderbolt Configuration-

Security Level - No Security

GPIO3 Force Pwr - Enabled

 

-Hardware-

Mobo - Ga Z490 Vision D

https://tinyurl.com/y4gajha4


Processor - i7 or i9 10th Intel

https://tinyurl.com/y6jlskwz


GPU - RX 580, 590, VEGA 56, VEGA64, 5700XT or RADEON VII
https://tinyurl.com/y4mxc7t6


Cooler - SCYTHE Ninja 5 

https://tinyurl.com/yyrbx5lf


NVME - WD Black SN750 NVMe SSD
https://tinyurl.com/vnq46yr

 

-EFI folders- 

https://tinyurl.com/ybr968w3

 

Paste EFI folder into EFI partition, reboot and extract one SendMe. Post this dump here for full ACPI solution!

Download RunMe.app dumper

 

-DSDT Patches-

Quote

-FIX ACPI ERRORS

-REMOVE UNUSED SCOPES / DEVICES

-HIGH PRECISION EVENT TIMER

-SATA

-DMAC

-REMOVE PROBLEMATIC AND UNUSED DEVICES

-FIX K.P in REBOOT

-SLPB

-DARWIN / WINDOWS 2015

-XHCI

-PLUGIN TYPE

-HDEF

-REAL TIME CLOCK

-ARTC

-IRQs

-SBUS

-BUS1

-MCHC

-ALS0

-SHUTDOWN

-LAN

-FWHD

-USBX

-PMCR

-XSPI

-CNVW

-IMEI

-EC

-PNLF

-ARPT

-GFX0

-NVME

-DTGP

-HDMI / HDAU

 

-Screenshots-

2MRZbCC.png

7H3bhTD.png

OH1QQZN.png

HAO1mpK.png

VGq2fSR.png

6uaY1Bh.png

EXkcWfI.png

A0SZQYh.png

iLEjszW.png

bQw0vGz.png

KltktNo.png

QinwZrc.png

7WKKgcf.png

IKKuA1V.png

o0dtnxJ.png

ezlIIoy.png

Fi2lykR.png

0uBvKFV.png

c7USqbd.png

73cjKaf.png

kZjrvhd.png

LSpj6lv.png

QxFXr0B.png

OoqTQKY.png

oOTB4bb.png

dLmg3kt.png

zu4ddVI.png

YlZNNPc.png

2pZg8Jr.png

qPt9Nx7.png

6vXFdZd.png

 

-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!

Thx to KGP for SSDT Thunderbolt

Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!


We're all here to have fun and learn from each other!

 

  • Like 2

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Cool one Silly question if the iGPU is enable then why its not showing in Graphics/Display even i have seen it in several build such as.

HackBook Pro :-HP DV6-6121 TX (Win 10 Pro + macOS 10.13.6 + OC )

Hac Pro:-GA-B365-D3H, Core i5 9440F AMD RX 580 8 GB (Win 10 Pro + macOS 10.15.7 + Big Sur Beta )

Hac Pro:-z97 sabertooth mark 2, Core i7- i7 4790k with GT 740 2GB and 32 GB Ram (OC+Catalina)

iHack:- Assus M2N68-AM-SE2,AMD Athlon+LE-1640,250 SSD ,4GB DD3 800MHZ Nvidia 9400GT (win 10 and 10.9.5+10.10.5)

iHack:-GA875M-D3H ,core-i5 3250,NVDIA 610-2GB 27"LED,8GB DDR3 1600mhz, (Only 10.10.5+10.11.6 with CLOVER)

iHack:-GA-78LMT-S2PT ,AMD Phenom II-X2 560,Radeon 6770 1 GB ,onboard Radeon HD 3000 not tested 4 GB DDR-3 1333 MHZ (10.11.6+Win 10 pro) Special thanks....  To Genius donovan6000 For Mode Bios (WiFi +BT Whitelist removed) & Amazing Hackintosh Guides and tutorial and much more visit this blog Hackintosh Mumbai

Link to comment
Share on other sites

  • Administrators
37 minutes ago, matpratik said:

Cool one Silly question if the iGPU is enable then why its not showing in Graphics/Display even i have seen it in several build such as.

if appears there is wrong. ;) 

yM8cWoR.png

  • Thanks 1

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

Enjoy, @eric76

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • 2 weeks later...

Hi Maldon , im using your efi folder and patched dsdt , everything seems to work fine, do I need more ssdts in my ACPI folder ?

i have attached the " send me" zip file

also, do you know why the Thunderbolt says "No drivers are loaded".  ? i dont have any thunderbolt devices, just want to know if this is normal

my board is the same in this post Gigabyte Z490 VISION D

any help will be greatly appreciated

here is the zip file in google drive . the olarilla website only letme upload 2.93MB i dont know why so here is a link in google drive , thank a lot

https://drive.google.com/file/d/1iuGSuO7_7is21GjErvh9GhAM797keRwa/view?usp=sharing

Link to comment
Share on other sites

  • Administrators
4 minutes ago, iaksakkah said:

Hi Maldon

no. u dont need any ssdt. ssdt is not full solution and here we avoid it

ur config looks very fine

is common in thunderbolt, but work fine with hotplug etc

change ur smbios to imacpro or enable internal graphics

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Thanks for the quick reply Maldon i will change smbios to imacpro, i just realized that my onboard audio does not work :( i was using Audio tru Display port but when i change the the output to the internal audio it does not work, maybe if a change smbios to macpro it may work, i will post the results , thank again Maldon

Link to comment
Share on other sites

  • Administrators

ok

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

hi maldon me again very happy with results just one problem the dsdt. aml needs to be in the ACPI folder? windows does not boot with this file, if i press F12 and select the windows drive it boots fine, if i remove the file it boots fine, but with this file¬† it does boot, i get a ACPI BIOS ERROR, and it does not boot, it boots fine if i press F12 but will not boot with OC bootloader ūüėĒany ideas??¬†

Link to comment
Share on other sites

  • Administrators
41 minutes ago, iaksakkah said:

hi maldon me again very happy with results just one problem the dsdt. aml needs to be in the ACPI folder? windows does not boot with this file, if i press F12 and select the windows drive it boots fine, if i remove the file it boots fine, but with this file¬† it does boot, i get a ACPI BIOS ERROR, and it does not boot, it boots fine if i press F12 but will not boot with OC bootloader ūüėĒany ideas??¬†

opencore dont drop edited tables, smbios, quirks, if u need a full solution with dsdt, for now need use a bootkey f12 or use a ssdt olarila with partial solution ;)  work good too but no full, never

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators
4 minutes ago, egroys said:

Do we need an SSDT for an RX 5700 in clover?

use radeonboost. easy way

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • 2 weeks later...
  • Administrators
6 hours ago, JLC said:

Could you please post the bios parameters and efi if we just want to use internal graphics?

Quote

            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>AAPL,ig-platform-id</key>
                <data>BwCbPg==</data>
                <key>device-id</key>
                <data>mz4AAA==</data>
                <key>enable-hdmi20</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>EAAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-unifiedmem</key>
                <data>AAAAgA==</data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

 

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators
1 hour ago, iaksakkah said:

hi, how do you change generic AHCI controller and generic SSD Controller to something else ? or why is not showing correctly ?

our mobo is not for macos. we need inject apple properties, removed unused devices, etc. a bunch of crazy ssdts don't solve many things ;)

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Hi there!

 

I think your Clover Config.plist is wrong. I mean the red ethernet configuration in Clover won¬īt work unless you add:

<key>PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)</key>
            <dict>
                <key>device-id</key>
                <data>8hUAAA==</data>
            </dict>
With this line it works for me.

THANK YOU

 

Link to comment
Share on other sites

  • Administrators
14 minutes ago, JLC said:

Hi there!

u need request ur dsdt. here we dont use it via bootloader. we use via dsdt, principal bios/uefi table

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators
14 hours ago, JLC said:

Thanks for your replay. I tried with the DSDT and it didn¬īt work.

hey

yes, u need request one from ur machine

Post one Full Dump
https://www.olarila.com/topic/10301-olarila-runme-dumper/

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

On 9/24/2020 at 2:03 AM, MaLd0n said:

hey

yes, u need request one from ur machine

Post one Full Dump
https://www.olarila.com/topic/10301-olarila-runme-dumper/

Thank you I will prepare it.

Another question are the blue ports working at 3.0 speeds?

The blue ports in the back have 2.0 speeds.
I know they are part of a hub. The yellow ones are ok.
All the other ports works ok.
Could you please check your speeds?

Thanks in advance again!

After a BIOS RESET it works perfect ... 

 

 

Edited by JLC
  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...
  • Administrators
4 hours ago, iamnatanon said:

Hello MaLd0n,

DSDT.aml.zip

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...