Jump to content

Hackintosh Guide - Catalina / Big Sur on Mobos Series 100, 200, 300, 400 and 500 with OpenCore Bootloader


Recommended Posts

  • Replies 734
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Fixed it. Need to set XHCI handoff enabled in BIOS.

Buenos días Cuando el ordenador entra en reposo y quiero activarlo tocando el mouse o el teclado se reinicia. Probé muchas cosas, como darkwake, y nada funciona. Alguna solución? Saludos y g

same folder serie 100/200/300

dsdt from clover in some cases dont work with oc, is about fixregions/rebaseregions

 

I changed rebaseregions NO but it didn't makes any difference. is problem DSDT or something else? You said this DSDT will work with OC am I got wrong?

Link to post
Share on other sites
  • Administrators

I changed rebaseregions NO but it didn't makes any difference. is problem DSDT or something else? You said this DSDT will work with OC am I got wrong?

 

u need use rebase, reboot and patched

Link to post
Share on other sites

u need use rebase, reboot and patched

 

@MaLd0n I really dont got it what do you mean;


I follow the your first page instructions;


Download EFI to USB

Add DSDT.aml and SSDT-4-xh_cfsd4.aml which you created

I checked the config and Rebase already set"YES"


When I boot I am getting this error;


IMG-0044.jpg

Link to post
Share on other sites

u need boot with oc without dsdt and with rebase regions and patch new dsdt

 

Ok, I got it now what do you mean. I installed your first post EFI and add to Bootable USB Stick(No DSDT just your first post-EFI) and reboot click F8 and choose USB and OC boot screen came and chose my Clover Catalina disk, verbose starts, and machine reboot. I tried several times and it looks like reboot loop.


I took send-me from Clover without DSDT; is this can be help for OC DSDT or I must force the boot with OC?


http://s000.tinyupload.com/index.php?file_id=07079951604495968640

Link to post
Share on other sites

Hi Maldon, mine did not boot using the above EFI folder. Thanks


Added in 53 minutes 51 seconds:

Hi Maldon, found another EFI folder here that you posted and my system now is booting. However, I have no audio and my Windows drive is not showing in boot menu. Looking forward for your DSDT patch. Thank you so much. :)

 

I still can't able to boot using the updated OpenCore EFI. :cry::cry::cry:

Link to post
Share on other sites
DSDT.aml.zip

 

Didn't worked. No Bluetooth hardware? Here is what I did; I added DSDT.aml and disable all other SSDT's except SSDT-4 which is mine native USB SSDT and XhciPortLimit YES (I tried NO) it didn't work. Did I something wrong?


Screen-Shot-2020-01-26-at-19-13-12.png

Link to post
Share on other sites

i don't need any ssdt, ssdts just inject into dsdt

 

Ok. I disabled all SSDT's and activate XhciPortLimit YES, but no USB and Bluetooth hardware say still No hardware.


is DSDT requires USBInject.kext?


Yes, it does. When I add USBInjectAll.kext now everything works.


I just learned no native USB with OpenCore like the Clover!


Screen-Shot-2020-01-26-at-19-55-08.png

Link to post
Share on other sites
  • Administrators

Yes, I am.

But I said if put the DSDT.aml to ACPI folder can't boot will stop in loading page in opencore

first u need boot with oc without dsdt edited, extract and patch
Link to post
Share on other sites
  • MaLd0n changed the title to Hackintosh Guide - Catalina / Big Sur on Mobos Series 100, 200, 300, 400 and 500 with OpenCore Bootloader

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap