Jump to content

Hackintosh Guide - Catalina / Big Sur / Monterey on Mobos Series 100, 200, 300, 400 and 500 with OpenCore Bootloader

Recommended Posts

  • Replies 738
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Fixed it. Need to set XHCI handoff enabled in BIOS.

Buenos días Cuando el ordenador entra en reposo y quiero activarlo tocando el mouse o el teclado se reinicia. Probé muchas cosas, como darkwake, y nada funciona. Alguna solución? Saludos y g

same folder serie 100/200/300

Here's the updated send_me version:


Please note that I don't use all of the .AMLs in the ACPI folder (just the ones enabled on the Config.plist of OpenCore


It just reboots and I get a Kernel panic

When it boots back up, thunderbolt (usb devices on the Ultrafine monitor) are gone.

panic(cpu 4 caller 0xffffff7f8e54e970): "UPSB(iMac17,1): thunderbolt power on failed 0xffffffff\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IOPCIFamily/IOPCIFamily-370.0.2/IOPCIBridge.cpp:1396

Backtrace (CPU 4), Frame : Return Address

0xffffff83c6fcba60 : 0xffffff800db39a3b

0xffffff83c6fcbab0 : 0xffffff800dc70fe5

0xffffff83c6fcbaf0 : 0xffffff800dc62a5e

0xffffff83c6fcbb40 : 0xffffff800dae0a40

0xffffff83c6fcbb60 : 0xffffff800db39127

0xffffff83c6fcbc60 : 0xffffff800db3950b

0xffffff83c6fcbcb0 : 0xffffff800e2d17f9

0xffffff83c6fcbd20 : 0xffffff7f8e54e970

0xffffff83c6fcbd40 : 0xffffff7f8e537bdb

0xffffff83c6fcbda0 : 0xffffff7f8e538116

0xffffff83c6fcbdc0 : 0xffffff7f8e536320

0xffffff83c6fcbe10 : 0xffffff7f8e540b33

0xffffff83c6fcbe30 : 0xffffff800e226654

0xffffff83c6fcbea0 : 0xffffff800e22645a

0xffffff83c6fcbec0 : 0xffffff800db7b625

0xffffff83c6fcbf40 : 0xffffff800db7b151

0xffffff83c6fcbfa0 : 0xffffff800dae013e

Kernel Extensions in backtrace:


BSD process name corresponding to current thread: kernel_task

Boot args: dart=0 shikigva=60 agdpmod=pikera

Mac OS version:


Kernel version:

Darwin Kernel Version 19.0.0: Thu Oct 17 16:17:15 PDT 2019; root:xnu-6153.41.3~29/RELEASE_X86_64

Kernel UUID: 7503CD47-851F-321E-8747-50DB4299165F

Kernel slide: 0x000000000d800000

Kernel text base: 0xffffff800da00000

__HIB text base: 0xffffff800d900000

System model name: iMac17,1 (Mac-DB15BD556843C820)

System shutdown begun: NO

Panic diags file available: YES (0x0)

System uptime in nanoseconds: 465474601678

Link to post
Share on other sites

I am a brand new registered Olarila "member" (10m ago). I have a fresh newly built hackintosh and I would like to install Catalina 10.15.1 using OpenCore (Clover if better for my hardware) and with all ports working including native Thunderbolt 3 onboard. I have never used OpenCore but have used Clover. I have struggled to get this working and the quickest, best solution with better future compatibility (OpenCore) is what I am looking for. Please point me exactly where I can get up and running the quickest. If I am posting this in the wrong forum please let me know where I should be posting as I am new and thought it was best to describe everything up front in hopes I can get to a solution quickest. I have the following hardware:

I initially will be using HDMI cable to connect to monitor to get started then migrate to Display port or TB3 in near future.

Gigabyte Z390 (F8 BIOS)


HyperX Predator Black 64GB 3600MHz DDR4 CL17

Samsung 970Pro NVME M.2 (installed in 1st M.2 slot)

Fenvi T919 PC PCI WiFI Card (BCM94360CD)

Asus USB-BT400 Bluetooth dongle

Radeon 7 (direct from AMD) (installed in top PCIE 3.0 x16 slot)

EVGA SuperNova 1000 G3 80 Plus Gold

Fractal Design R6 case

Mac Keyboard (full with numbers)

Magic Mouse 2

Thank you to anyone that can jumpstart me in making this a quick and least time consuming success. I apologize if I am posting in wrong forum I didn't know where to go.

Link to post
Share on other sites

MaLd0n thanks for your reply.

Before I found your site I tried a Clover install and frankly I think I am very close to getting it to work. I don't know how I am to use the RunMe app since I cant get the hackintosh working. I do have some real Macs so is that where I am to use it?

I will share with you my Clover EFI and a report that I think shows what the problems are with the hackintosh trying to boot. I used this Vanilla guide r/Hackintosh to build the EFI. Also, in case you are wondering why I am using OcQuirks (2.09), that is supposed to be a better replacement for AptioMemfix (or whatever that driver is named).


I have been at this for a few weeks and at the end of my patience trying to get this to work. I would really appreciate any help you can offer to get me up and running fast with Catalina 10.15.1 and with all ports, iMessage and everything else a Mac does and have it working. PayPal $ ready to go if this can get done.


Link to post
Share on other sites

i am working on Bootcamp windows side right now, let me go to my MacBookPro and download your EFI and pop it in the hack and see if it can work.

By the way, I love your quick response and help. I will report back in a few minutes.

Added in 16 minutes 17 seconds:

MaLd0n okay, I popped it in, pressed reset button on hack, a small text menu opened in top left corner of screen. I could barely read it before it auto booted. It streamed a bunch of code on the screen for a bit then flashed a pic of the Gigabyte BIOS icon/pic and like 8 or so text errors flashed so quick I couldn't read and it went back to the text boot screen and did the same thing over and over. I never had the chance to choose how to boot it just did it on its own.

Anything I should try now? I did happen to notice the first menu item said this "Install Catalina (external)". I am using an internal Samsung 970 Pro NVME M.2. I don't have any external drives connected. Does that matter?

By the way, my BIOS settings are on F8 (newest BIOS that supports 9900KS) and I changed the settings to what most everybody has changed for this build and setup.

This may appear to be a very dumb question but is there a specific USB port I am supposed to be using to boot? 2.0, 3.0? Not sure if it makes a difference.

Link to post
Share on other sites

Just the DSDT.aml file and nothing else?

Added in 6 minutes 41 seconds:

[ref]MaLd0n[/ref], okay, I only removed that DSDT.aml file and tried again. Same result, doing same thing and not working

Should I remove the Radeon 7, Enable iGPU in BIOS and try again? Then, if it works re-install, disable iGPU in BIOS and fix anything from there that might not be working?

I did try removing Radeon 7, Enable iGPU in BIOS and make Auto and it didn't work, did the same as before but even quicker fail. I re-installed Radeon 7, Disabled iGPU and set to PCIE 1 in BIOS. I am back to square one with no progress.

Link to post
Share on other sites

Send me Garys-iMac-Pro.zip


this is the zip from runme.app - trying to test opencore 0.5.3 on my B360 Asus Motherboard - the version in post 1 doesn't work - so included my zip file for a opencore sdst creation.

my mac os is 10.15.2 beta3 - the clover bootloader on ssd has been removed (was fully working - but gone clean for open core) and i boot my samsung 2.5inch 850 ssd (sata port 1) via usb clover stick.

I understand opencore is flaky with NVMe drives (this is my m.2_2 drive in PCI-e X4 mode this has windows on) can be removed is opencore will not play nicely

my m.2_1 drive is pci-e X2 mode as AHCI /sata mode is a WDC120GB green drive - this is blank - also understand opencore seeing nvme drives as sata is flaky too... (i have been reading both old and new open core guides... till head hurts!)

my OSX drive that boot fine is a samsung 850 ssd in sata port one has 10.15.2. beta3 on running a RX5700 (yes i know about agpdmod+pikera)

i can easily remove all m.2 drives and just use 850ssd if required due to conflicts, the rx5700 can be swapped for a rx480 if required,

I am using ethernet intel1219v7 - can remove my asus wi-fi card if required but this was plug and play.

some help with any or all of above - even if advice on required kexts etc.

Link to post
Share on other sites

@Mald0n opencore 0.5.3 has now a public release, but just replacing/updating files in efi folder doesnt work. machine wont boot if you take the new opencore. any idea whats going on? will you update efi folder on page1?

edit: forgot to update files in "drivers" folder. ;) working now.


Link to post
Share on other sites

[ref]Prathapsingh[/ref], use efi from first post and my edited dsdt

I Followed Your Advice.

Now i have Zip File includes ACPI & OC Folders.

How can i Use This ?

i already Downloaded Olarila Catalina 10.15.1 & Create Bootable USB via balenaEtcher.

What should i do next ?

please Reply.

Thank you...

Link to post
Share on other sites
  • MaLd0n changed the title to Hackintosh Guide - Catalina / Big Sur / Monterey on Mobos Series 100, 200, 300, 400 and 500 with OpenCore Bootloader

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

:cap-Please Disable Your ADBlocker-:cap