Jump to content
PatrickDOrleans

Guia Instalação OS X 10.9 em Aspire 5750 (não G)

Recommended Posts

rafaelsaba, o arquivo gerado pelo Patch é um novo kext. Ele vai gerar na mesma em que estiver o arquivo AppleIntelHDGraphicsFB.kext. Você deve pegar esse novo AppleIntelHDGraphicsFB.kext e colocar na pasta Extensions e deletar o antigo AppleIntelHDGraphicsFB.kext que existe nela, caso haja. Após isso rode o Kext Utility para atulizar o cache. Apenas isso. Se você instalou todos os componentes IntelHdGraphics então tudo deveria funcionar normalmente. Boa sorte!

 

PatrickDOrleans, poderia conferir se estou fazendo alguma coisa errada? Vou passar o passo a passo desde o começo e você me diz se estou pulando algo ou fazendo alguma coisa errada.


1- Crio um pendrive de instalação, baseado na imagem .Raw do Mac OS X 10.9.4 com o Win32DiskImager.

2 - Inicializo o Pendrive e deixo o mesmo entrar na tela de inicialização do Clover

3 - Seleciono o Pendrive de instalação, aperto espaço e vou na opção Boot Mac OS X in Single user verbose mode

4 - Executo os comandos para remover as Kexts de video que você passou no post inicial.

5 - Reinicio o Notebook e aperto enter pendrive de instalação do Mac OS X

6 - Faço a instalação do Mac OS X normalmente e reinicio o notebook

7 - Faço as configurações iniciais e inicializo o Mac OS X normalmente sem as Kexts de video.

8 - Instalo o Chamaleon 2.2SVN-R239 (Para a criação do diretório Extra na Raiz do HD Mac OS X)

9 - Instalo as Kexts da Pasta Aspire 5750 para conseguir usar a porta Ethernet do notebook e instalar o DSDT Patch.

10 - Faço a aplico o Patch Aspire 5750 na minha DSDT e salvo o arquivo DSDT.aml no Direotiro /Extra criado na instalação do Chamaleon

11 - Instalado Todas Kexts de video com o Kext Utility(Que de acordo com o as informações do Tutorial já estão com Patch)

12 - Reinicio o notebook.

13 - Depois de Reiniciado o mesmo apresenta tela Quadruplicada

14 - Executo o Intel HD Graphics Patcher e arrasto AppleIntelHDGraphicsFB.kext para o Intel HD Graphics Patcher

15 - Não deixo marcado a opção DualLink e escolho a opção Mac OS X 10.9*

16 - Aplico o Patch e ele me apresenta o seguinte erro:

 

General Patch Error!
singleLink patch 1 error!
singleLink patch 2 error!
singleLink patch For Mavericks Error!
LinkWidth X1 (Singlelink) patch error!

 

17 - Pego AppleIntelHDGraphicsFB.kext com Patch e coloco ela no diretorio Extensions e substituo o AppleIntelHDGraphicsFB.kext que está lá.

18 - Rodo o Kext Utility para atulizar o cache

19 - Reinicio o computador e o problema de tela Quadruplicada persiste.


No Geral é isso que eu estou fazendo, se vocês conseguirem me ajudar na solução do problema eu ficaria muito grato!


Muito obrigado pela atenção e ajuda de vocês.

Share this post


Link to post
Share on other sites

Cara, nem li tudo porque já vi o erro de cara. Você deve aplicar as códigos DEPOIS de instalado! Não faz sentido nem lógica alguma o que você está fazendo. Você sabe pra que os comandos que estão no guia servem? Servem pra remover os kext de vídeo da pasta Extensions, do sistema já instalado! Você vai usar o instalador com a tela quadruplicada e depois que finalizar a instalação vai usar o pen-drive de instalação para bootar a partição que JÁ ESTÁ INSTALADA e nela entrar como single user e aí sim aplicar os códigos NELA. Repare que os comandos estão na parte do "pós-instalação". Outra coisa: faça as coisas aos poucos pra ver se resolve o problema. Não faça tudo de uma vez. Faça uma, depois reinicie e faça outra caso não funcione. Você tem que pegar a manha da parada!

Share this post


Link to post
Share on other sites
Cara, nem li tudo porque já vi o erro de cara. Você deve aplicar as códigos DEPOIS de instalado! Não faz sentido nem lógica alguma o que você está fazendo. Você sabe pra que os comandos que estão no guia servem? Servem pra remover os kext de vídeo da pasta Extensions, do sistema já instalado! Você vai usar o instalador com a tela quadruplicada e depois que finalizar a instalação vai usar o pen-drive de instalação para bootar a partição que JÁ ESTÁ INSTALADA e nela entrar como single user e aí sim aplicar os códigos NELA. Repare que os comandos estão na parte do "pós-instalação". Outra coisa: faça as coisas aos poucos pra ver se resolve o problema. Não faça tudo de uma vez. Faça uma, depois reinicie e faça outra caso não funcione. Você tem que pegar a manha da parada!

 

PatrickDOrleans, fiz tudo conforme você me falou um passo de cada vez, reiniciando depois da instalação de cada fase do processo de pós-instalação. Mas o problema da Tela quadruplicada persiste, me desculpe mas existe mais alguma coisa que eu consiga fazer para resolver esse problema da tela quadruplicada?

Share this post


Link to post
Share on other sites

Na boa cara, você leu alguma coisa?


O tópico da HD 3000 fala para usar SMBIOS de MacBookPro8,1. Você está usando MacPro5,1.


Em org.chameleon.Boot.plist você não deve colocar GraphicsEnabler=Yes (ou coloque No).


Se colocar UseKernelCache=Yes as kexts de /Extra/Extensions(.mkext) não serão carregadas a menos que você tenha KernelPatcher.dylib em /Extra/modules.


Não adianta e nem precisa colocar as kexts de vídeo (AppleIntel*) em /Extra/Extensions, elas já estão em /S/L/E.


Não faz nenhum sentido duplicar as kexts em /Extra/Extensions e /Extra/Extensions.mkext, use um ou outro.

Share this post


Link to post
Share on other sites
Na boa cara, você leu alguma coisa?


O tópico da HD 3000 fala para usar SMBIOS de MacBookPro8,1. Você está usando MacPro5,1.


Em org.chameleon.Boot.plist você não deve colocar GraphicsEnabler=Yes (ou coloque No).


Se colocar UseKernelCache=Yes as kexts de /Extra/Extensions(.mkext) não serão carregadas a menos que você tenha KernelPatcher.dylib em /Extra/modules.


Não adianta e nem precisa colocar as kexts de vídeo (AppleIntel*) em /Extra/Extensions, elas já estão em /S/L/E.


Não faz nenhum sentido duplicar as kexts em /Extra/Extensions e /Extra/Extensions.mkext, use um ou outro.

 

pernacabeluda, cara muito obrigado pela ajuda! Graças a você e o PatrickDOrleans e mendietinha consegui resolver o problema do video, alias um dos problemas que eu encontrei que estava causando esse problemas

era a forma que eu estava fazendo as configurações da SMBIOS e a aplicação do patch na DSDT, eu estou usando o Clover como bootloader, e quando se usa o Clover o arquivo DSDT.aml gerado no Patch da DSDT tem que ser colocado em /EFI/CLOVER/acpi/patched e para fazer as configurações da SMBIOS é preciso usar o Clover Configurator e editar o arquivo config.plist que fica em /EFI/CLOVER.


Eu ainda tenho algumas Dúvidas, se puderem continuar me ajudando eu agradeço!


1. Toda vez que tento me conectar em alguma rede Wifi ele apresenta uma mensagem com um ponto exclamação escrito: Connection Failed (Isso todas as redes Wifi) como eu posso resolver isso?


2. Meu leptop não está saindo Som, instalei a Kext que veio junto com as outras do Tutorial, alguma coisa que poça solucionar o problema?


3. Como faço para mostrar o status da minha bateria?


Muito obrigado pela ajuda de vocês!

Share this post


Link to post
Share on other sites
Rafael, sobre o áudio e a bateria eu tenho as kexts que funcionam perfeitamente no meu notebook, me mande um e-mail que te passo por lá: [email protected]

 

Vou te mandar o Email Elvis, dai você me manda as Kexts.


 

precisa do patch na dsdt pro áudio funcionar.

 

Você esse Patch para me passar cara?



Muito obrigado!

Share this post


Link to post
Share on other sites

Esse ano continua igual como no ano passado, pode seguir que funciona.


Observação: alguns BIOS limitam o boot de acordo com o tipo de tabela de partição do HD. Para boot legacy é necessário usar MBR e se usar GPT o boot tem que ser UEFI.

Share this post


Link to post
Share on other sites
Esse ano continua igual como no ano passado, pode seguir que funciona.


Observação: alguns BIOS limitam o boot de acordo com o tipo de tabela de partição do HD. Para boot legacy é necessário usar MBR e se usar GPT o boot tem que ser UEFI.

 


Consegui resolver o esquema do Triple Boot, muito obrigado! Mas surgiu um outro problema, fui refazer a instalação do Mavericks, lendo e seguindo tudo que vocês me passaram e funcinou, porém tive infeliz surpresa na hora da instalação das kexts de video, tela quadruplicada novamente. Estou usando o Clover (Ultima versão) como bootloader e estou usando a SMBIOS do MacBook Pro 8.1 como você me recomendou. Se você conseguir verificar minha basta EFI do clover e ver se tem algo errado eu agradeço cara, segue em anexo https://anonfiles.com/file/2ea2db4a54990227522e0f6d19223b4c



muito obrigado pela ajuda

Share this post


Link to post
Share on other sites

Mesmo erro que no Chameleon.


Graphics/Inject/Intel tem que ser false

	<key>Graphics</key>
<dict>
	<key>Inject</key>
	<dict>
		<key>ATI</key>
		<false/>
		<key>Intel</key>
		<false/>
		<key>NVidia</key>
		<false/>
	</dict>
</dict>

Share this post


Link to post
Share on other sites
Mesmo erro que no Chameleon.


Graphics/Inject/Intel tem que ser false

	<key>Graphics</key>
<dict>
	<key>Inject</key>
	<dict>
		<key>ATI</key>
		<false/>
		<key>Intel</key>
		<false/>
		<key>NVidia</key>
		<false/>
	</dict>
</dict>

 

Cara, muito obrigado! Resolveu o problema aqui! Alias não encontrei nada relacionado a ativar mouse no bootloader clover, eu não estou conseguindo usar o mesmo, você tem alguma coisa para me recomendar? Alias existe algum Jeito de deixar a tela de inicialização do Mavericks (a tela da maçã)menos esticada?


muito obrigado!

Share this post


Link to post
Share on other sites

 

Não entendi muito bem como funciona esse procedimento do HDMI audio, tem uma parte do tutorial que fala para fazer um Patch na DSDT, só que eu não sei se é preciso fazer esse Patch ou é uma modo alternativo de ativar o Audio HDMI, se você conseguir explicar melhor essa parte eu agradeço.


Abraço

Share this post


Link to post
Share on other sites

Não uso HDMI mas pelo que vi, depende do caso. Pode precisar patch na DSDT ou SSDT, tem casos que pode ser feito pelo Clover e outros que também precisa patch na kext.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...