Jump to content

Need Help with DSDT Sony Vaio z11


Recommended Posts

[email protected]


I get a new notebook (sony vaio z11 c5e) for my girlfriend and try to install mountain lion 10.8.2


I have an unlocked bios, so I can boot with ahci controller mode without "waiting for root" error.

I use latest cloverEFI as bootloader

use the macbookpro6,2 as smbios

no other injections or autopatchs

following staff is working:


-nvidia 330m gpu with graphicsenabler = yes with qe/ci and full resolution

-battery with voodoobattery and custom appleacpiplatform kext

-touchpad with voodoops2controller

-audio with voodoohda

-ethernet with intel1000e kext

-bluetooth working out of box


not working:


-display dim/ display brightness

-sleep not working - sleep working but after wakeup -> restart

-fn-keys not working - volume buttons, but not the brightness buttons


I download untouched dsdt from the internet and patch following patchs from dsdteditor:

new-hpet

_T_x rename

dtgp

ehci

ehci-sleep

irqs

pnlf sb

uhci

fn keys


now i start with the dsdt from scratch and boot up preconfigured vaio windows with all drivers inside

but i must use RAID as controller mode, cause this is the default mode

and make a dsdt and patched again with dsdt patchs I wrote above


I attached this and hope somebody with more dsdt editing experience can help me. I have not enough dsdt editing experience and skills to fix it on my own.

DSDT_Vaio_z11_orig&patched.zip

Link to post
Share on other sites
[email protected]


I get a new notebook (sony vaio z11 c5e) for my girlfriend and try to install mountain lion 10.8.2


I have an unlocked bios, so I can boot with ahci controller mode without "waiting for root" error.

I use latest cloverEFI as bootloader

use the macbookpro6,2 as smbios

no other injections or autopatchs

following staff is working:


-nvidia 330m gpu with graphicsenabler = yes with qe/ci and full resolution

-battery with voodoobattery and custom appleacpiplatform kext

-touchpad with voodoops2controller

-audio with voodoohda

-ethernet with intel1000e kext

-bluetooth working out of box


not working:


-display dim/ display brightness

-sleep not working - sleep working but after wakeup -> restart

-fn-keys not working - volume buttons, but not the brightness buttons


I download untouched dsdt from the internet and patch following patchs from dsdteditor:

new-hpet

_T_x rename

dtgp

ehci

ehci-sleep

irqs

pnlf sb

uhci

fn keys


now i start with the dsdt from scratch and boot up preconfigured vaio windows with all drivers inside

but i must use RAID as controller mode, cause this is the default mode

and make a dsdt and patched again with dsdt patchs I wrote above


I attached this and hope somebody with more dsdt editing experience can help me. I have not enough dsdt editing experience and skills to fix it on my own.

Try this:DSDT.aml.zip

Link to post
Share on other sites

thanks, but no progress.


no brightness control

no fn keys

no sleep - after sleepimage is done? I see the orange pulse led, but after wake through keyboard -> restart

 

but sleep ist working after I restore the AppleACPIPlatform from 10.8.1 !!! :)


after wakeup the speedstepping has an error, so the multiplicator is on max = 21, should be 9 on idle



also i tried now the hdmi output and it's not working. I changes the onboard video switcher to static, so only the geforce gpu is detected


your dsdt has no warnings, how do u do this?


do u need the console log? or something else?

Link to post
Share on other sites
thanks, but no progress.


no brightness control

no fn keys



but sleep ist working after I restore the AppleACPIPlatform from 10.8.1 !!! :)


after wakeup the speedstepping has an error, so the multiplicator is on max = 21, should be 9 on idle



also i tried now the hdmi output and it's not working. I changes the onboard video switcher to static, so only the geforce gpu is detected


your dsdt has no warnings, how do u do this?


do u need the console log? or something else?

look: http://Olarila.com/forum/viewtopic.php?f=19&t=1131

Link to post
Share on other sites

After I posted my success with sleep it doesnt work anymore.. I dont know what I have done, but I figured out it has something relate to AppleACPIPlatorm & AppleSmartBatteryManager kext


With some custom AppleACPIPlatform no sleep, only display goes off, but after keyboard touch I'm back..

with other ACPiPlatform it goes sleep, with blinking led, no fan, all off and after wake up, it resets


I tried various patches for my dsdt, but no success..


please help me figured it out


here is my actually dsdt

VAIO.aml.zip

Send me carina vaiobook 2.zip

Link to post
Share on other sites

@cyonix: I had the same problem with sleep as yours and suspect it's somehow related to the VoodooBattery + AppleACPIPlatform 1.3.6. As soon as I've removed VoodooBattery and tried vanilla AppleACPIPlatform from 10.8.1 (also I have FakeSMC.kext without any kexts in Contents->Plugins) I lost battery indicator but got correct sleep behaviour with your patched DSDT. I recommend you to begin with patched DSDT that Mirone made especially for you because changes I've made to it are only for my USB and sound so you may lose yours if you decide to begin with my variant.

And, yes, I also have a patched BIOS with static VGA switching policy and controller in RAID mode. I've tried AHCI but got completely unbootable system that hangs at VAIO screen and can't get even to BIOS, I had to disassemble the notebook and temporarily switch off SSD cable to get RAID mode back. So I have no changes to BIOS except for VGA switching policy (of course trigger above the keyboard is set to SPEED and not STAMINA).


UPDATE: AppleACPIPlatform.kext 1.3.6 helps with battery indicator but sleep doesn't work with this kext. So currently either battery indicator or correct sleep.

Link to post
Share on other sites

ok, i tried the AppleACPIPlatform version 1.6 and 1.5 but no sleep


which FakeSMC do u using?


Which edits do u make in my dsdt? Can u upload all nessesary kexts


I using latest version of voodoops2controller.kext and see that if I use F2 and F3 buttons there is some error logs in console, so I think the GPU is not working corrent with all output possibilities and only 1600x900 resolution works correct. Some people with Thinkpads have fixed this feature, so maybe it's the same procedure.


SpeedStep works correct but sometimes the GPU clocks to high and stay high and if I use Geekbench I got lower result than with my original MacbookPro6,2

In theory, the MacbookPro6,2 has the same specs like the Vaio z11 (Intel300+Nvidia 330M) so we must get it working ;)

Link to post
Share on other sites

When I've decided trying install ML on my Vaio, I began with multishit 5.2.1, checked UserDSDT, Network->Intel(AppleIntelE1000e) and Sound->ALC889 (with DSDT) patches under Drivers. So if description is right this program installed Chimera, FakeSMC and patches to AppleRTC (by default), IONetworkingFamily for Intel Ethernet and AppleHDA for ALC889. My changes to your DSDT are necessary because of my patched AppleHDA (so changed HDEF block) and different IRQs in my HPET block (don't know why it doesn't want to use IRQ 0). Also I've noticed different hex values in OperationRegion blocks with SystemMemory at the beginning of DSDT and changed yours to that of my original one, don't know definitely does it matter. I refused to use VoodooBattery because as I've mentioned earlier AppleAHCIPlatform 1.3.6 that comes with it causes wrong sleep behaviour (same as yours: system sleeps but reboots when trying to wake, either from power button or from keyboard).

So, my last state is: I've changed 16bit EC registers to 8bit pairs as described here: http://www.insanelymac.com/forum/topic/272459-appleacpibatterymanagerapplesmartbatterymanager-for-lion/#entry1772114

and installed AppleSmartBatteryManager from there. My latest DSDT is in Extra.zip attachment here.

I've tried to make my DSDT adapted to your system so if you want to use it don't try to install my AppleHDA, leave yours.

DSDT_Z11_C5E.zip

Extensions.zip

Extra.zip

Link to post
Share on other sites

thx for your experience, all your stuff ist working also on my sony z11, but sleep doesnt.. I think that this is not mac osx related. maybe there is somethink wrong with my bios settings. on some gigabyte board, I had same malfunctions, so I must reset the bios, but on my sony I dont know how.


yesterday I tried many different settings, but if I goes sleep, only display get sleep, and after keyboard push, sometimes display wake up, sometime doesnt. no real sleep, no pulsating led. in console I see some logs sleep related, I can post later


can u write down your bios settings? or make pictures...


tnx a lot!

Link to post
Share on other sites

Hey man, I have new infos..


cause my sleep doesnt work, no matter what I change, I now looking for the backlight slider


If GPU in BIos is on static, only intel or nvidia gpu is working ( led is lighting ), so no backlight change is working nether in Windows 7. I see the HUD animation in Windows but no backlight change. So my theory is, that this feature is only possibly with auto/dynamic option in Bios.


also I tried following dsdt changes:

http://www.insanelymac.com/forum/topic/239463-dsdt-for-sony-vaio-vpcz13/ <-- look inside the dsdt. he had add nvidia 330m devices and hdmi audio


also there is also some information:


http://www.insanelymac.com/forum/topic/236835-updated-2012-genericbrightnesskext/

Link to post
Share on other sites
  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

:cap-Please Disable Your ADBlocker and Support Our Forum-:cap