Jump to content

Olarila HackBeast GA Z490M - Full DSDT patches - OPENCORE


Recommended Posts

  • Administrators

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with ETH 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05

Donation with LTC MTmkEY9xiLkuzf4vHtRYHLoapBcmmoApFc

Donation with DAI 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05

Donation with USDC 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05

Donation with PicPay @danielnmaldonado

Donation with PiX @[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

 

-TUTORIAL-

https://tinyurl.com/ycvcnp8h

 

--Bios/UEFI Settings--

CSM Support - Disabled

 

-EFI OpenCore Folder

https://tinyurl.com/y7puzwv9

-EFI Clover Folder

https://tinyurl.com/ycr9g9ye

 

---HARDWARE---

-Mobo Gigabyte GA Z490M

-Processor Core i5-10400

-GPU Radeon RX 5500 XT

0FbZJyd.png

--DSDT Patches--

-FIX ERRORS AND WARNINGS
-FIX ACPI ERRORS
-REMOVE UNUSED SCOPES / DEVICES
-HIGH PRECISION EVENT TIMER
-SATA SERIE ID
-DMAC
-REMOVE LINES, PROBLEMATIC and UNUSED
-FIX K.P in REBOOT
-NVRAM
-REAL TIME CLOCK
-SLPB
-DARWIN / WINDOWS
-XHCI
-PLUGIN TYPE
-HDEF
-ARTC
-IPIC
-TIMR
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-UAR1
-LAN
-FWHD
-USBX
-PMCR
-PPMC
-XSPI
-GMM
-kUSBCompanionIndex
-io-device-location
-IMEI
-EC
-PNLF
-ARPT
-GFX0
-NVME
-ACPI-WAKE-GPE
-DTGP
-ACQUIRE MUT0 0XFFFF
-MUTEX MUT0 0x00
-EXTERNAL REFERENCES
-UNKNOWNOBJ
-HDMI / HDAU
-FULL RENAMED DEVICES

 

--Screenshots--

6UPGSTp.png

YuO7SMQ.png

c37ckv0.png

7lnlg6K.png

itH16rj.png

1QwCldQ.png

V7LutH4.png

9TQWJvf.png

5BgdTWM.png

iVkwu2j.png

9YcSmSL.png

YR6wPIW.png

gWKp6MS.png

335jfJb.png

vyjccvo.png

alIqPnN.png

FgNBglH.png

dmX5qjP.png

gQ6tHw7.png

4RR4rWm.png

 

Link to post
Share on other sites
  • 2 months later...
  • Administrators
27 minutes ago, Pepe Arento said:

Hey, thanks for this, do you know if this can work with iGPU only?

Yes

Quote

            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>AAPL,ig-platform-id</key>
                <data>BwCbPg==</data>
                <key>device-id</key>
                <data>mz4AAA==</data>
                <key>enable-hdmi20</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>EAAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-unifiedmem</key>
                <data>AAAAgA==</data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

 

Link to post
Share on other sites
  • 2 months later...

Good morning, please where i can find the CLOVER or OPENCORE EFI FOLDER and relatiive config.plist??

 

I have the same mainborad (bios F7B) with IGPU only… connected to the DVI PORT

 

Thanks ;-):classic_biggrin:

 

Edited by ruggero
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap