Jump to content
MaLd0n

macOS Mojave 10.14.4 - Out!

Recommended Posts

HACKINTOSH PPL, UPDATE CLOVER

https://sourceforge.net/projects/cloverefiboot/files/Installer/

 

---

 

Safari

Adds Dark Mode support for websites that support custom color schemes

Streamlines website login when filling credentials with Password AutoFill

Allows push notification prompts only after interacting with a website

Adds a warning when an insecure webpage is loaded

Removes support for the expired Do Not Track standard to prevent potential use as a fingerprinting variable; Intelligent Tracking Prevention now protects against cross-site tracking by default

 

iTunes

Shows more editorial highlights on a single page in the Browse tab, making it easier to discover new music, playlists, and more in Apple Music

 

AirPods

Adds support for new AirPods (2nd generation)

 

More

Supports Air Quality Index in Maps for US, UK and India

Improves the quality of audio recordings in Messages

Supports real-time text (RTT) for phone calls made through a nearby iPhone on Mac

Provides enhanced support for external GPUs in Activity Monitor

Fixes an App Store issue that may have prevented adoption of the latest versions of Pages, Keynote, Numbers, iMovie, and GarageBand

Improves the reliability of USB audio devices when used with MacBook Air, MacBook Pro and Mac mini models introduced in 2018

Corrects the default screen brightness for MacBook Air (Fall 2018)

Fixes a graphics compatibility issue that may occur on some external displays connected to Mac mini (2018)

Resolves Wi-Fi connection issues that may occur after upgrading to macOS Mojave

Fixes an issue where re-adding an Exchange account may cause it to disappear from Internet Accounts

Fixes an issue where AOL user passwords may be frequently requested in Mail

 

Sohramr.png

J3IBlO9.png

Share this post


Link to post
Share on other sites

Thank you very much MaLd0n!


Then, the recommended steps would be?


- Update to the most recent kexts (Lilu, Whatevergreen, etc)

- Install the latest clover

- Update MacOs to 10.14.4

- Reinstall Clover


do you recommend following these steps?

I mean, to avoid any kernel panic or some problem like that...


the update does not affect the USB's patches (via hackintool) or video patch, right?


thanks!

Share this post


Link to post
Share on other sites

- Update to the most recent kexts (Lilu, Whatevergreen, etc)

- Install the latest clover

- Update MacOs to 10.14.4

- Reinstall Clover

You can omit the last step.

Share this post


Link to post
Share on other sites

[ref]Wizzard[/ref], u need use apfs instead hfs

Share this post


Link to post
Share on other sites

Hi again! Just a simple questions before update...


The update breaks some of the patches made by hackintool? Actually I have the video patch for UHD 630 (works great!) injected in config.plist and the USB patch, with the custom USBPorts.kext


I have the lastes clover boot installed... So, it is not necessary to reinstall before the update, right?


Just update the kexts (Lilu, WGE, AppleALC) before 10.14.4...


thanks!


sorry for many questiones, but I do not want to be surprised that the hack does not start, boot loop, kernel panic, etc... :?

Edited by Guest

Share this post


Link to post
Share on other sites

[ref]kultrun[/ref], work good for me in all hacks, last clover version and last kexts version

Share this post


Link to post
Share on other sites

Ah, very good MaLd0n!! So I'll tray soon, you are the absolute guarantee of good Hack performance!


Many thanks!!

 

kultrun, work good for me in all hacks, last clover version and last kexts version

Share this post


Link to post
Share on other sites

Does anybody know if this includes support for new system definitions? I'm assuming there will be iMac 19,1 or something to reflect new 9th gen processors and chipsets.


Also, I noticed my computer is no longer going into deep sleep. It was working perfectly prior to this this upgrade (sleeping in the 1-2W range, vs now showing 60-85W consumption while sleeping). It's possible something changed BEFORE I upgraded to Mojave but I only noticed this issue after the upgrade.

Share this post


Link to post
Share on other sites

[ref]kultrun[/ref], my 10.14.3 ran perfectly, now i restart every time, because ot the update ... 10.14.4 has major graphics changes and i had a graphics issue with mojave before, which was fixed with skylake spoof -> now it was messed up and a need to find a solution.


Will try Maldon's config after all in the evening :)

Share this post


Link to post
Share on other sites

Hi Morselina (and all), thank you very much for your warning!

Currently, I'm like in your case: my hack works perfectly with 10.14.3 with video patch made by hackintool (inject info about platformId etc in config.plist), with the USB patch also made by hackintool (generates USBports.kext)

I absolutely trust in MaLd0n's recommendations about the update, the steps to do: update clover, update kexts, install update, etc

I still did not apply the update because I did not have time to work quietly with the hack...


But, as in your case, I've seen out there that this update seems to be different from others and breaks several configurations that previously worked very well


So... maybe I'll wait a bit and see the big picture about this update and if new tips or warnings appear to avoid having a headache and my hack will not start, enter in boot loop, etc


many thanks for all!!!

Share this post


Link to post
Share on other sites

[ref]kultrun[/ref], I even used latest WhateverGreen and Lilu kexts, and one from the latest clover - i see when i boot clover, that it is indeed 4907 but this doesnt solve my problem.


In the past i had a specific problem with Mojave, which tool few weeks to be solved, now i still have the problem with 10.14.4 update downloaded from Apple website.


I was warned that i should wait at least 10 days before I install the update, but dont listened and tried to see what will happen :)

Share this post


Link to post
Share on other sites

Morselina, maybe I'll wait a couple of weeks until there's a newer clover boot and read a little more about how this update has result...

about what I can read, this update has been more problematic than the previous ones


thank you very much MaLd0n for all the help given! when I am encouraged to install the update, I tell you how everything has resulted!


a very silly (cosmetic) question ... in case I decide not to move forward with the update, is there a way to remove this update notice available in system settings, dou you think?


7uC830E.png


many thanks!


 

I was warned that i should wait at least 10 days before I install the update, but dont listened and tried to see what will happen :)

Share this post


Link to post
Share on other sites

I know it was a purely aesthetic nonsense, but I found that solution!

If someone does not plan to update to 10.14.4 for now and does not want to see the red Software Update notification bubble on the System Preferences app in MacOS Mojave (not App Store), there is the solution:


https://apple.stackexchange.com/questions/344278/how-can-i-disable-the-red-software-update-notification-bubble-on-the-system-pref


Basically what resulst to me:


defaults write com.apple.systempreferences AttentionPrefBundleIDs 0


Killall Dock



thanks!

Share this post


Link to post
Share on other sites

Can't convert existing 10.14.3 disk from HFS to APFS... selection is grayed out. Suggestions?

Share this post


Link to post
Share on other sites

[ref]149113[/ref], make a back up with carbon copy cloner of your main drive an save your efi also boot on to the clone then format main drive as apfs an restore back that should help you out

Share this post


Link to post
Share on other sites

gigabyte z370p d3

i5 9400f

radeon rx570

ssd


Hi MaLd0n,

problem !!

I forgot to disable auto update (...)

It somehow updated itself to 10.14.4

I had all the sudden wake up problems.

It didn't sleep for more then 1 second, powering back up...all memory leds, fans, usb drives restart, but it cant phisically wake up.

Could it be that just the video card doesn't wake up?

the effect of that is that the computer looks awake, but mouse and keyboard seems to do nothing and the screen remains with "no signal" tryed also hdmi vs dport. No luck !


I updated clover and kexts. no joy !!

Please help, second beer on the way !


I installed a back up carbon copy on an m2 drive (only problem being formatted as hfs+ instead of afs - worst case i 'll start from that !!)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...