Jump to content
Jedispara

Lion on Intel DX58S0 - Need help

Recommended Posts

Hey guys, i've been struggling for over a week now to get my system up and running, and while I can get Lion installed with no problem, I keep hitting a brick wall for ethernet and audio. I've posted a few times over on tonycrap with no success, and its getting critical that my machine get up and running, as its where i do the primary amount of work for my own small business.


The Hardware

MoBo: Intel DX58S0 - Bios revision 5506 (most current)

- Audio according to the intel site is Realtek ALC889

- Intel® 82567LM Gigabit Ethernet Controller

CPU: i7 970

GFX: Sapphire Radeon 5770

Ram: 12GB Corsair Vengence

HDD: 6 WD 1TB Green drives in Raid 1/0 (stripping over 3 mirrors)



I'm using the tonycrapX86 unishit system to install lion on the hard drives with great success. The actual install takes under 10 minutes and i'm back at the Chimera boot screen from the USB stick. As a side note, at the end of it all i'm using the guide here to get the boot-loader installed on the boot segments of the raid array.


I have also been using the guide here for what options to select in multishit, but if the number of kext's/options can be slimmed down, i'm sure its better.


Where I'm running into great difficulty is with Audio and Ethernet. I know, they are supposed to be the hardest, but i've tried everything I can think of. Initially I simply used Multi-beast to limited success. Since then i've started working on a fully customized DSDT file to try to get the machine running as vanilla as possible. I've tried every combination I have been able to find online, searching exhaustively and I still can't get the audio or ethernet to work fully.


ALSO (EDIT) - I've discovered your DSDT patches on this site and have been using that as a base for preparing my DSDT.


1) Ethernet - seems to sometimes work and sometimes not, and there is no explanation, is there a known fix to make it work fully.


2) 5.1 Audio from the ALC889 - I've gotten output but no input, or input and no output, trying numerous different DSDT and KEXT fixes for this. I need 5.1 audio for my business, or at bare minimum functioning output AND input at the same time. I've been looking into bin-patching, but I can't make any headway with this.


Other than these 2 issues, the machine runs nearly flawlessly with relatively few fixes.


Thank you in advanced for your time and let me know if you need any files from me.

Link to comment
Share on other sites

I'm going to do a full re-install of Lion on the hackintosh using as few hacks as possible listed below...

 

  • DX58S0 DSDT edit from this site along with the HDEF edit to remove the need for a HDAEnabler

  • AppleIntel8256X.kext (from this thread)

  • VoodHDA.kext (from this thread)

  • multishit with no audio kext selection or ethernet selection, using UserDSDT, and also using Chimera 1.6.0 for a bootloader

 

I'll let you know how it goes.

Link to comment
Share on other sites

OK, so audio working fine, ethernet still no go.


Patches I ended up using


- DX58S0 DSDT patch using DSDT Editor after extracting the DSDT using DSDTFixer to remove a min/max/length error.

- Did the following steps using multishit 4.1.0

- - System Utilities

- - Drivers & Bootloaders - No audio or ethernet selected - IOAHCIBlock... & 3rd Party Esata - Evoreboot, FakeSMC, NullCPUPower, Chimera (bootloader)

- After installing with multishit I applied the VoodooHDA and AppleIntel8256X Kext files from this thread using Kext Helper b7

- Removed AppleHDA from the S/L/E folder and also ran the shell commands from earlier in this thread for the ethernet

- Finished up by going through the following how to install on raid 0 guide to make the machine HDD bootable.


End result is me still scratching my head.


I've run the System Info program from the Kext area here and for the ethernet controller its showing the above mentioned kext file as the one for the controller, but for what ever reason the control panel refuses to get a proper IP from DHCP, or even when i put in a static IP, nothing will contact the outside (safari, pinging something etc). Also to note is that when i go into the system panel > network, it shows ethernet as connected, but if i go to network diagnostic from safari it shows as ethernet not connected.


Hope this helps Cassio, and I really appreciate your help with this so far.


EDIT - On the other hand, unplugging and replugging in my network cable fixed it? Rather mystified on this one.

Link to comment
Share on other sites

I have DX58SO, with i7-920 CPU, 6GB Triple Channel Ram, GT9500 1Analog/1DVI Video.

I Used unishit to install the OS and the Lion version of multishit (I copied all of the OS Updates, multishit and installation files onto the unishit USB Drive First) to install the bootloader and most of the drivers.

When I used multishit, I had to use EASYBEAST because i am having a problem with the DSDT, Then

I Had to use the E1000e LAN Driver and the ApplieAzilla Audio Kext using kext helper and had to set the System Power management to never because the system does not come out of sleep properly.


I recently found a DSDT inside of the DX58SO installer package and will the auto patcher and see if i get the DSDT to function and have my energy saving setting to work properly. But I am going to wait untill i get a Dual DVI Video card working properly.

I Hope this Helped.

Link to comment
Share on other sites

One last question and I should be completely set on this machine. I have a DVD drive that i would like to plug into the eSATA port on the back. Now the chipset is Marvell 88SE6121 Sata II controller (Dev ID - 6121). I did a search on the kext portion of this site and found several and was just wondering if you had any recommendations as to which one to use.


*Update* in the bios the only 2 options are IDE and RAID, now the DVD drive is recognized in the bios properly, and the bios is set as IDE currently, let me know if this needs to change.


Thanks in advanced!

Link to comment
Share on other sites

I guess this would be important information as well, I'm trying to use a LG HL-DT-ST GSA-H62N dvd drive plugged into the eSATA port (via a SATA to eSATA cable). I don't know if this changes anything. But the dvd drive is atleast recognized by the BIOS.


Also i've been trying the VIA ATA kext, when i reboot i seem to be getting intermittent KP's. Trying a fresh install again using the method I used earlier in this thread.

Link to comment
Share on other sites

Some versions of AppleVIAATA have problem with more than 2 GB of RAM, try another one.


This one claims to solve the problem, but it's 32 bit only

http://code.google.com/p/darwin-ata/downloads/list

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Well, rebooted several times with the new kext in there and it seems to be working fine. And when i run compatibility check with the program "System Info" the marvell driver shows a checkmark. But the DVD drive doesn't register, either in the system profile, or when a disk is inserted.

Link to comment
Share on other sites

Jed did you get the Sleep (energy saver) to work in the DSDT?


I Have a dx58so, i7-920, 6bm Ram, Powercolor HD4870, I used the AppleAzila for audio and E100e for Ethernet, Both seem to be working without any issues.. The Only issue is Powermanagement.. When the System goes to sleep from the energy saver the system does not wake. I am assuming its DSDT.


I hope your Audio and Ethernet is working for you.


Too bad there isnt a more automated way to extract and patch the DSDT. Does anyone have a good DSDT guide on how to create and modify?

Edited by Guest
Link to comment
Share on other sites

To be honest, i've disabled the machine going to sleep to avoid dealing with that. I've got it set to go to screensaver after 15 minutes and monitors to shut off at the hour mark. From what I've read though you do need to patch it in the DSDT, I just haven't bothered going into it as it something that I don't need.


Audio and Ethernet are fine using the kext's that Cassio linked earlier in this thread.


For extracting and patching the DSDT i've done it all myself. I've used DSDTFixer from the Evo team. I use it to extract the DSDT and fix any errors, BUT I don't apply any patches using that program. Once the DSDT is extracted and fixed, I apply the DX58S0 patch compiled on this found here, and patch the DSDT using DSDT Editor.


From there I just use multishit and kext helper b7 to set up the bootloader and kext files (if you check back to page 2 you can find the most recent WORKING order of things).


Hope that helps! I'll probably write a guide about this once I get the last thing working.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...