Jump to content
ruglau

NEW HACK - Would be the quite best

Recommended Posts

Sorry Guys for bother.

I really want to say thanks to all your work!


I decided to open a thread just because I'm very new on Hackintosh and I lose my self around all the forum discussions.


I have just configured a pc with:

Asus rog maximus hero XI z390

I9 9900k

Rtx 2070 (which I will use only for Windows)

And rx 580 (for the hack)

2 m2 nv 970pro and 970 evo respectively for windows and for osx


What I want for this Hack? - A dual boot OSX/WIN on 2 Different SSD and 2 different Video Cards that boot respectively on mac or windows (RX580 on mac and RTX2070 on Win)


Install AtherosE2200Ethernet.kext for TP-LINK TL-WDN4800 Wifi connection (works perfectly)

Start, reboot and shutdown works perfectly


I also send to you my DSDT file and patched it by you. But I really don't understand what it helps :D


Now the problems:

 


  •  
    [list=]
  • USB 3.0: I downloaded the InjectUSB files from your link

    downloaded notsupported from here: https://github.com/RehabMan/OS-X-USB-In ... orted.kext (hope I can link that link sorry if not) (cause I have a z390 MB)

    copy on EFI/EFI/Clover/Kexts/Other

    reboot

    But don't works noone of my USB3.0 works

    I can't download loreg cause isn't still available

 


  •  
    [list=]
  • On clover boot if I click on Windows the system show an old Windows 10 logo with white square background and do nothing (I have 2 SO on 2 different SSD - What I have to do for dual bot on clover with 2 different SSD?

 


  •  
    [list=]
  • I followed the brightness key guide, but not works (is just for apple monitor or I can use also for an ASUS monitor?)

 


  •  
    [list=]
  • Power managment guide??? I really don't understand nothing :D :D but by the way, how can monitorating temperatures/fanspeed and I have to do something for Power managment and others things connected to that?

 

[list=]Last but not least I can't see very well on my monitor: The word appear without antialiasing and also is all too saturated and contrasted. On windows with the second boot with de same monitor and the same VGA and the same profile monitor i see all good.

 

Are there others things that I have not consider? I don't wanna burn my PC for failings :D


Many Thanks to all and for next answer!

Link to comment
Share on other sites

  • Administrators

[ref]ruglau[/ref], HDMI audio don't have a volume control in Mac, native no


entries, u can hide many, just avoid hide EFI entry


post one SEND_ME here

RunMe.app

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

[ref]ruglau[/ref], use it

CLOVER.zip

reboot and extract new send_me with new files

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

You are a king.

I have to copy these files on clover EFI folder (and so replace the old) or use your folder and delete mine folder?


I also see that in your config.plist give to me you taken out the kext-dev-mode=1 and npci=0x2000 (were unecessary?)


Your kext folder contain less kext, I have to delete mine extra?


Added in 46 minutes 47 seconds:

EDIT:

I just copy your file and not delete mine. Just overwitten. (please say if I had to do)

I add kext-dev-mode=1 and npci=0x2000 in your config cause I don't know if are necessary (please say also this :( )


but! YOU are really a King! cause I see the audio outputs now.... (but still not works, Maybe I have to test the layouts?)

And also the boot on windows works good :D


The monitor problems seems was a combination problem between this monitor and OSX, but I solved :)



Now remain these problems:


- USB 3.0 I followed your tips and yes now my 3.1 gen2 works, but no work for USB 3.0 in the rear and in the front of case (the front are cabled with a 19pin on mobo)


- I don't know if it is a bullshit but I have 2 videocards one for windows and one for hack, is possible with 2 HDMI and a monitor with 2 source use NVDIA when I use Windows and use AMD when I use mac?


- I followed the brightness key guide, but not works (is just for apple monitor or I can use also for an ASUS monitor?)


- Power managment guide??? I really don't understand nothing :D :D but by the way, how can monitorating temperatures/fanspeed and I have to do something for Power managment and others things connected to that? (but maybe you just do something on my file IDK)


Thanks again Maldon! surely as soon as the salary arrives I will see to thank you with a donation, at least as a thought

Link to comment
Share on other sites

  • Administrators

[ref]ruglau[/ref], extract new send_me with new files

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

[ref]ruglau[/ref], PM, etc all looks good, i disable nvidia card in macosx too, now u have only amd working in osx


u just need solve ur usb now, follow here

https://Olarila.com/forum/viewtopic.php?p=65287#p65287

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

[ref]ruglau[/ref], Your monitor needs to support DDC/CI for this app to work.


what happens if u connect device usb in usb3 ports?

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

when I connect a drive 3.0 in 3.1 gen2 works perfect.

when I connect a drive 3.0 in 3.0 gen1 doesn't recognize

when I connect a drive 2.0 in 3.0 gen1 doesn't recognize


(also in IOREG)


other problem doesn't solved is audio (I can see the output and imput in audio preference but don't works audio)


Added in 46 minutes 8 seconds:

EDIT: i tried different layout.


I connect external speaker on the green output

1: show all outputs but none works

2: show only internal speaker and digital outputs (and works on internal speaker choice but I haven't internal just the external speaker)

5/7/11: show all outputs but only internal speaker choice works (but still I don't have an internal speaker)

13: show only earphones and if I remember digital outputs but works only on earphones choice (but still my jack is connect to external speaker)

15: The worst: doesn't work and none outputs showed


WHat I have to do?


Added in 24 minutes 49 seconds:

EIDT2: probably the best layout is the 7 but the working output is called internal speaker (and obviously it isn't internal but external)

the front panel audio doesn't works

Link to comment
Share on other sites

  • Administrators

[ref]ruglau[/ref], audio u just need a correct id

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

My comment:


Analogue audio is working as per seen here in ioreg.

 

626473035_Screenshot2018-12-29at10_54_59AM.png.d0be080c0879150cf8eeba3906b92c9d.png

 



There are 5 SSxx ports indicating USB 3.0 ports are available. Consider testing with a different USB 3.0 device

 

1222599338_Screenshot2018-12-29at10_54_05AM.png.235883ae8e712f5368a89e74351b9e7d.png

 



You should also consider removing unused kexts in your clover folder. Find out what they are and decide if you need them. Hint: You dont need that many USB injector kexts.

 

1524803560_Screenshot2018-12-29at10_55_45AM.png.538a5de17711d08b47a00ea914cf36e2.png

Donate

Gitter Chat


Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset

Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)


MSI B360 Gaming Arctic

Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)

Link to comment
Share on other sites

My comment:


Analogue audio is working as per seen here in ioreg.


Screenshot 2018-12-29 at 10.54.59 AM.png

yes audio is working, but on outputs info is called: "internal speaker instead speaker"

 

There are 5 SSxx ports indicating USB 3.0 ports are available. Consider testing with a different USB 3.0 device


Screenshot 2018-12-29 at 10.54.05 AM.png

 

I tried but didn't works 3.0 drive and 2.0 drive in that 3.0 ports :(

 

You should also consider removing unused kexts in your clover folder. Find out what they are and decide if you need them. Hint: You dont need that many USB injector kexts.


Screenshot 2018-12-29 at 10.55.45 AM.png

 

how can I know whcih one is useless?

Link to comment
Share on other sites

[ref]ruglau[/ref],

yes it states internal speaker instead thats fine

to set your usb follow onemans guide

for kext see attached pic for what kexts you need

kexts.jpg.e12a08ce34abc93527475e6230c531f2.jpg

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

Oh wait :)


I just followed the usb guide but just 3.1 gen2 works. :(


For kext some of your selection I really need, like atheros for internet cards.


Eficheckdisabler what is it?


Others I don't knoe if need or not...



But now my real problem is that 3.0 usb doesn't work, only 3.1 gen 2 and uab 2.0

Link to comment
Share on other sites

  • Administrators

[ref]ruglau[/ref], use Eficheckdisabler for disable Apple Spy :mrgreen::boxing

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[ref]ruglau[/ref], ok want to sure with lan then switch the 2 an put back 300 series injector Eficheckdisabler place back didnt realize its a apple check file blocker

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

[ref]ruglau[/ref], use Eficheckdisabler for disable Apple Spy :mrgreen::boxing

so I have to keep? :D

[ref]ruglau[/ref], ok want to sure with lan then switch the 2 an put back 300 series injector Eficheckdisabler place back didnt realize its a apple check file blocker

for make work the 3.0? sorry guys I'm not that inside theese things
Link to comment
Share on other sites

[ref]ruglau[/ref], for usb to work follow this guide

">

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

[ref]ruglau[/ref],


1. I think you need to understand what HSxx and SSxx are by reading the quick response HERE


2. There is no "probably my two port type-c". You need to test all ports type A and type C using appropriate testing devices i.e you will need a reliable USB type 3 device or USB type C device and so on. Reading your motherboard documentations helps.


3. There is no "maybe my 3.0 unworking" on HSxx port.


3. It is also helpful for users to know their motherboard specifications e.g what type of USB chipset is in use. Only intel chipsets are fully supported.


4. Lastly, Hackintosh are not perfect Apple product.


Having said that, I have no issues detecting my USB type C and USB type A on my build. Hint: Use reliable detection device for testing.

Donate

Gitter Chat


Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset

Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)


MSI B360 Gaming Arctic

Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)

Link to comment
Share on other sites

[ref]ruglau[/ref], Yes you should test ALL ports (as per the guide suggests) with proper device (as per the guide suggests). I think the answer is obvious that you will not be able to determine which ports are used by USB type C if you do not have the tools and possibly lose other ports due to the lack of test method.

Donate

Gitter Chat


Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset

Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)


MSI B360 Gaming Arctic

Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
  • Create New...
The popup will be closed in 15 seconds...