Jump to content
contactwajeeh

Please help Asus X541U - Mojave Install, Wifi & Sound Not working

Recommended Posts

  • Administrators

[ref]contactwajeeh[/ref], DSDT.aml.zip

 

change GFX0 to IGPU
47465830 
49475055 

change HDAS to HDEF
48444153 
48444546 

change HECI to IMEI
48454349 
494d4549 

change SAT0 to SATA
53415430 
53415441 

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Hello Maldon,


Appreciate your swift response. I tried with your DSDT and suggested patches, it didnt helped in enabling sound, nor wifi. However I got the battery icon to show but its not showing the current status of the battery like always on 0%. Please find attached the dump after applying your suggestions above.


Thanks in advance.

Send me Mohammeds-MacBook-Pro.zip

Link to comment
Share on other sites

Hello Maldon,


After spending time reading a lot, I was able to get the install working now the following things work out of the box on a fresh install.


1. Graphics fixed (by using your folder)

2. Audio fixed (by injecting layout 22)

3. lan / ethernet works


The following things are broken

1. Wifi (most probably an unsupported wifi module - RTL8723BE) - Do I have an option to opt for the external usb wifi dongle here?

2. Battery Status - The icon shows as 0% always and as soon as I unplug, I get the batter low message "Your mac will sleep soon...."

3. The trackpad isn't detected, in settings its show no trackpad


Can you please help me on these, I am attaching the files from the runme app for your kind perusal. Looking forward to hear from you soon.

Send me Mohammeds-MacBook-Pro.zip

Link to comment
Share on other sites

[ref]contactwajeeh[/ref], DSDT.aml.zip

 

Awesome. it fixed

1. battery percentage

2. screen brightness (which I didn't checked earlier wasn't working for me).

3. Touchpad detected (not all gestures are working but its fine atleast its working)



but after using this DSDT it's working absolutely fine. Anything else I should be looking for? Please advise and thanks so much for your time.


A small gift for you Confirmation number: 1EB35183HG398625H.

Link to comment
Share on other sites

Hello Maldon,


One more request, I decided to update my laptop to Catalina.


Everything worked fine, but I got a kernel panic when I used the Voodooi2C & Voodooi2CHID kexts, if I remove them from the clover folder it works fine but no trackpad. I am here with attaching the output from runme app can you please look in to it.

Send me Wajees-MacBook-Pro.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...