Jump to content
Akshunhiro

Help with GA-B360M-D3H i3-8100 iGPU

Recommended Posts

Hi all,


I'm kind of stuck with a new build. It's been a while since I've played with another hackintosh and figured this would be a good place to start.


Posting from the current install but experiencing issues with audio and also receive a KP when trying to install the 10.14.1 update.


It took quite a while to get the iGPU working. BIOS setting were all correct but I was experiencing bad window glitches even though System Report showed 1536 VRAM. LAN is working okay out of the box. Didn't have to do anything from what I could tell.


I also followed the general guide on Hackintosher for BIOS settings. Probably main note is XHCI hand-off: Enabled


Tried again today with a pre-built EFI from Hackintosher but, like my earlier attempt, I didn't have video after the reboot back into the installer (initial video output worked). I am using DisplayPort as per other posts about supported outputs. I wasn't sure whether it was due to APFS or the Intel iGPU so I'm not sure which settings I changed made it work.


This will be a headless setup (mainly used for IP camera server and light encoding) so not too worried about all the features working but would be nice to get audio working and found the cause of the KB when trying to update to 10.14.1


Oh and I think it was the same KP which popped-up after it completed the install but rebooted into Mojave fine.


Thanks in advance!

config.plist.zip

20181201_135847_HDR.thumb.jpg.e6f0c29958cbe3e91b7c03619ad4d96f.jpg

Link to comment
Share on other sites

[ref]Akshunhiro[/ref],


Read here for graphics issues https://www.insanelymac.com/forum/topic/334899-intel-framebuffer-patching-using-whatevergreen/


For sound, use DPCIManager app to find out your audio codec id. Then read here if codec is supported https://github.com/acidanthera/AppleALC

Donate

Gitter Chat


Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset

Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)


MSI B360 Gaming Arctic

Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)

Link to comment
Share on other sites

Thankyou! I will take a look. Also trying to use RunMe.app but keep getting;

Generating system info, this may take a while.

Saving IOReg...

IOREG dump failed. Retrying

Increased delay x2 for IOREG dump. This will take a while...(33 sec)

This keeps repeating.

Attached what I could get so far.


Added in 34 minutes 7 seconds:

Okay, I got 10.14.1 installed. Didn't realise I simply needed to boot to "Install macOS Mojave" to continue the update.

HackMini.zip

Link to comment
Share on other sites

Still no luck with audio

Your GA-B360M-D3H board uses ALC892 codec https://www.gigabyte.com/Motherboard/B360M-D3H-rev-10#sp


You can use AppleALC.kext + Lilu.kext with layout ID=1 https://github.com/acidanthera


You should be looking at kexts folder instead.

Donate

Gitter Chat


Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset

Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)


MSI B360 Gaming Arctic

Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)

Link to comment
Share on other sites

Thanks for the quick reply. Yes, that's right. I had followed a guide (https://hackintosher.com/guides/get-hackintosh-audio-working/) for testing and changing layout id. Wasn't working at all with any of them. It's back on 1 and I also tested UseIntelHDMI to see if I get any output devices listed.


I also made sure to add;

 

624587579_ScreenShot2018-12-01at6_32_08pm.png.700bbfdfe1a17b0973a06e768c53d91f.png

 

Kexts are;

 

1740537154_ScreenShot2018-12-01at6_29_32pm.png.8dda371d19b4af9d76cb7b9cbc92dca3.png

Edited by Guest
Link to comment
Share on other sites

I think I gave you wrong files LOL. Let me check.


EDit: Yes, I did! Sorry for the blunder. Need to dig my trashcan now


Edit2: Check again. Thnks.

 

EFI.zip

Donate

Gitter Chat


Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset

Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)


MSI B360 Gaming Arctic

Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)

Link to comment
Share on other sites

Thanks so much for your time and effort. I found motherboard BIOS had reset back to F6 (I had the choice when updating of doing Fast or Intact) so updated again to F11. Found the video guide for "RunMe.app in Mojave" so that's working fine now. Posted the zip in the DSDT patch thread! Do donations go to the whole team?

Link to comment
Share on other sites

  • Administrators

check if work, [ref]Akshunhiro[/ref],

CLOVER.zip

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

[ref]Akshunhiro[/ref], DSDT.aml.zip

test sleep, shutdown and all usb port with usb 3 device

let me know

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

[ref]Akshunhiro[/ref], for a full USB solution, check here

https://Olarila.com/forum/viewtopic.php?p=65287#p65287

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Hmmm, doesn't seem to be working.


I deleted my existing entry for Mojave under kexts to patch "Find: 83 FB 0F 0F 83 03 05 00 00 Replace: 83 FB 0F 90 90 90 90 90 90"


and added "uia_include=SS01;SS02;SS05;SS06;HS07;HS08" in boot arguments but it doesn't seem to have any effect.


I looked at RehabMan's guide and, holy shit, pretty complex.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...