Jump to content
t3ch

sound and boot problem

Recommended Posts

hello!


I have installed high Sierra. to install it I have to format all disk with live usb Debian and use gparted to set Mac partition scheme.. then installer have work. now sound and boot still not working as it should..


now for booting iam using usb installer stick and for sound am not sure how to continue.


"in /System/Library/Extensions I have only AppleHDA.kext but AppleHDAController.kext and AppleHDAHardwareConfigDriver.kext are missing. " this have found by viewing AppleHDA.kext in plugins directory.!


here is some system info:

cat /proc/asound/card0/codec#0

Codec: Conexant CX20724

Address: 0

AFG Function Id: 0x1 (unsol 1)

Vendor Id: 0x14f150f4

Subsystem Id: 0x103c8120

Revision Id: 0x100101

No Modem Function Group found

Default PCM:

rates [0x140]: 48000 96000

bits [0xa]: 16 24

formats [0x1]: PCM

Default Amp-In caps: N/A

Default Amp-Out caps: N/A

State of AFG node 0x01:

Power states: D0 D1 D2 D3 D3cold S3D3cold CLKSTOP EPSS

Power: setting=D0, actual=D0

GPIO: io=7, o=0, i=0, unsolicited=1, wake=1

IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0

IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0

IO[2]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0

IO[3]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0

IO[4]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0

IO[5]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0

IO[6]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0

Node 0x10 [Audio Output] wcaps 0xc1d: Stereo Amp-Out R/L

Control: name="Headphone Playback Volume", index=0, device=0

ControlAmp: chs=3, dir=Out, idx=0, ofs=0

Control: name="Headphone Playback Switch", index=0, device=0

ControlAmp: chs=3, dir=Out, idx=0, ofs=0

Device: name="CX20724 Analog", type="Audio", device=0

Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=1

Amp-Out vals: [0x80 0x80]

Converter: stream=1, channel=0

PCM:

rates [0x540]: 48000 96000 192000

bits [0xa]: 16 24

formats [0x1]: PCM

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x11 [Audio Output] wcaps 0xc1d: Stereo Amp-Out R/L

Control: name="Speaker Playback Volume", index=0, device=0

ControlAmp: chs=3, dir=Out, idx=0, ofs=0

Control: name="Speaker Playback Switch", index=0, device=0

ControlAmp: chs=3, dir=Out, idx=0, ofs=0

Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=1

Amp-Out vals: [0x36 0x36]

Converter: stream=1, channel=0

PCM:

rates [0x540]: 48000 96000 192000

bits [0xa]: 16 24

formats [0x1]: PCM

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x12 [beep Generator Widget] wcaps 0x70000c: Mono Amp-Out

Control: name="Beep Playback Volume", index=0, device=0

ControlAmp: chs=1, dir=Out, idx=0, ofs=0

Control: name="Beep Playback Switch", index=0, device=0

ControlAmp: chs=1, dir=Out, idx=0, ofs=0

Amp-Out caps: ofs=0x07, nsteps=0x07, stepsize=0x0f, mute=0

Amp-Out vals: [0x03]

Node 0x13 [Audio Input] wcaps 0x100d1b: Stereo Amp-In R/L

Control: name="Capture Volume", index=0, device=0

ControlAmp: chs=3, dir=In, idx=1, ofs=0

Control: name="Capture Switch", index=0, device=0

ControlAmp: chs=3, dir=In, idx=1, ofs=0

Device: name="CX20724 Analog", type="Audio", device=0

Amp-In caps: ofs=0x4a, nsteps=0x50, stepsize=0x03, mute=1

Amp-In vals: [0x80 0x80] [0x50 0x50] [0x50 0x50] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]

Converter: stream=1, channel=0

SDI-Select: 0

PCM:

rates [0x140]: 48000 96000

bits [0xa]: 16 24

formats [0x1]: PCM

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 7

0x18 0x19 0x1a* 0x15 0x1d 0x1e 0x1f

Node 0x14 [Audio Input] wcaps 0x100d1b: Stereo Amp-In R/L

Amp-In caps: ofs=0x4a, nsteps=0x50, stepsize=0x03, mute=1

Amp-In vals: [0x4a 0x4a] [0x4a 0x4a] [0x4a 0x4a]

Converter: stream=0, channel=0

SDI-Select: 0

PCM:

rates [0x140]: 48000 96000

bits [0xa]: 16 24

formats [0x1]: PCM

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 3

0x1a* 0x15 0x1f

Node 0x15 [Vendor Defined Widget] wcaps 0xf0050b: Stereo Amp-In

Amp-In caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=1

Amp-In vals: [0x4a 0x4a] [0x4a 0x4a]

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 2

0x10* 0x11

Node 0x16 [Pin Complex] wcaps 0x400581: Stereo

Pincap 0x0001001c: OUT HP EAPD Detect

EAPD 0x2: EAPD

Pin Default 0x03211040: [Jack] HP Out at Ext Left

Conn = 1/8, Color = Black

DefAssociation = 0x4, Sequence = 0x0

Pin-ctls: 0xc0: OUT HP

Unsolicited: tag=01, enabled=1

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 2

0x10* 0x11

Node 0x17 [Pin Complex] wcaps 0x400501: Stereo

Pincap 0x00010010: OUT EAPD

EAPD 0x2: EAPD

Pin Default 0x91170110: [Fixed] Speaker at Int Rear

Conn = Analog, Color = Unknown

DefAssociation = 0x1, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x40: OUT

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 2

0x10 0x11*

Node 0x18 [Pin Complex] wcaps 0x40048b: Stereo Amp-In

Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0

Amp-In vals: [0x00 0x00]

Pincap 0x00001324: IN Detect

Vref caps: HIZ 50 80

Pin Default 0x40f001f0: [N/A] Other at Ext N/A

Conn = Unknown, Color = Unknown

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00: VREF_HIZ

Unsolicited: tag=00, enabled=0

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x19 [Pin Complex] wcaps 0x40048b: Stereo Amp-In

Control: name="Mic Boost Volume", index=0, device=0

ControlAmp: chs=3, dir=In, idx=0, ofs=0

Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0

Amp-In vals: [0x00 0x00]

Pincap 0x00001324: IN Detect

Vref caps: HIZ 50 80

Pin Default 0x03a11030: [Jack] Mic at Ext Left

Conn = 1/8, Color = Black

DefAssociation = 0x3, Sequence = 0x0

Pin-ctls: 0x24: IN VREF_80

Unsolicited: tag=02, enabled=1

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x1a [Pin Complex] wcaps 0x40040b: Stereo Amp-In

Control: name="Internal Mic Boost Volume", index=0, device=0

ControlAmp: chs=3, dir=In, idx=0, ofs=0

Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0

Amp-In vals: [0x00 0x00]

Pincap 0x00000020: IN

Pin Default 0x95a60120: [Fixed] Mic at Int Top

Conn = Digital, Color = Unknown

DefAssociation = 0x2, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x20: IN

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x1b [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x1c [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x1d [Pin Complex] wcaps 0x40058b: Stereo Amp-In

Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0

Amp-In vals: [0x00 0x00]

Pincap 0x00011334: IN OUT EAPD Detect

Vref caps: HIZ 50 80

EAPD 0x2: EAPD

Pin Default 0x40f001f0: [N/A] Other at Ext N/A

Conn = Unknown, Color = Unknown

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x40: OUT VREF_HIZ

Unsolicited: tag=00, enabled=0

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 2

0x10* 0x11

Node 0x1e [Pin Complex] wcaps 0x40048b: Stereo Amp-In

Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0

Amp-In vals: [0x00 0x00]

Pincap 0x00000024: IN Detect

Pin Default 0x40f001f0: [N/A] Other at Ext N/A

Conn = Unknown, Color = Unknown

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00:

Unsolicited: tag=00, enabled=0

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x1f [Pin Complex] wcaps 0x40040b: Stereo Amp-In

Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0

Amp-In vals: [0x00 0x00]

Pincap 0x00000020: IN

Pin Default 0x40f001f0: [N/A] Other at Ext N/A

Conn = Unknown, Color = Unknown

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00:

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x20 [Audio Output] wcaps 0x611: Stereo Digital

Converter: stream=0, channel=0

Digital:

Digital category: 0x0

IEC Coding Type: 0x0

PCM:

rates [0x540]: 48000 96000 192000

bits [0xe]: 16 20 24

formats [0x5]: PCM AC3

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Node 0x21 [Pin Complex] wcaps 0x400701: Stereo Digital

Pincap 0x00000010: OUT

Pin Default 0x40f001f0: [N/A] Other at Ext N/A

Conn = Unknown, Color = Unknown

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00:

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 1

0x20

Node 0x22 [Pin Complex] wcaps 0x400501: Stereo

Pincap 0x00010010: OUT EAPD

EAPD 0x2: EAPD

Pin Default 0x40f001f0: [N/A] Other at Ext N/A

Conn = Unknown, Color = Unknown

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00:

Power states: D0 D1 D2 D3 EPSS

Power: setting=D0, actual=D0

Connection: 2

0x10* 0x11

root@debian:/home/user# cat /proc/asound/card0/codec#2

Codec: Intel Skylake HDMI

Address: 2

AFG Function Id: 0x1 (unsol 0)

Vendor Id: 0x80862809

Subsystem Id: 0x80860101

Revision Id: 0x100000

No Modem Function Group found

Default PCM:

rates [0x0]:

bits [0x0]:

formats [0x0]:

Default Amp-In caps: N/A

Default Amp-Out caps: N/A

State of AFG node 0x01:

Power states: D0 D3 CLKSTOP EPSS

Power: setting=D0, actual=D0, Clock-stop-OK

GPIO: io=0, o=0, i=0, unsolicited=0, wake=0

Node 0x02 [Audio Output] wcaps 0x6611: 8-Channels Digital

Converter: stream=0, channel=0

Digital: Enabled KAE

Digital category: 0x0

IEC Coding Type: 0x0

PCM:

rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000

bits [0x1a]: 16 24 32

formats [0x5]: PCM AC3

Power states: D0 D3 EPSS

Power: setting=D0, actual=D0

Node 0x03 [Audio Output] wcaps 0x6611: 8-Channels Digital

Converter: stream=0, channel=0

Digital: Enabled KAE

Digital category: 0x0

IEC Coding Type: 0x0

PCM:

rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000

bits [0x1a]: 16 24 32

formats [0x5]: PCM AC3

Power states: D0 D3 EPSS

Power: setting=D0, actual=D0

Node 0x04 [Audio Output] wcaps 0x6611: 8-Channels Digital

Converter: stream=0, channel=0

Digital: Enabled KAE

Digital category: 0x0

IEC Coding Type: 0x0

PCM:

rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000

bits [0x1a]: 16 24 32

formats [0x5]: PCM AC3

Power states: D0 D3 EPSS

Power: setting=D0, actual=D0

Node 0x05 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP

Control: name="IEC958 Playback Con Mask", index=0, device=0

Control: name="IEC958 Playback Pro Mask", index=0, device=0

Control: name="IEC958 Playback Default", index=0, device=0

Control: name="IEC958 Playback Switch", index=0, device=0

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x00 0x00]

Pincap 0x0b000094: OUT Detect HBR HDMI DP

Pin Default 0x18560010: [Jack] Digital Out at Int HDMI

Conn = Digital, Color = Unknown

DefAssociation = 0x1, Sequence = 0x0

Pin-ctls: 0x00:

Unsolicited: tag=00, enabled=0

Power states: D0 D3 EPSS

Power: setting=D0, actual=D0

Devices: 0

Connection: 0

In-driver Connection: 3

0x02 0x03 0x04

Node 0x06 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP

Control: name="IEC958 Playback Con Mask", index=1, device=0

Control: name="IEC958 Playback Pro Mask", index=1, device=0

Control: name="IEC958 Playback Default", index=1, device=0

Control: name="IEC958 Playback Switch", index=1, device=0

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x00 0x00]

Pincap 0x0b000094: OUT Detect HBR HDMI DP

Pin Default 0x18560020: [Jack] Digital Out at Int HDMI

Conn = Digital, Color = Unknown

DefAssociation = 0x2, Sequence = 0x0

Pin-ctls: 0x00:

Unsolicited: tag=00, enabled=0

Power states: D0 D3 EPSS

Power: setting=D0, actual=D0

Devices: 0

Connection: 0

In-driver Connection: 3

0x02 0x03 0x04

Node 0x07 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x00 0x00]

Pincap 0x0b000094: OUT Detect HBR HDMI DP

Pin Default 0x58560030: [N/A] Digital Out at Int HDMI

Conn = Digital, Color = Unknown

DefAssociation = 0x3, Sequence = 0x0

Pin-ctls: 0x00:

Unsolicited: tag=00, enabled=0

Power states: D0 D3 EPSS

Power: setting=D0, actual=D0

Devices: 0

Connection: 0

Node 0x08 [Vendor Defined Widget] wcaps 0xf00000: Mono


root@debian:/home/user# lspci

00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)

00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)

00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)

00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)

00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)

00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)

00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)

00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)

00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)

00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)

00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)

00:1f.3 Multimedia audio controller: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

03:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)

04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)



####



lscpu

Architecture: x86_64

CPU op-mode(s): 32-bit, 64-bit

Byte Order: Little Endian

CPU(s): 4

On-line CPU(s) list: 0-3

Thread(s) per core: 2

Core(s) per socket: 2

Socket(s): 1

NUMA node(s): 1

Vendor ID: GenuineIntel

CPU family: 6

Model: 78

Model name: Intel® Core i5-6200U CPU @ 2.30GHz

Stepping: 3

CPU MHz: 603.515

CPU max MHz: 2800.0000

CPU min MHz: 400.0000

BogoMIPS: 4800.00

Virtualization: VT-x

L1d cache: 32K

L1i cache: 32K

L2 cache: 256K

L3 cache: 3072K

NUMA node0 CPU(s): 0-3

Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch epb invpcid_single kaiser tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid mpx rdseed adx smap clflushopt intel_pt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp



#####




lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 006: ID 138a:003f Validity Sensors, Inc. VFS495 Fingerprint Reader

Bus 001 Device 005: ID 8087:0a2a Intel Corp.

Bus 001 Device 004: ID 05c8:0383 Cheng Uei Precision Industry Co., Ltd (Foxlink)

Bus 001 Device 003: ID 0718:0619 Imation Corp.

Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Link to comment
Share on other sites

  • Administrators

now have install this kext: https://github.com/acidanthera/AppleALC/releases version 1.2.8 because couldn't find applealc before but if try to view package content there is only this:

u can boot into system

if yes run app and post files here

RunMe.app

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

have replaced clover and restarted but same it stuck with some Intel console thing and last line is DHCP: *.. if screenshot help can make it. sound can't fix too.. have tried AppleHDAPatcher with AppleALC-master -> resources -> dir: CX20724 and restart and didn't work too.. :(


and another thing that is not related with topic but maybe you know something.. for publishing apple app you need iPhone to manage two factor authentication? :x


:)


thanks!

Edited by Guest
Link to comment
Share on other sites

have tried AppleHDAPatcher with AppleALC-master -> resources -> dir: CX20724 and restart and didn't work too

You can not use both methods, either use AppleHDA Patcher or AppleALC, never both or this will result in never having your Audio working.

btn_donate_SM.gif
Link to comment
Share on other sites

now have fixed boot with mounting EFI partition to some directory and then copy directory from system partition /EFI/boot to EFI partition and clover too it was missing..


but your clover stuck on loading last thing is VoodooPS2Controler. clover from installation CD works..


and sound still not working. have tried copy AppleALC.kext to partition EFI to CLOVER/kexts/Other/.. and don't help..


thanks

Link to comment
Share on other sites

  • Administrators

If you have a boot error, please use -v debug=0x100 boot arg, take a photo and post here.


Are you using InjectKexts as Yes in your config.plist?

Did you repair the disk permissions?

Thanks & Regards

IdeaPad Gaming 3i  Aspire A515-52 • Clover / OpenCore
We are in a great Forum, so, let's have some fun and learn from each other!

btn_donate_SM.gif

Link to comment
Share on other sites

boot args are:

dart=0 -v keepsyms=1 npci=0x2000 debug=0x100 kext-dev-mode=1 -no_compat_check


and InjectKext is YES


boot is working with clover from installation cd 10.13.6 but with clover that MaldOn have uploaded is kernel panic but screen get unviewable so photo don't help.. :)


what is the best way to repair disk permissions and why they need to be fixed, for what? you mean .kext files?


these .kext files should have permissions as

chmod -R 755

chown -R root:wheel ?


if I use AppleALC.kext in boot clover kexts/Other/AppleALC.kext, do I need to remove AppleHDA.kext from /System/Library/Extensions/AppleHDA.kext?

Link to comment
Share on other sites

  • Administrators

what is the best way to repair disk permissions and why they need to be fixed, for what? you mean .kext files?

Download KextUtility

 

if I use AppleALC.kext in boot clover kexts/Other/AppleALC.kext, do I need to remove AppleHDA.kext from /System/Library/Extensions/AppleHDA.kext?

 

No. Just make sure that this AppleHDA are not a patched version, but the original = Without patches

Thanks & Regards

IdeaPad Gaming 3i  Aspire A515-52 • Clover / OpenCore
We are in a great Forum, so, let's have some fun and learn from each other!

btn_donate_SM.gif

Link to comment
Share on other sites

AppleHDA original:


I think because dates are same of all files its not modified? :) I have trying to modify some things but think this is original of HDA.. when have modifying it before have made copy to desktop and later have copy it back.. :) maybe have move it because if u copy it dates change..?


clover: :)

CLOVER.zip

CLOVER.zip

Edited by Guest
Link to comment
Share on other sites

iam not sure any more but before there was some files already. I have use clover installer and don't know if more things.. if I use HS installer and install over(with out erasing disk) its all original?

Link to comment
Share on other sites

AppleHDA original:


I think because dates are same of all files its not modified? I have trying to modify some things but think this is original of HDA.. when have modifying it before have made copy to desktop and later have copy it back.. maybe have move it because if u copy it dates change..?

try this:Arquivo Comprimido.zip

Install AppleHDA.kext in System/Library/Extensions.

rebuild caches and repair permissions.

btn_donate_SM.gif
Link to comment
Share on other sites

attached /L/E folder screenshot.


have downloaded and moved AppleHDA to /S/L/E then have run kext utility and restart and still no sound. when os is loading something writes about AppleALC but goes trough too fast. is anywhere loged what is written on startup?

214513849_ScreenShot2018-07-25at21_47_49.thumb.png.79e24c5a8e85201c7738b9eaf71cd196.png

Link to comment
Share on other sites

  • Administrators

when os is loading something writes about AppleALC but goes trough too fast. is anywhere loged what is written on startup?

 

Run this app, and upload the file result here.

RunMe

Thanks & Regards

IdeaPad Gaming 3i  Aspire A515-52 • Clover / OpenCore
We are in a great Forum, so, let's have some fun and learn from each other!

btn_donate_SM.gif

Link to comment
Share on other sites

attached, maybe need to be different layout-id=1 ?


Audio HDA (addr:0x1F0003) setting specified layout-id=1 (0x1)


on this page for layout-id it says something about 3 and 13?

page: https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

line: Conexant CX20724 layout 3, 13 13 (10.9) —


Mirone: have tried but looks the same


now have try to change layout-id with clover configuratior from 1 to 3 but same.. and in settings -> sound there is even no device found what about hearing anything.. :)

Send me t3chs-MacBook-Pro.zip

Link to comment
Share on other sites

If you want to follow other processes or other people feel free to do so, if you want to follow my methods I suggest you do what I tell you if I can not help you.


follow these steps:

1- Delete AppleALC.kext or similar from your EFI / CLOVER / KEXTS folder

2- Replace current config.plist to attached

3- Copy AppleHDA.kext and CX20724.kext to System / Library / Extensions

4- Copy the RepairPermissions folder to your desktop and run Repair.command (two clicks on the file)

 

Files.zip

btn_donate_SM.gif
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...