Jump to content

Mac OS X 10.6.3 Snow Leopard bootable USB for Intel PCs


Recommended Posts

Boot with the installer, open terminal (utilities menu) and rename AppleHPET from installed partition

cd /Volumes/"your partition name"/System/Library/Extensions
mv AppleHPET.kext AppleHPET.kext.orig

Boot with -f and you should have working mouse.


How to patch IRQs

http://Olarila.com/forum/viewtopic.php?f=19&t=634


For networking you need to install proper kext

http://Olarila.com/forum/viewtopic.php?f=28&t=1694

Link to post
Share on other sites
  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

**The image is not a Distro, is a clean image without any mod with Clover bootloader, essentials kexts and patches, all inside Clover folder**   --Download Updated Images https://w

Posted Images

Boot with the installer, open terminal (utilities menu) and rename AppleHPET from installed partition

cd /Volumes/"your partition name"/System/Library/Extensions
mv AppleHPET.kext AppleHPET.kext.orig

Boot with -f and you should have working mouse.


How to patch IRQs

http://Olarila.com/forum/viewtopic.php?f=19&t=634


For networking you need to install proper kext

http://Olarila.com/forum/viewtopic.php?f=28&t=1694

Ok I managed to get my mouse and internet working but I can't manage bootloader to work. I installed it with Chameleon Wizard and when I'm trying to boot I get apple gray logo freeze when I tried to boot with -v -f I saw loading up kexts and then a black screen...

Link to post
Share on other sites
Try to use same Chameleon version as in USB installer.
I installed 2.1 r2069 not 2.1 r2109 which is on the USB because I couldn't find a working installer but that didin't fix the problem anyway. But in the start when I tried to boot it showed me that it can't find /mach_kernel but after some tries to boot it worked but I got black screen anyways.
Link to post
Share on other sites
Try to copy boot file and Extra folder from USB to HD.
I only copied Extra folder because I couldn't find a boot file. But that didin't help, I used boot file from r2069 version and now everytime when I'm trying to boot it shows Can't find /mach_kernel.
Link to post
Share on other sites
mach_kernel should be there, it's installed by default, I have no idea why it's not, you can copy from the installer.


Both mach_kernel and boot files are hidden

http://Olarila.com/forum/viewtopic.php?f=2&t=2919

Yep, mach_kernel was there. I tried to use boot file from USB but it gave me this


boot0: test

boot0: test

boot0: done

boot1: error


When I tried to use mach_kernel from the USB with boot file from r2069 version it gave me the same error Can't find /mach_kernel

Link to post
Share on other sites
If you are using the installer from this topic, boot file is Clover, copy boot1 from USB and rename it to boot.

Yes I'm using installer from the topic, boot file worked but it still shows the same can't find /mach_kernel.

Link to post
Share on other sites
Can you boot the installed system if you start from USB? Did you copy Extra folder from USB to HD?

Uh, I forgot that I deleted it. Okay computers boots without problems now but now with those IRQs, I patched them, restored AppleHPET.kext but my mouse didin't work after restart. And another problem is with graphics, kext is installed but I can only use 1024x768 resolution and programs like Google Chrome are laggy.

Link to post
Share on other sites
Make sure you have device HPET in DSDT and IRQs patch is applied. Put compiled DSDT.aml in /Extra.


X3100 kexts are 32 bit only so you have to add arch=i386 to kernel flags. If your device ID is 2a12 you need to patch kexts

http://Olarila.com/forum/viewtopic.php?f=3&t=144

I added arch=i386 to the kernel flags, patched kexts because yes my device ID is 2a12. But that didin't help, maybe I used wrong kexts?



And how to add device HPET to the DSDT?

Link to post
Share on other sites

You should use original kexts, just run the commands to patch them and update caches

sudo perl -pi -e 's|\x86\x80\x02\x2a|\x86\x80\x12\x2a|g' /System/Library/Extensions/AppleIntelGMAX3100FB.kext/AppleIntelGMAX3100FB
sudo perl -pi -e 's|0x2A028086|0x2A128086|g' /System/Library/Extensions/AppleIntelGMAX3100FB.kext/Info.plist
sudo perl -pi -e 's|\x86\x80\x02\x2a|\x86\x80\x12\x2a|g' /System/Library/Extensions/AppleIntelGMAX3100.kext/Contents/MacOS/AppleIntelGMAX3100
sudo perl -pi -e 's|0x2a028086|0x2a128086|g' /System/Library/Extensions/AppleIntelGMAX3100.kext/Contents/Info.plist
sudo touch /System/Library/Extensions

 

If there's no HPET in your DSDT, use this patch

http://Olarila.com/Patches/Misc/New%20HPET.txt

Link to post
Share on other sites
You should use original kexts, just run the commands to patch them and update caches

sudo perl -pi -e 's|\x86\x80\x02\x2a|\x86\x80\x12\x2a|g' /System/Library/Extensions/AppleIntelGMAX3100FB.kext/AppleIntelGMAX3100FB
sudo perl -pi -e 's|0x2A028086|0x2A128086|g' /System/Library/Extensions/AppleIntelGMAX3100FB.kext/Info.plist
sudo perl -pi -e 's|\x86\x80\x02\x2a|\x86\x80\x12\x2a|g' /System/Library/Extensions/AppleIntelGMAX3100.kext/Contents/MacOS/AppleIntelGMAX3100
sudo perl -pi -e 's|0x2a028086|0x2a128086|g' /System/Library/Extensions/AppleIntelGMAX3100.kext/Contents/Info.plist
sudo touch /System/Library/Extensions

 

If there's no HPET in your DSDT, use this patch

http://Olarila.com/Patches/Misc/New%20HPET.txt

I did that but it didin't help :(
Link to post
Share on other sites
  • 1 year later...

Hi, thanks for the guide. I have successfully installed the os on my dell inspiron 1525 using the boot option 1. I cannot load the os without usb. How do I change that to normal boot.

There is no audio or WiFi connectivity also.

Looking forward for your help.

Link to post
Share on other sites
  • 11 months later...
  • 1 month later...
  • Administrators
8 hours ago, dr.msnagi said:

will this version work with dell latitude d531 ? it is an amd lap

no, u need change things inside image for put ur amd to boot

Link to post
Share on other sites
  • 2 months later...
  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap