Jump to content
ūüéČ [ IMPORTANT ] Premium and Donators users ūüéČ √ó

ESXI 7.0 Catalina - can't get rx580 gpu to work.


Recommended Posts

Hi,

I'm on VMWare ESXI 7.0b with rx580 passed as gpu passthrough. 

I can't seem to get the HW acceleration working or display the vm on monitor. 

I've applied Lilu & Whatevergreen kext and it changed to GFX0 and gave the name to the device in system report however it is still not identified as display and can't really use it.

The display that is available is the vmware virtual display.

I'm attaching dsdt.aml dump that I dumped through Hackintool.

Thanks so much and I hope you can help me.

Some Images:

AvUIulCd.png

eE2Z36rY.png

eHteDLXX.png

t5Bu64du.png

 

DSDT.aml

Edited by kokozaurs
Link to comment
Share on other sites

  • Administrators

have two gpus? or igpu+dgpu?

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

27 minutes ago, MaLd0n said:

have two gpus? or igpu+dgpu?

ESXI passes through it's internal vmware display driver to osx naturally. Thats the display with 128MB Vram. It's used only for remote console etc.

I've attached single gpu through passthrough to the vm - thats the rx580. There's also the hdmi audio interface passed through. See vSphere settings:

o3CRombL.png

 

I need the RX580 to get recognized as display and have hw acceleration. 

 

It seems like it appears in the dsdt but for some reason it's just sitting there and macOS is not using it for anything. 

Edited by kokozaurs
Link to comment
Share on other sites

  • Administrators
28 minutes ago, kokozaurs said:

I have been fighting with this for days but can't figure it out. 

save one ioreg

https://olarila.com/files/Utils/IORegistryExplorer.app.zip

  • Like 1

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

67df is native 

this vm is strange 

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

9 minutes ago, MaLd0n said:

67df is native 

this vm is strange 

It is visible though, but i'm not sure why it doesn't initialize any of the gpu properties. 

Even though it's listed in macos, the hw acceleration is not working, its not recognized by any apps and none of the ports work. 

it only appeared as rx580 after whatevergreen, before that it was just a random display with no name, but again - no properties. 

it almost seems like it's not loading the graphics driver? I'm not sure. 

Link to comment
Share on other sites

  • Administrators

is not load

what ur motherboard? lets try real installation

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

9 hours ago, MaLd0n said:

is not load

what ur motherboard? lets try real installation

its running on dell r720 with 0x3d66 motherboard. but i'm not sure if the VM expose the motherboard to mac like that.

 

maybe the problem is that there is no igpu?

 

I cant seem to find anyone that has figured out how to properly get amd cards recognized through esxi vm. The only references i've had that people had success with old Nvidia cards. 

Maybe there's a way to patch the drivers? or patch the kernel? 

Edited by kokozaurs
Link to comment
Share on other sites

  • Administrators

i think the problem in VM

this gpu have native support

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

try a native install direct in ssd with no VM

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

19 hours ago, MaLd0n said:

try a native install direct in ssd with no VM

I have a feeling that the problem might be that i dont have igpu. its only the virtual gpu that the vmware gives and dgpu rx580. Is there a way to bypass that? 

Edited by kokozaurs
Link to comment
Share on other sites

My guess from the boot log:

Quote

kernel[0]: (AppleGraphicsDeviceControl) <AppleGraphicsDeviceControl`AppleGraphicsDeviceControlClient::authorizeTask(AppleGraphicsDeviceControl*, task*, unsigned int)> AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PE60@17/IOPP/GFX0@0/AMD9500ControllerWrangler)
2020-10-02 08:39:23.145618-0700  localhost kernel[0]: (Sandbox) <Sandbox`sb_report> Sandbox: 3 duplicate reports for bluetoothd deny(1) mach-lookup com.apple.server.bluetooth
2020-10-02 08:39:23.145621-0700  localhost kernel[0]: (Sandbox) <Sandbox`kernel_report> Sandbox: distnoted(281) deny(1) file-read-metadata /usr/sbin/distnoted
2020-10-02 08:39:25.843835-0700  localhost kernel[0]: (Sandbox) <Sandbox`kernel_report> Sandbox: bluetoothd(149) deny(1) mach-lookup com.apple.server.bluetooth
2020-10-02 08:39:49.984892-0700  localhost kernel[0]: PMRD: power event 7 args 0xc15a600572fc86a1 0x0
2020-10-02 08:39:49.985048-0700  localhost kernel[0]: PMRD: destroyed capability client set 0xc15a60057163deb1
2020-10-02 08:39:49.985323-0700  localhost kernel[0]: (IOGraphicsFamily) <IOGraphicsFamily`IOFramebuffer::systemPowerChange(void*, void*, unsigned int, IOService*, void*, unsigned long)> GTrace synchronization point 7
2020-10-02 08:39:49.985484-0700  localhost kernel[0]: kPEDisableScreen 1

 

 

It doesn't see Igpu, or for whatever other reason it flags that the system is unauthorized client which results in not authorizing amd9500controllerwrangler. Later on the kernel disables screen and the gpu is just a paperweight. 

IMO it would probably crash at that point if the esxi wouldn't supply it's of GFX which follows right after that

Quote

kernel[0]: (VMwareGfx) gfx: fb: registerForInterruptType: Unexpected interruptType=hdci.
2020-10-02 08:39:49.986381-0700  localhost kernel[0]: PMRD: PowerChangeDone: ON_STATE->ON_STATE
2020-10-02 08:39:50.170648-0700  localhost kernel[0]: kPEDisableScreen 1
2020-10-02 08:39:50.170668-0700  localhost kernel[0]: (VMwareGfx) gfx: fb: setDisplayMode: (1) wxh=2560x1440, 32 10240
2020-10-02 08:39:50.170867-0700  localhost kernel[0]: (VMwareGfx) gfx: svga: SetMode: mode w,h=2560, 1440 bpp=32
2020-10-02 08:39:50.187857-0700  localhost kernel[0]: (VMwareGfx) gfx: svga: SetMode: pitch=10240
2020-10-02 08:39:50.187990-0700  localhost kernel[0]: (VMwareGfx) gfx: fb: setDisplayMode: Display ID=1, Depth ID=0
2020-10-02 08:39:50.188082-0700  localhost kernel[0]: (VMwareGfx) gfx: fb: setDisplayMode: wxh=2560x1440, bpp=32, pitch=10240
2020-10-02 08:39:50.188564-0700  localhost kernel[0]: kPEEnableScreen 1
2020-10-02 08:39:50.188617-0700  localhost kernel[0]: (VMwareGfx) gfx: fb: GetDisplayMode: Bad mode ID=0
2020-10-02 08:39:50.188714-0700  localhost kernel[0]: (VMwareGfx) gfx: fb: getPixelInformation: Display mode 0 not found.
2020-10-02 08:39:50.405550-0700  localhost kernel[0]: IOConsoleUsers: time(0) 0->0, lin 0, llk 0,
2020-10-02 08:39:50.405564-0700  localhost kernel[0]: IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
2020-10-02 08:39:50.467120-0700  localhost kernel[0]: IOConsoleUsers: time(0) 0->0, lin 0, llk 0,
2020-10-02 08:39:50.467136-0700  localhost kernel[0]: IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0

 

Since kernel ends up finding a graphics display which is the vmwaregfx, it continues to boot successfully. 

Is there a way to bypass this and make it think that it's a proper client considering I have no igpu in order to get the amd card working?

is there a way to fake a igpu presence? 

Edited by kokozaurs
Link to comment
Share on other sites

  • Administrators
4 hours ago, kokozaurs said:

I have a feeling that the problem might be that i dont have igpu. its only the virtual gpu that the vmware gives and dgpu rx580. Is there a way to bypass that? 

yes. need only GPU and iMacPro1,1 smbios with Catalina

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

dont need

native install with clover or opencore work like a mac. vm is very bad way

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...