Jump to content
maccam70

ALC 887 sound issue

Recommended Posts

Hello! I need your help.

I have Catalina installed and everything works fine but I can't get the sound working.

I'm using AppleALC.Kext + Lilu but as soon as I inject any ID number the computer doesn't boot
(It boots fine without injecting any, the kexts are loaded properly and so is AppleHDA).

I've tried voodooHDA but I can only get HDMI out. but that's not a real solution.

The system just doesn't see the sound device Codec ID the way it sees the Nvidia built-in HDMI out and I think this is why voodooHDA just "provides" HDMI output.

I use clover on a dual xeon rig:

- Huananzhi x79-8d (c602 chipset, Ivi bridge-E)

- Dual Xeon 2680v2

- 64 GB

-Quadro K2000

As I can't upload my EFI folder (it's bigger than 3 MB) I'm sending my config.plist and a few screenshots.

Hope anyone can help, thanks 

config.plist.zip Screenshots.zip

Link to comment
Share on other sites

Hi MaLd0n,

I've followed that guide with no avail, as soon as I inject any number with "alcid=XX"¬†the system does¬īt boot...

It boots properly without injecting any but no sound.

With Mackintool I can see the "device" and the "sub device" numbers but nothing in "codec" nor in "revision", it seems as if MacOs can't recognize properly the sound device. It does with the graphics card by the way.

I'm stuck here I would appreciate any help

Thanks

 

Link to comment
Share on other sites

Hi, Both Lilu and AppleALC are loaded but when I put alcid=1 as boot flag it doesn't boot (it boots fine without it)

I've checked with -v to see where it stops when I use alcid boot flag and it is always at 

EXEC_RESOURCE -> MRT[66] exceeded mem limit        (img included) 

 

I've tried 1, 2, 3, 5, 7, 11, 13... as shown in AppleALC wiki for ALC887 but as soon as I use alcid=xx or I put any number via clover configurator it just doesn't boot (the log varies from one number to the other but always finish the same way)

I know I shouldn't be that difficult to get the sound working as everything else is working just fine (ethernet, USB3 etc.) and it boots rather quick.

The kexts I'm using in EFI/CLOVER/KEXTS are:

AppleALC, FakeSMC, Lilu, NullCPUPowerManagement, RealtekRTL8111, USBPorts and VoodooTSCSync  and I used a patched SSDT via ssdtPRGen.sh for my CPU.

(you can check my config.plist in the first post)

Thanks

alcid_1.jpg.zip

Link to comment
Share on other sites

Hi MaLd0n,

When It boots without alcid boot flag there are far less errors, I've checked the booting log and they're mainly related to CPU issues (although the dual Xeon is properly recognized once booted in Catalina)

Unsynchronized  TSC for cpu 
(IOPlatformPluginFamily) X86PlatformPlugin::getCPUCStates
(IOPlatformPluginFamily) X86PlatformPlugin::publishACPIStates - Failed to get CPU P States!
(pmtelemetry) Unsupported CPU
(pmtelemetry) Unsupported PCH

and there is this one also:

(kernel) AppleALC       alc: @ failed to obtain device info for analog controller (1)

which I think is the cause the system can't see any audio device apart from HDMI out from my graphics card.

Here it is the complete kernel boot log if you don't mind to check it out.

Thanks a lot !!

BootLog_Kernel.zip

Link to comment
Share on other sites

Hi MaLd0n,

It boots fine with your DSDT in CLOVER/ACPI/patched folder but I can't see any difference (I've got rid of all the ACPI patches in config.plist as I guess now are applied to the DSDT).

The sound device is still not recognized and it hangs when inject any number with "alcid" as before. 

I've just upgraded to 10.15.6 with no issues and MacOs is running very smooth but it is so frustrating not being able to get the sound working...

Thanks anyway for your time

Link to comment
Share on other sites

Hi MaLd0n,

I've done as you said, I put your DSDT in the "patched" folder, removing usbinjectall and setting the cpu number in voodootscsync to 39 (my system has 20 cores + 20 threads in total) I used to have it right but I had changed the kext recently and forgot to edit it :(.

The main difference I can see is that now there are several devices listed in System Info/PCI (screenshot attached) one of them being the High Definition Audio controller but there's nothing in the audio tab and obviously no sound.

It hangs at boot when I set an Alcid boot flag (any number) as before.

I've found something interesting while using your DSDT. 

I can get P-states up to 31 ( that would be the top frequency for the E5-2680v2 with all cores in turbo mode: 3100 Mhz) but if I run Cinebench 20 for instance, the performance of the system is only 80% than it was before  (I send you several screenshots so you can see that).

Thanks

 

Screenshots.zip

Link to comment
Share on other sites

Right now I'm using a patched SSDT.aml generated with ssdtPRGen.sh to fix it but I guess that's not enough...

Do you know of any good guide to fix power management for my chipset?  its a C602 although x79 should do as well.

 

BTW I've tried to use macPro 6,1 as other users are using this with a similar rig but the system just reboots...

Link to comment
Share on other sites

Thank you for your help MaLd0n!!

Now I think I kind of sorted out the power management. 
I'm using your last DSDT and I followed the Stinga guide and it seems it's working much better (Cinebench score is 5888 now!!) and there are far more C-states & P-states tan before.
I couldn't download the "LegacyX86PlatformPlugin.kext" mentioned in the guide but even without it the system runs much smoother ¬Ņcan it make any difference?

The boot log is also much cleaner but the sound issue hasn't change though... 

I attach a kernel boot log and AppleIntelInfo so you can see the difference.

Info.zip

Link to comment
Share on other sites

I did, I can only get HDMI sound thru the graphics card (1 for each socket). I guess it's better than nothing...

The HDMI sound is properly seen by the system but the ALC 887 isn't (no codec ID as you can see in the image attached), that may be the reason why voodooHDA provides only HDMI sound out

DPCIManager.zip

In the kernel boot log:

2020-07-26 13:49:00.23 kernel[0]: (kernel) AppleALC       alc: @ failed to obtain device info for analog controller (1)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...

Hey! Welcome to Olarila.com  Please Disable Your ADBlocker!

3vHSCmh.png

The popup will be closed in 15 seconds...