Jump to content
Sign in to follow this  
SynN00b

Catalina is Laggy with HD Graphics 520

Recommended Posts

Posted (edited)

Hello Guys I have a Hackintosh in a Acer E5-574G-75ME and installed with a Olaria Image and work's fine but without 3D Acceleration and other things like batery status.

I downloaded an EFI from here this EFI is for Acer E5-572, all is working fine and the 3D acceleration too, but are happening a strange thing, the mouse is laggy when I pass at menus and view a video on Youtube, I Tried enable my HD Graphics with videos on youtube and the method injecting AAPL Key dont' work.


The EFI downloaded work's but only this small bug that on 3D acceleration that make imposible to use the hackintosh properly, someone have a advice?

 

Moderators I put an external link where I downloaded my EFI, please remove if is against of rules.

 

My Specifications:

processor: Mobile DualCore Intel Core i7-6500U

Graphic adapter: Intel® HD Graphics HD520 and Nvidia 920 (Disabled) by EFI

Sound Adapter: Realtek ALC255

Hard Drive: HDD SSD 240GB Kingston + 1 TB HD Western Digital

 

Network:

Qualcomm Atheros AR956x Wireless Network Adapter

 

Edited by SynN00b

Share this post


Link to post
Share on other sites

u can post here. no problem

u try other video patch?

Share this post


Link to post
Share on other sites
Posted (edited)

I am starting with Hackintosh and tried the methods available on youtube, tried inject on clover configurator and using this EFI.

This EFI use a diferent method, I tried mark Inject intell, and ig-platform-id --> 0x19160000        in Devices added the properties:

-- Device - IntelGFX Key - AAPL,GfxYTile Value - 01000000 Value Type - DATA

these values don't worked.

 

Where I find other path? The GPU is exactly the same, only the processor is diferent.

I tried other methods and one use a kext Appleintelsklgraphicsframebuffer but I don't finded this kext to download.

Sorry for my bad english, I speak portuguese ._.

Edited by SynN00b

Share this post


Link to post
Share on other sites

Mald0n, I found a DSDT for my Laptop E5-574 that you edited for another user and now is more stable but still laggy, it's happen when I navigate on menus or see videos on Youtube, but now I can watch.

I downloaded the EFI mentioned above and replaced with your DSDT and all are working including the brightness adjust.

I will continue testing, the biggest problem of this mode is the discrete graphics, maybe this the problem.

So if someone have the same notbook like me Acer E5-574G-75ME and want try can Use this EFI partition but and now replaced the DSDT file with this

the 3D acceleration work with this small laggy bug with mouse and the UI.

Thanks a lot Mald0n for try help me and your time.

Share this post


Link to post
Share on other sites

u try with this patch?

<key>PciRoot(0)/Pci(0x02,0)</key>
            <dict>
                <key>AAPL,GfxYTile</key>
                <data>AQAAAA==</data>
                <key>AAPL,ig-platform-id</key>
                <data>AAAbGQ==</data>
                <key>framebuffer-fbmem</key>
                <data>AACQAA==</data>
                <key>framebuffer-patch-enable</key>
                <integer>1</integer>
                <key>framebuffer-stolenmem</key>
                <data>AAAwAQ==</data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I ll try It now, a strange thing is happening, my keyboard are working normaly, but when I use the hackintosh to test these bug's simply stoped to work, only using a USB keybord, I don't changed nothing in config.plist, it maybe the DSDT?

----EDITED----

The keyboard work for a small time in the login and stop, I tried the mentioned patch and have the same result. This is really strange.

Edited by SynN00b

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for your time Mald0n the limit size of file exced the permited but I uploaded on Mega link here

I planning to make a new instalation if it work's or the patch is for the instalation?

I have a notebook with SSD and HDD using a Cady to replace my DVD drive to another disk.

I tried use my Harddrive in the Cady slot and USB 3.0 and have this problem.

My SSD are internal, I plan to install Mac OS on my SSD if it work.

The strange thing is the notebook start well, keyboard working and no lag, but the keyboard stop, and when I navigate on menus have the mentioned bug.

 

----- EDITED ----

I found this topic and the problem is close, but in my case the UI is laggy too and the keyboard and the mouse stoped and don't work anymore only with a USB mouse and Keybord.

When I use the Clover provided by Olaria Catalina RAW work well and with no lag but don't have 3D aceleration, audio, because the kexts and patches.

Edited by SynN00b

Share this post


Link to post
Share on other sites
Posted (edited)

I tested the EFI provided and the Lag was gone but the keyboard and the mouse still don't work, when I started at the first time I was capable to adjust the brightess for example but now don't work anymore.

When I generate other dump and the RunMe opened the safari the lag back again but I restarted the hackintosh and the lag was gone again.

The only problem apear be only with the keyboard and the mouse if I dont open the Safari this is really strange.

I plaining to make a new and clean instalation on saturday on my SSD.

I maked this new dump

----- EDITED -----

Well I have to make more tests but when the system was locked the lag occur again, but now is better than the first EFI that I provided.

----- EDITED -----

I can confirm now is more stable, the keyboard dont work but the lag was gone and more stable If occur I Just have Reboot, after the keyboard stoped work I was able to ajust the brightness and the volume only one time and dont worked anymore.

----- EDITED -----

I maked an aditional test, today I turn on my notebook and the keyboard is alive again but without trackpad and no laggy, but with the use, the keyboard stop again and now the laggy is back. Maybe something with input? I now just can use a USB mouse/keyboard.

In a video on youtube is more evident the problem because reflect on all system, but moving the mouse trhought menus and the interface have this issue.

Edited by SynN00b

Share this post


Link to post
Share on other sites

Just posting again for nothification if the topic was readed before, sorry for the flood.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...