Jump to content
Hardel

Reinicializaçåo ao termino de carregamento das Kexts

Recommended Posts

Amigo estou com um serio problema.

Fiz o tutorial para a instalação do Mountain Lion, mas a maquina reinicializa ao termino de carregamento das Kexts.

Fiz uma partição de 10gb no Hd somente para ter os arquivos de instalação, e uso um leitor de cartão ou pendrive ate finalizar a instalação para depois instalar o chameleon na partição do sistema.

Vou postar minha configuração e o que estou utilizando.


Configuração

Asus P5q-e

Q6600

AMD 6870 Xfx

4Gb

Hd Samsung 300

Teclado e Mouse Ps2


Chameleon R1856 no leitor de cartão com as kexts, AppleACPIPS2Nub, fakesmc, IOAHCIBlockStorageInjector, IONetworkingFamily, OpenHaltRestart, VoodooPS2Controller.


Essas kexts eu uso no Snow a muito tempo, mas tentei utilizar tanto as kexts disponíveis no tutorial de instalação do ML quanto as que uso no Snow, nenhuma das formas tive sucesso, alguma tem alguma dica pra ajudar?

Link to comment
Share on other sites

O Chameleon oficial não suporta o ML mesmo na versão atual, tem que ser uma versão modificada.


Se não funcionar com a do tópico, tente com "arch=i386".

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

O Chameleon oficial não suporta o ML mesmo na versão atual, tem que ser uma versão modificada.


Se não funcionar com a do tópico, tente com "arch=i386".

 

Tentei com a versão do tópico Cassio. Tem alguma outra versão dele que posso tentar o ML?

O arch=i386 ja tentei tambem, mesmo problema... inicialização no final do carregamento das kexts!


Essas kexts que eu sitei eu uso no Snow e usava no Lion, precisei formatar o Hd agora nem o Lion ta subindo tambem.

Link to comment
Share on other sites

Se nem o Lion tá subindo você deve estar fazendo algo errado, reveja os procedimentos e as versões das kexts e do boot loader.


No ML vários estão tendo esse problema, alguns conseguem subir em i386. Li comentários sobre o problema estar relacionado com a versão da FakeSMC, mas ninguém confirmou com certeza.


Você também pode tentar outro boot loader

http://www.projectosx.com/forum/index.php?showtopic=2304

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Consegui subir ate a tela de instalação Cassio!

Depois que eu terminar eu vou postar exatamente o procedimento que eu usei pra chegar ate la.


Mas estou com outro problema, quando vou instalar, ele diz que nao encontra o Software Essencial do Sistema...

Link to comment
Share on other sites

Você não deve ter feito o procedimento completo http://Olarila.com/forum/viewtopic.php?f=26&t=995

Ent'ao Cassio o procedimento esta correto, estou seguindo ate a ordem, ja tentei tanto com o Dp1 quanto com Dp2, os dois param na mesma mensagem.

Me parece algum problema com a pasta Packages, nao faz muito sentido, ela foi copiada para o local correto, mas nao encontra o tal Essencial.

Link to comment
Share on other sites

Consegui subir o ML dp1e2 em 64bit fiz uma pequena alteração na bios

na aba: Advanced setup habilitei CPU TM Function e Execute Disable bit.

e na aba Power Managment setup eu deixei ACPI Suspend mode como 'Auto" ao invés de S3.

dessa forma subiu em 64bit.

Usei o chameleon 1860 e o chimera 1.8 todos dois funcionou.

btn_donate_SM.gif
Link to comment
Share on other sites

Consegui subir o ML dp1e2 em 64bit fiz uma pequena alteração na bios

na aba: Advanced setup habilitei CPU TM Function e Execute Disable bit.

e na aba Power Managment setup eu deixei ACPI Suspend mode como 'Auto" ao invés de S3.

dessa forma subiu em 64bit.

Usei o chameleon 1860 e o chimera 1.8 todos dois funcionou.

Vc tambem tem a placa Asus p5q-e Altamiro?

Link to comment
Share on other sites

Altamiro na minha bios ja estavam exatamente assim, com essas opções habilitadas.


Cassio consegui fazer a instalação do sistema.

Era o que eu imaginava, ou tinha algo errado com a pasta Packages ou o arquivo Essencial estava corrompido. Entrei no Dev Center fiz o download do Dp2 novamente e pra fazer um teste substitui somente a pasta Packages e a instalação prosseguiu.


Fiz a instalação com o Chameleon_2.1svn_r1820_trunk_10.8, estou usando as kexts: FakeSMC, IOAHCIBlockStorageInjector, NullCPUPowerManagement, OpenHaltRestart, AppleACPIPS2Nub e VoodooPS2Controller todos na E/E, todas as kexts que eu ja usava no Lion.

Procurei uma nova kext para o som porque a mesma VoodooHDA do Lion não funcionou no ML, mas encontrei uma mais atual e subiu o som.

A vga subiu nativamente e com aceleração gráfica sem necessidade de nenhuma kext nem GraphicEnable, é uma XFX HD 6870.

O problema esta sendo rede, nenhuma IONetworkfamily que eu encontrei funcionou.

Link to comment
Share on other sites

Não a minha é Pcware mas acredito que funcione se vc habilitar Execute disable bit na bios.

 



MUUUUUUITO OBRIGADO! Tava há dias tentando instalar o ML DP2 e não conseguia, e a muito tempo atrás criei um tópico que o Sleep não funcionava mais no Lion como funcionava no Snow Leopard, muita gente do fórum tentou me ajudar mas não deu em nada, desisti. Mas mudando essas configurações além de subir a instalação do ML o sleep funciona perfeitamente no Lion e no Mountain. o/

Link to comment
Share on other sites

Bom pessoal aqui ta quase tudo OK!

Tem só alguns detalhes que queria tirar duvida com vcs.


Teclado e Mouse PS2.

Eu uso as 2 kexts pra teclado e mouse ps2 sitadas a cima. Como minha placa só tem uma entrada ps2 nela eu tenho o teclado, e o mouse eu uso um adaptador usb (duplo, para teclado e mouse).

Quando desligo a maquina e no outro dia ligo, o mouse não funciona, eu tenho que reiniciar a maquina, entrar no windows pra ele funcionar, reiniciar a maquina novamente pra entrar no Mac OS, ai sim o mouse funciona.

Alguém sabe como solucionar este problema?


FileVault.

Quando vou atira o FileVault nas preferências tenho a mensagem:

"O FileVault não pode ser ativo para o disco "OS X Mountain Lion".

Alguns formatos de disco não são compatíveis com a partição de recuperação exigida pela criptografia.

Para usar a criptografia, reinstale esta versão de Mac OS X em um disco reformatado."

*Detalhes: Quando fui instalar o Mountain Lion usei o DI da instalação, formatei o HD e criei a partição novamente, ou seja ele ficou zerado.

Alguém sabe como ativar o FileVault?


iCloud.

Fiz o login, habilitei tudo menos "Compartilhar Fotos". (Preciso do iPhoto, então este problema é simples de resolver).

"Voltar ao meu Mac". O servidor do iCloud não está respondendo. (Estou usando o Chameleon com fix de iCloud e FaceTime).

"Buscar Meu Mac". É necessário uma partição de recuperação.

Alguem sabe como ativar o "Voltar ao meu Mac" e "Buscar Meu Mac"?


Obrigado.

Link to comment
Share on other sites

O problema do mouse talvez resolva com um patch DSDT, tem um pronto pra sua mobo: http://Olarila.com/forum/packs.php

 

Obrigado Cassio, preciso tentar usar Dsdt com o MT, pois nas minhas tentativas com leopard, snow e lion sempre tive KP.

Vi em algum lugar que não se pode usar Dsdt de outra maquina, o certo seria extrair e aplicar os patchs necessários, verdade isso? (mesma mb claro!)

Agora... como eu consigo saber exatamente quais os patchs são necessário pra minha mb? Faz tempo que procuro isso mas não acho resposta.

É possivel implementar tudo via Dsdt e não usar nenhuma Kext?


Quando ao Buscar Meu Mac e Voltar ao Meu Mac vc tem alguma sujestão que eu possa tentar?


Comprei um novo Hd, 160Gb só pra ter como teste, vou tentar a formatação com o DI da instalação do Lion e instalar novamente e reporto aqui.



Obrigado pela força.

Link to comment
Share on other sites

Vi em algum lugar que não se pode usar Dsdt de outra maquina, o certo seria extrair e aplicar os patchs necessários, verdade isso? (mesma mb claro!)

Sim, é verdade, principalmente nas Asus, porque qualquer diferença na versão do BIOS, núcleos do CPU ou quantidade de RAM, vai causar problema.

 

Agora... como eu consigo saber exatamente quais os patchs são necessário pra minha mb? Faz tempo que procuro isso mas não acho resposta.

Eu te indiquei um link onde tem um patch pronto pra sua placa, você vai aplicar esse patch sobre a sua DSDT original.

Se quiser entender o motivo de cada patch, leia http://Olarila.com/forum/viewtopic.php?f=7&t=646

 

É possivel implementar tudo via Dsdt e não usar nenhuma Kext?

Não, é impossível. DSDT é uma tabela ACPI (BIOS), tem poucos KB e não substitui drivers de dispositivos. O que pode acontecer é que com ajustes na DSDT você possa usar kexts originais da Apple, sem precisar de kexts modificadas ou de terceiros. Leia http://Olarila.com/forum/viewtopic.php?f=2&t=30

 

Quando ao Buscar Meu Mac e Voltar ao Meu Mac vc tem alguma sujestão que eu possa tentar?

Não testei nenhuma das outras funções que você citou no post anterior, pois não tenho conta de developer.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...