Jump to content
gmbmg

MSI RX 580 armor oc 8gb black screen on Mojave

Recommended Posts

Hello everyone,

I bought the MSI RX 580 armor oc 8gb and at the end of booting sequence, the screen turns black. I bought it because it thought it was going to work OOB, but nothing

This RX 580 card has 2 x HDMI, 2 x DP, 1 x DVI-D

System configuration:

Mac OS 10.14.6

Motherboard: Gigabyte H55M-USB3

Processor: i5 760 @2.80 ghz

PSU supports up to 600w

Clover 5119 (also used 5102 before, but the result is the same, clover version doesn't seem to matter)

 

VERY IMPORTANT: I also have an Nvidia GT 210, using it plugged in PEG 16x and the RX 580 Plugged in PEG2 8x, I am able to boot the system, but only using -x flag. So no hardware accelleration on both cards, however I am able to use any of the port on the RX 580 (2 x HDMI + 2 x DP). At least, in this way, I understand there should be a way to have the RX 580 work. If I don't use -x or if switch the cards, (RX 580 in PCI 16x and GT210 in PCI 8x), I get gioscreenlockstate 3 hs 0 bs 0 now 0 sm 0x0, which seems to be due to some kind of error in High Sierra, but I found that it was solved after, and since I am in Mojave, I have searched a bit more and it seems it's due exactly because of 2 GPU at the same time. The funny thing is that when I am able to boot with -x, I plug both cards to the same Samsung TV via HDMI, without mirroring the screen, the GT210 has no accelleration, but when I change HDMI port from my remote to see what is the RX 580 doing, I have maximum resolution. 

I have tried many things, like:

1. Lilu 1.4.5 + Whatevergreen 1.4.0 (right now these are the lastest versions), no Ati Injection, no RadeonInit

2. No Lilu, no WEG, Ati Injection, Orinoco Framebuffer with 5 ports

3. I tried the guide on how to patch AMD FB, but i guess something was wrong when dumping RX 580 Rom using PAVO's script. The 8 digits blocks are positioned in a different way compared to what I saw in the tutorial. I don't know if I can make any reference to other sites. (See attachment AMD_Framebuffers_Extraction.zip). I patched all the framebuffers with 5 ports, created different config.plist for each framebuffer and booted each one from clover bootloader. The result was the same

4. I have tried all ports with all these methods, none is working.

 

Please, let me know if you need more informations, files, screenshots, videos, whatever could help you to help me.

 

 

 

 

AMD_Framebuffers_Extraction.zip

Link to comment
Share on other sites

  • Administrators

ur mobo is legacy i think, use DP output

 

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

I tried every output. Both DP outputs just return black screen like HDMI, but if I am in safe mode (-x) with the GT210 in x16 PCIE slot, I can get full resolution and all ports working for RX 580, even if there is no accelleration like QE/CI, Metal etc. It's really strange. I also checked the loaded kext, and AMD9500controller is loaded when I am able to boot using -x.

Edited by gmbmg
Type corrected (AMD instead of HDMI)
Link to comment
Share on other sites

  • Administrators

rx580 is a uefi gpu, ur mob is legacy, i think this problem is that

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Thanks for your answer. Finally I was able to boot without -x and with only the RX 580. I injected EDID using 1002 for vendor and 67DF for product and both DP and HDMI are able to get to the desktop. I will make few checks to see if everything is ok, but for now the legacy MOBO is accepting it. I will report back later with more details

Link to comment
Share on other sites

  • Administrators

Extract tables with F4 key in Clover boot screen, boot into system and run this app
https://www.olarila.com/files/Utils/RunMe.app.zip
https://www.youtube.com/watch?v=k9wmIfGLe3A

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Thanks for your effort, but I still get the black screen since there is no inject edid and vendor 1002 + component 67DF

This is the efi folder with which I can get to the desktop, even if there is no acceleration

https://easyupload.io/1z41mz

Edit:

- Now I am able to boot without having to inject edid, vendorid 1002 and productid 67DF after doing the following, but still no acceleration:

- Change SMBIOS to iMacPro1,1
- Applied Graphics Policy patch in config to overcome black screen on boot issue.
- Added dummy kext in the kexts/Other folder.

 

I will try to use some of the bootflags in the config.plist you created for me and see what happens.

 

Edited by gmbmg
Additional infos
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...