Jump to content
bcntower

Black Screen Mojave Gigabyte GA-EX58-UD5 and Sapphire RX580

Recommended Posts

Hi to everyone!

I've installed MacOS in several computers with no problem, but I'm stuck with this one.

It's an legacy computer:

Mobo: Gigabyte GA-EX58-UD5
CPU: iCore 7 950
Power Supply: Corsair CS750M
3 SATA HHD (1 SSD)
GPU: Sapphire Pulse Radeon RX580 (8GB) through a HDMI cable

This computer had a Radeon HD 5770 and was running Lion fine, but I wanted to upgrade it. So I installed Mojave (Catalina was impossible because I was not able to get the SSD recognised) and everything was OK but the screen resolution (just 1024x578). I read that this was because the GPU was not supported by Catalina.

After reading some posts, I decided to buy the Sapphire RX580. With the config.plist I used, after Apple logo the GPU stopped working (fans stopped). So I did some things:

- I modified the config.plist (is the 'config rx850.plist' in the attached EFI folder).
- I updated both Lilu.kext and Whatevergreen.kext to the last version (1.4.3)
- I updated Clover to 5114.

With all of this, the only thing I can get is a black screen after Apple logo (but the GPU fans are running). It happens if I run the Mojave installed and I try to run the installer.

Any help is appreciated. I've attached the Clover in the EFI folder (just with Lilu and WhateverGreen in Kexts/Other folder).

Thanks in advance!

CLOVER.zip

Link to comment
Share on other sites

  • Administrators

legacy mobo, use dp video output

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Thanks @ ACPI Eater.

The solution to that was connecting the RX580 through a dp port. I managed to install Catalina with no problems and running smooth with a iMac14,2 sysdef.

Thanks again!!!

How can I change the thread status to 'Solved'?

Edited by bcntower
Link to comment
Share on other sites

  • Administrators

stay open for other people ;) 

Enjoy!

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×
  • Create New...
The popup will be closed in 15 seconds...