Jump to content
tobiasger

Random freezes in Mojave 10.14.6 (Asus Prime Z370-A II, Intel i5 9600K, RX 580)

Recommended Posts

I bought components for a Hackintosh build in November last year with macOS Mojave 10.14.6 on one drive and Windows 10 on another. So I'm dual-booting but on separate drives. I installed macOS with the Vanilla Guide on r/hackintosh, using Clover. The setup worked perfectly for a few weeks as I can remember, but after a while I started getting these random freezes. By freezes, I mean that the system is completely frozen and requires a restart on the reset button of the computer. This happens only on macOS and has never happened when running Windows 10.

Specs:

  • Motherboard: Asus Prime Z370-A II
  • CPU: Intel i5 9600K
  • CPU cooler: Noctua NH-D15S
  • GPU: Sapphire RX 580 Nitro+ 8 GB
  • SSDs: WD Black SN750 NVMe SSD M.2 250GB (macOS) and Intel 660p Series M.2 2280 SSD 1TB (Windows)
  • PSU: Corsair RM750X
  • RAM: Kingston HyperX Fury Black DDR4 3200MHz 2x8GB
  • WiFi/Bluetooth: fenvi T919
  • FireWire: SYBA Low Profile SD-PEX30009
  • Fans: 2x Fractal Design Dynamic X2 GP-14 PWM and 2x Fractal Design Dynamic X2 GP-12 PWM
  • Case: Fractal Design Define C

Kexts:

  • AppleALC.kext
  • IntelMausiEthernet.kext
  • Lilu.kext
  • USBMap.kext with aml file
  • WhateverGreen.kext
  • FakeSMC

DSDT Patches:

  • change XHCI to XHC
  • change XHC1 to XHC
  • change SAT0 to SATA
  • Fix 300-series RTC bug
  • change EHC1 to EH01
  • change EHC2 to EH02
  • Rename EC0_ to EC__

The freezes seems to happen in conjunction with clicks or button presses on either the mouse or the keyboard. It could be pressing "enter" when logging in, clicking a link in the browser or basically anything that involves clicking or pressing a button. But they are not consistent ‚Äď more random in nature.¬†I initially thought that this was caused by not having a proper USB mapping set up. I initially had USBInjectAll.kext but nothing else.

In my first attempt of fixing this issue, I activated a patch that increased the port limit. For some reason, the freezes didn't happen for a while after this, but after some time they came back. I noticed that the freezes started happening again after updating Windows 10, but I thought that was just a coincidence. Before this I also changed from VirtualSMC.kext to FakeSMC.kext, but this didn't make any difference.

My second attempt was to run the USBMap.command tool in order to config the USB ports correctly by limiting them to a maximum of 15 ports and then adding the generated USBMap.kext file and the AML file with it. And of course removing USBInjectAll.kext after that. Again, this seemed to fix it - but like before, they came back after a while. And like before, they came back after I did another update of Windows 10. So my suspicions seemed to be valid after all. I also had Activity Monitor opened during one session, in order to see if there were any spikes in the CPU or similar just when the freeze happens, but I couldn't see anything suspicious in the activity upon the computer freezing.

The freezes seems to happen more frequently when they first appear. I can use the computer for about 3-5 minutes between every freeze initially. After a few reboots they appear less and less frequently (maybe 30 minutes up to 2 hours apart) until they kind of goes away. Again, this is just my personal observations, and they could just as well be completely random.

And this is where I am now. I have no clue what to do and no idea what is causing it. My only lead right now is that someone on Reddit had a similar issue and told me that checking one specific option on the initial window in Clover Configurator fixed it for him. But he can't remember what options it was.

I would really appreciate any insight in this from anyone!

Edited by tobiasger
Changing phrasing
Link to comment
Share on other sites

  • Administrators
22 minutes ago, tobiasger said:

Thank you! I assume that I should continue using the 300 series Clover folder from now on?

In what directory should the .aml file go? And is there anything else I need to do?

yes, just put dsdt into clover/acpi/patched

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Hello,

I have seen the thread and I have the same problem with my catalina installation. The motherboard is the same, the processor is an i9 9900K and the graphics are a shappire 580x

The installation works perfectly and I have almost all the usb ports enabled, but it reboots randomly.

I am attaching my EFI folder in case you can help me, as I think the problem is very similar.

Thank you very much for your attention and I hope to solve this soon! Thanks for your work and help!

 

https://drive.google.com/file/d/1T-TX6mMxucPX_F4f8yUfoTdxL-6pQYam/view?usp=sharing

On 15/3/2020 at 19:52, MaLd0n said:

sí, solo ponga dsdt en clover / acpi / parcheado

Hola,

He visto el hilo y tengo el mismo problema con la instalación de catalina. La placa base es la misma, el procesador es un i9 9900K y los gráficos son 580x shappire

La instalación funciona perfectamente y tengo casi todos los puertos USB habilitados, pero se reinicia al azar.

Adjunto mi carpeta EFI por si me pueden ayudar, ya que creo que el problema es muy similar.

¡Muchas gracias por su atención y espero solucionar esto pronto! ¡Gracias por tu trabajo y ayuda!

 

https://drive.google.com/file/d/1T-TX6mMxucPX_F4f8yUfoTdxL-6pQYam/view?usp=sharing

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...

Hey! Welcome to Olarila.com  Please Disable Your ADBlocker!

3vHSCmh.png

The popup will be closed in 15 seconds...