Jump to content
Nexxusone

ASUS B360G Gaming / I5-9400f / Sapphire RX 5700 Pulse 8GB / Samsung 970 Evo NVMe

Recommended Posts

My Work in Progress Hackintosh ASUS B360G gaming mATX Bios 1703 - macOS 10.15.3 Beta 1 on m2. Nvme 256GB

 

Boots direct to Apple Logo, then login (No Clover GUI) Catalina 10.15.3 Beta 1.

 

POST install EFI is Clover 5100 with NO GUI and verbose off, so boots straight to Apple Logo (Open Core being explored) - SMBios iMacPro1.1.

 

For the PRE install USB, it requires Clover r5092 IF using gibmacOS or will get No internet error, due to the installer requiring internet.

 

App Store Catalina and terminal created install media will work with Clover 5100, once installed gibmacOS works with Clover 5100

 

Everything works or is disabled via dsdt.aml file in clover, with lots of help from the main moderator / owner of forums.

 

Hardware Info:

 

Motherboard : ASUS B360G Gaming (BIOS 1703) - 300 series Socket 1151 mATX motherboard.

 

 

CPU : 9th Generation - Socket 1151- Intel¬ģ Core‚ĄĘ i5-9400f. (NO iGPU)

 

GPU : SAPPHIRE RX 5700 Pulse 8GB (requires agdpmod=pikera as a boot argument flag BUT only IF WEG.kext present in Clover.)

 

RAM : Corsair VENGEANCE LPX 16GB (2x8GB) DDR4 3000MHz C15 + (2x4GB) of same, to give 24GB RAM all @ 2666mhz (xmp in bios).

 

NVMe : SAMSUNG 970 EVO 256 GB in m.2_2 (macOS 10.15.2. Beta 4).

 

SSD : WDC 120GB m.2 SATA3 in m.2_1 (Data Drive)

 

CPU Cooler : Cooler Master Seidon 120V Liquid cooler V2 - from my parts bin because of noisy AIO pump (clicks) but fine to use.

 

PSU : Cooler Master 600W lite non modular - to be replaced soon.

 

CASE: Cooler Master Q300L.

 

Wi-Fi: ASUS PCE-AC56 PCIe 1300AC - works out of box x1 slot card in a spare x16 slot due to space for RX5700 cooling.

 

BLUETOOTH: CSR8510 A10 USB Dongle in USB2.0 port.

 

4uV3TXP.jpg

 

See this for Help and files I used.

 

 

Link to comment
Share on other sites

  • Administrators

[ref]Nexxusone[/ref], :cap

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

UPDATE

Changed Rx480 4GB to same brand Sapphire RX 5700 Pulse 8GB - this required agdpmod=pikera as a boot argument flag, as booted to logo then displayed no screen but could hear the failed user login noise....

use clover install usb - manually typed in agdpmod=pikera as a boot argument - then boot to the OSX drive (not usb) and use clover config to add agdpmod=pikera into config.plist and saved back to boot ssd.


Now boots fine, I know I could have just removed the WEG.kext but thats for future investigation.

Link to comment
Share on other sites

UPDATE: macOS 10.15.2 Beta 4 Post install Clover r5100 and deleted all boot arguments and removed WEG.kext , updated all Kexts and slimmed down to my hard ware specific kexts only.


enables fast boot -1 in boot in clover configurator - so goes straight to apple logo then login - no clover gui.


Ran Hackintool and corrected a few outdated kexts and proximity wake in power was set to 1 and now zero.


so far No random reboots.


Ran it all night with intel power gadget running + playing a video on loop. still running rock solid this morning - 8hrs later...

Link to comment
Share on other sites

  • Administrators

[ref]Nexxusone[/ref], :crazy::cap

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Update:


Added a VA panel 144 mhz 1ms 32" WQHD 2K Monitor via display port to replace my 24" 1080p HDMI monitor (Early xmas present)


Config.plist from scratch for my hardware not universal 100/ 200 / 300 chipset folder.


My Kexts slimmed down to my hardware only and updated (compiled) to latest DEV releases


mapped my USB ports


Via Appstore Beta program, Update Catalina to 10.15.3 Beta 1 from Desktop.


All seems o.k

Link to comment
Share on other sites

Last update:


Added WhatsEverGreen.kext 1.3.6 to fix HEVC as apple for now disabled it.

Added a Logitech k780 keyboard (windows / Mac / iOS /android support and tablet and a Logitech MX master Mouse, both plug n play using just 1 unifying receiver.


I will probably not update this anymore until a Major revision of macOS released as I now consider my machine stable.

Link to comment
Share on other sites

 

UPDATED: RX5700 rebooting Kernel Panic is FIXED  by the 10.15.4 Beta1 (so far - limited testing)

 

Motherboard : ASUS B360G Gaming (BIOS 1703) - 300 series Socket 1151 mATX motherboard.

 

CPU : 9th Generation - Socket 1151- Intel¬ģ Core‚ĄĘ i5-9400f. (NO iGPU)

 

GPU : SAPPHIRE RX 5700 Pulse 8GB (requires agdpmod=pikera as a boot argument flag BUT only IF WEG.kext present in Clover.)

 

RAM : Corsair VENGEANCE LPX 32GB (4x8GB) DDR4 3000MHz C15  @ 2666mhz (xmp in bios).

 

Nvme: Sabrent Rocket 1TB TLC Nand formatted in 4K blocks (10.15.3) in m.2_2 (x4 mode slot) DRIVE 1

 

Nvme : SAMSUNG 970 EVO 256 GB in m.2_1 in mode x2 slot  (macOS 10.15.4 Beta1). DRIVE 2

 

SSD : WDC 120GB m.2 in external USB enclosure (for CCC clone drive)

 

CPU Cooler : Cooler Master Seidon 120V Liquid cooler V2 - from my parts bin because of noisy AIO pump (clicks) but fine to use.

 

PSU : Cooler Master 600W lite non modular - to be replaced soon.

 

CASE: Cooler Master Q300L.

 

Wi-Fi: ASUS PCE-AC56 PCIe 1300AC - works out of box x1 slot card in a spare x16 slot due to space for RX5700 cooling.

 

BLUETOOTH: CSR8510 A10 USB Dongle in USB2.0 port.

 

Well updated the 2nd drive to Beta1 of 10.15.4 and its FIXED the RX5700 Rebooting Kernel panic on display sleep. Hopefully this fix is for ALL NAVI RX5x00 cards.

  • Like 1
Link to comment
Share on other sites

On 12/27/2019 at 4:36 AM, zo_zo said:

Hi [ref]Nexxusone[/ref], Can you upload final EFI? Thank you so much!

I used the olarila clover 100 200 300 chipset zip EFI with slight mods to config.plist to suit my hardware.

Edited by Nexxusone
Link to comment
Share on other sites

with the new 10.15.4 Beta my Hack has been on now over 24+ hours - Auto screen saver at 5 mins and 5 mins later  auto put to sleep @ 00:50 and Mouse wiggle to wake @ 7.20am and HELLO.... one fully awake -  working Hack ....

used for day watching videos /play/ make USB / compile Kexts etc, leaving to idle and sleep , also set caffeinated app for a hour , it keeps Hack awake for hour, the screen after 5 and then sleep, wakes up fine every time.

and NOT A single reboot /kernal panic in over 24+ hours... HAPPY

Link to comment
Share on other sites

  • Administrators
3 hours ago, Nexxusone said:

with the new 10.15.4 Beta

looks good

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...