Jump to content
🎉 [ IMPORTANT ] Premium and Donators users 🎉 ×

[Solved] iMessage stopped working and now giving me activation error


Recommended Posts


My iMessage was working on my Hackintosh, I have of course followed guides for setting SMBios and so on, it was working!! after two weeks or so now it stopped working and giving me "An error occurred during activation. Try again."

Did Apple change something in their activation procedure? Does anybody else have this problem? The only catch about my configuration is that I am using NullEthernet.kext, since my laptop did not have any working ethernet for Hackintosh, I even tried changing NullEthernet Mac address to an Apple's Mac address range, still the same problem.

If anybody is wondering how I am connected to internet, I am using a USB ethernet adapter.

Every time that I change my settings to retry I delete iMessage configs like this: "

sudo rm -rf ~/Library/Caches/com.apple.iCloudHelper*

sudo rm -rf ~/Library/Caches/com.apple.Messages*

sudo rm -rf ~/Library/Caches/com.apple.imfoundation.IMRemoteURLConnectionAgent*

sudo rm -rf ~/Library/Preferences/com.apple.iChat*

sudo rm -rf ~/Library/Preferences/com.apple.icloud*

sudo rm -rf ~/Library/Preferences/com.apple.imagent*

sudo rm -rf ~/Library/Preferences/com.apple.imessage*

sudo rm -rf ~/Library/Preferences/com.apple.imservice*

sudo rm -rf ~/Library/Preferences/com.apple.ids.service*

sudo rm -rf ~/Library/Preferences/com.apple.madrid.plist*

sudo rm -rf ~/Library/Preferences/com.apple.imessage.bag.plist*

sudo rm -rf ~/Library/Preferences/com.apple.identityserviced*

sudo rm -rf ~/Library/Preferences/com.apple.ids.service*

sudo rm -rf ~/Library/Preferences/com.apple.security*

sudo rm -rf ~/Library/Messages


Still does not solve the problem, any help in this regard is appreciated

Edited by Guest
Link to comment
Share on other sites

  • Administrators


PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]


ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9


PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE


Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

My Issue finally solved, for anyone else having this problem, it was because of "OsxAptioFixDrv.efi, v3 solved the issue, funny thing is the v1 version worked for a while until it broke, therefore use "OsxAptioFix3Drv.efi" whenever possible.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...