Jump to content
radek@dresowka.pl

Problems with getting fully functional OS

Recommended Posts

Im out of ideas what the hell im doing wrong. Please support me with some help.


About my setup and things that im done.


Hardware:


Intel Core i9 9900K

Aorus Pro mobo

64Gb of Crucial b. ram

1TB NVME Samsung SSD

RX Vega 64 wc edition

Native Broadcom wifi+bt card


- Applied all correct BIOS settings according to my mobo,

- Got installed Latest Olarila Mojave OS

- Copied and pasted the correct chipset folder from the forum

- Pasted patched DSDT.aml file inside ACPI/patched folder

- Used OsxAptioFix2Drv-free2000.efi Instead of Aptiomemory fix one

- Used Hackintool for resolving "power" problems that where "red" listed there

- Updated Clover to the latest version



My problems:



1. It doesn't shutdown (makes restart instead)

2. After using Sleep, it does boot and I can't make it wake up - need to hard reset

3. Doesn't reboot properly

4. The PCI section on the System report is blank - doesn't show anything there

5. Im getting random problems with booting the system, it randomly stops at screen with Error Allocating 0x1196d paged at 0x000000000008f900000 alloc type 2, Couldn't allocate runtime area."


Im willing to donate someone who can help me with this crap. (pm me about it)

Link to comment
Share on other sites

[ref]radek@dresowka.pl[/ref], replace, reboot, extract one send_me

EFI.zip

 

Replace & reboot done, here is my runme.app file



And two more things, during the installation I had a problem with IO screen lock state and only disabling my integrated graphic card in bios helped. I really don't want to mess this OS another time. Please tell me how to turn it on again I need it for intel quick sync purpose.


Also when I tried to reboot without USB key with Olarila Mojave instal, it starts regular clover and after selecting boot from ssd a black screen with some strange dots appears.

Send me MacWojciaks-iMac.zip

Link to comment
Share on other sites

[ref]radek@dresowka.pl[/ref], EFI.zip

use this efi, reboot, enable intelhd, disable csm

We are almost home !

System Has all PCI devices, IT reboots, shuts down, USB works, hardware encoding, integrated graphics etc.


Sadly i have 2 more issues to fix :wallbash


1. Sound is not working. - Edit: SOLVED THIS ONE :D

2. After booting without USB stick, without touching anything Clover boots os from my drive. After loading i get Black screen with strange artifacts. But its i tak f12 there od another partitiion with osx. If i select it, system boots properly. How to m─ůk─Ö this partitiion as the default Clover partitiion to load from?





Is the late 2017 iMac Pro system definition is the best one for this setup? Before i had early 2019 core i9 iMac - does it really matters at all?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...