Jump to content
PedroDiniz

[HELP] ioconsoleusers gioscreenlockstate 3 after install high sierra nvidia webdrivers

Recommended Posts

Hello Friends, how are ya?


Could you help me with a problem?


I followed some guides like: https://www.insanelymac.com/forum/topic ... coffeelake -dsdt /


and the installation of high Sierra 10.13.6 (17G8030) and nvidia webdrivers (correspondent to OS version) went smoothly, the problem starts when I try to boot the GPU.


Hardware:

MOBO: Aorus B360M gaming 3 (rev.1)

CPU: i5 8400

GPU: GTX 1060 OC Galax redblack


BIOS:

Fast boot - disabled

windows 8/10 features - other os

lan pxe - disabled

storage boot option - UEFI

other pci devices - UEFI


Initial display output - PCie 1 slot

Intel's Platform Trust Technology (PTT) - disabled

sata mode selection - AHCI

XHCI hand off - enabled

VT-d - disabled

internal graphics - auto



The problem is:

I can log into the system normally without using my nvidia GPU but when I boot the system with the flags for webdrivers to work I fall into the login screen but it keeps flashing, I can see the mouse and I can move it but the screen flashes and the following error appears when the screen goes "black": IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0. I searched for this error on the internet and tried to solve but to no avail so far.


If someone can help me I would be extremely grateful! thanks in advance!


I couldn't attach my clover folder.

Anyway, I send the onedrive link containing my clover folder: https://1drv.ms/u/s!Aua4uwSY5cEtg7IBfdQCBSyxAqFGQA?e=wrMsXO

Link to comment
Share on other sites

[ref]MaLd0n[/ref], Thanks for the quick response!

about this file you sent me, should I just run it?

is my clover folder ok?


Added in 5 minutes 2 seconds:


Well i just ran the command and here's the output

 

 iMac-de-Pedro:~ pedrodiniz$ /Users/pedrodiniz/Downloads/nvidia-update.command ; exit;
      Welcome pedrodiniz       
Copyright (c) Benjamin-Dobell
*****************************
 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                Dload  Upload   Total   Spent    Left  Speed
100  6086  100  6086    0     0  21288      0 --:--:-- --:--:-- --:--:-- 21354
Password:
Downloading driver blacklist...
 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                Dload  Upload   Total   Spent    Left  Speed
100   140  100   140    0     0    604      0 --:--:-- --:--:-- --:--:--   606

Downloading driver list...
 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                Dload  Upload   Total   Spent    Left  Speed
100 70140  100 70140    0     0  39142      0  0:00:01  0:00:01 --:--:-- 39140

The latest driver revision is 387.10.10.10.40.130

387.10.10.10.40.130 is already installed.
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed. 

Link to comment
Share on other sites

[ref]PedroDiniz[/ref], just read

https://Olarila.com/forum/viewtopic.php?f=50&t=8685

 

[ref]MaLd0n[/ref], I rebuilt the clover folder Olarila again. I ran runme.app and sent the .zip generated by the app.


attached updated clover folder: https://1drv.ms/u/s!Aua4uwSY5cEtg7ICxU4mwCteNP-PKw?e=PyiFls


Thanks again for your attention. I can't wait to finish this hackintosh and make a donation :D

Send me iMac-de-Pedro.zip

Link to comment
Share on other sites

[ref]PedroDiniz[/ref], EFI.zip

 

[ref]MaLd0n[/ref], Thanks again for your attention. I performed all the procedures and for a moment I thought the problem had been resolved and the nightmare was over, but the error continues ... the screen keeps flashing and the IOConsoleUser error is there.


I noticed that the bootloader page has changed (I think it's because of the changes you sent me).


but no luck so far ... can we try anything else?


current clover folder: https://1drv.ms/u/s!Aua4uwSY5cEtg7JY42mIaQWLr3vD5g?e=DMqGPB


Obs: I can still boot up with nv_disable=1

Link to comment
Share on other sites

[ref]PedroDiniz[/ref], u have a last bios version?

 

[ref]MaLd0n[/ref], Updates:

I performed the bios update to the current version: F13.

I made an attempt with csm disabled but got the same result.

I managed to take some pictures of what is happening and I am sending them attached.


During login the monitor starts to flash and toggle between these 3 screens.


eNqGOt7Y_t.jpg 4hKlV525_t.jpg KEWecC1m_t.jpg


In the last image you can see that the 2 monitors are "activated" but is flashing and I can not enter the system


Still with this Clover folder: https://1drv.ms/u/s!Aua4uwSY5cEtg7JY42mIaQWLr3vD5g?e=El7Pc5

Link to comment
Share on other sites

[ref]PedroDiniz[/ref], first u need put to work with only one monitor

 

[ref]MaLd0n[/ref], I've been trying with just one monitor too.


but without success.


any tips on bios? What are the settings that may be causing this?


About the monitors, I have 2 monitors, 1 DVI 1440x900 (plugged in video card) 1 VGA with a displayport plug 1920x1080 (plugged in video card).


which one should I try? After I can make one work, can I make both work?


Could you look at my clover folder again and see if I have anything unnecessary in it that causes problems?


Once again, thank you very much for your help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...

Hey! Welcome to Olarila.com  Please Disable Your ADBlocker!

3vHSCmh.png

The popup will be closed in 15 seconds...