Jump to content
stakeout5

HP Installer Issues + KP images

Recommended Posts

Hey all! First and foremost I appreciate everyone's help so far. I had reached the promise land once on my HP Pavilion Laptop 15-cx0056wm with High Sierra so I KNOW it is possible - basically I got, very easily actually, up and running with High Sierra. Frankly my entire EFI went corrupt out of no where and I don't know why so I am doing it all clean - which was no big deal until....


Problem is what I did the first time now all of the sudden it isn't working (yes I backed up my EFI / Clover folder but it isn't working). Same BIOS settings, same steps I followed etc. Attached is my EFI and my specs are below. Mind you this was with a dual boot with Windows 10 and again no issues.


Used this guide primarily: https://www.tonycrapx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/


But I could almost reach the installer (close to it anyways, I got to the screen after all the verbose stuff with the apple and white bar) with either config as long as I used the cpus=1 flag . -- then it sits idle for ever.


EFI folder that I'm trying to use for the High Sierra USB: https://drive.google.com/file/d/1NhOUVAzvSBq52amB9myEzhXr02V30u6F/view?usp=sharing


Pic of panic: https://photos.app.goo.gl/K95eWMyr3LZ1SiPC9 . (in order)


Clover folder from ORIGINAL, previously working install that is no longer working: https://drive.google.com/open?id=1sXYSoj_C9lCG-kh7fEskwsW1zaa6DGHh


Read some stuff on threading of my CPU and how HP's have trouble or something? I'm not too sure. I tried to google parts of the KP but not much was related. Wondering why alllllll of the sudden too.

BIOS settings pics: https://photos.app.goo.gl/MqaK2pQ7DchgtzS57


My existing install boots to the log in screen perfectly normal then resets the PC out of nowhere now.

Here is the EFI folder that is now messed up out of no where (was on my HDD for High Sierra) you can see config.plist is shot... : https://drive.google.com/open?id=1Ekyxw-NlK4exkCIRkKi_odRNvfWAQ8OC


Product Specs

Product number: 4PY21UA

Product name: HP Gaming Pavilion - 15-cx0056wm

Microprocessor: IntelĀ® Coreā„¢ i5+ 8300H (2.3 GHz base frequency, up to 4 GHz with IntelĀ® Turbo Boost Technology, 8 MB cache, 4 cores)

Chipset: IntelĀ® HM370

Memory: 8 GB DDR4-2666 SDRAM (1 x 8 GB)

Video graphics: NVIDIAĀ® GeForceĀ® GTX 1050 Ti (4 GB GDDR5 dedicated) + Intel UHD 630 1536 Mb

Hard drive: 1 TB 7200 rpm SATA

Display: 15.6" diagonal FHD IPS anti-glare micro-edge WLED-backlit (1920 x 1080)

HP Imagepad with multi-touch gesture support

Wireless connectivity: IntelĀ® Wireless-AC 9560 802.11b/g/n/ac (2x2) Wi-FiĀ® and BluetoothĀ® 5 Combo

Network interface: Integrated 10/100/1000 GbE LAN

Expansion slots: 1 multi-format SD media card reader

External ports: 1 USB 3.1 Type-Cā„¢ Gen 1 (Data transfer only, up to 5 Gb/s); 3 USB 3.1 Gen 1 (1 HP Sleep and Charge); 1 HDMI 2.0; 1 RJ-45; 1 headphone/microphone combo


Thank you for your time.

Link to comment
Share on other sites

  • Administrators

[ref]stakeout5[/ref], for a good start use Olarila Clover folder for ur chipset

https://Olarila.com/files/Clover.Folder/CLOVER.NOTEBOOKS.100.200.300.zip

is need apply a video patch


after reboot extract one send_me

--Run_Me

RunMe.app

Support Olarila Vanilla Hackintosh by making a donationĀ HERE

About Premium Users you can checkĀ HERE

Problems with PaypalĀ HERE

Link to comment
Share on other sites

Booted with the patch and the DSDT - here's the file - again thank you. Brightness is available to adjust in my settings, output sound is only "internal speaker" but no sound comes from it, still no trackpad settings - it asks for me to connect an external trackpad (the track pad itself works but is seen as a mouse) - I'm sure you know all of this and are troubleshooting one thing at a time just letting you know as more things come to work. THANK YOU

Send me Michaels-MacBook-Pro.zip

Link to comment
Share on other sites

  • Administrators

[ref]stakeout5[/ref], audio alc295, check here, just inject other layout-id

https://Olarila.com/forum/viewtopic.php?f=28&t=9788


ur trackpad work with voodoops2? if no


trackpad, is a i2c put two kexts in clover/kexts/other and change trackpad to Advanced mode in bios

Arquivo Comprimido.zip

Ā 

run it

https://Olarila.com/files/Utils/Kernel%20and%20Kexts%20Cache.command.zip

reboot and extract new send_me


brightness key i think is q11 and q12, take one shot

DSDT.aml.zip

Support Olarila Vanilla Hackintosh by making a donationĀ HERE

About Premium Users you can checkĀ HERE

Problems with PaypalĀ HERE

Link to comment
Share on other sites

Hey guys, i have this laptop and id like to thank @Mald0n and @stakeout5 for your debugging and work, i first found out about it through a reddit post.


High seira might not be the best choice for this laptop imo, jumping to mojave got me full graphics acceleration , and working brightness buttons


the stuff i need to fix now are trackpad (which probably wont support gestures due to PS2) ethernet (keeps reconnecting) and the audio which is probably just some kext updates in general.

everything else is doing pretty well. my EFI folder is here if you are interested. i am using DSDT Previously patched, and a config.plist merged from various forums


P.S My UHD 630 reports full 2048MB on MacBook15,2 smbios . no IGPU hacks needed. native support (https://www.tonycrapx86.com/threads/guide-native-intel-uhd630-graphics-support-in-macos-10-13-6.256426/)


EFI : https://drive.google.com/file/d/1MfazgbuPCt0XyW8WYjnnHcBnik0qgJ7V/view?usp=sharing

Link to comment
Share on other sites

Update about trackpad.


So trackpad gestures and scrolling work when using ApplePS2Smarttouchpad kext from

https://drive.google.com/drive/folders/1dMEQja8X3pfXTrmqImQ8L2M1zjp1RDhC


It kinda works well, gestures are also supported (4 finger gestures to open and close stuff , vertical and horizontal scrolling too)

the main problems with this kext is


1) Mouse acceleration is bad. and no sensitivity control in sight, in fact there is no trackpad settings at all, it won't ask you to connect a trackpad but it will be blank


2) This kext breaks 2 things in our keyboard that are fine in voodoops2controller , it breaks brightness control in f2/f3 and caps lock is weird, it is not dependent on the indicator light, it takes 3 presses to switch from uppercase / lowercase


I think maybe voodoops2keyboard extension + appleps2touchpad combo might do us fine. audio wise I fixed it using voodooHDA. however note that the gains need to be modified, it is not as loud as it should. nothing that can't be fixed.


everything else on the build is doing fine, even stuff like palm rejection is working. bluetooth works with BluetoothDevBroadcomInjector


p.s : again all of this was done on Mojave and not high seira as the post initially was about

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...

Hey! Welcome to Olarila.comĀ  Please Disable Your ADBlocker!

3vHSCmh.png

The popup will be closed in 15 seconds...