Jump to content
trenetics

Sleep issue

Recommended Posts

Hi


I'm experiencing issues in getting sleep to work.


I've been looking into the logs and found this:


2019-07-05 12:22:33.157845+0200 localhost kernel[0]: (AppleACPIPlatform) System sleep prevented by pci8086,a2bd

2019-07-05 12:22:33.157847+0200 localhost kernel[0]: (AppleACPIPlatform) System sleep prevented by pci8086,a2bd


When i look into the PCI list in hackintool:


IOService:/AppleACPIPlatformExpert/[email protected]/AppleACPIPCI/pci8086,[email protected],3

PciRoot(0x0)/Pci(0x16,0x3)


It's suppossed to be an Communications Controller /Serial Controller - I'm wondering if it's the internal Intel Wifi/Bluetooth card?? Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

[ref]MaLd0n[/ref], It worked...! Thanks alot m8! I have another model at work doing exact the same problem! Can you tell what was wrong by any chance?


And can i do the USB SSDT and Configure Audio Layout in Hackintool now or will it brake everything again? Or was the fix in ACPI section?


Added in 11 minutes 10 seconds:

[ref]MaLd0n[/ref],


Ohh i see all the PCI, and the USB are done already!..


Is there a tool that can do these DSDT automatically?? Or can you point me somewhere on the site to a guide on how to do an DSDT?

Share this post


Link to post
Share on other sites

[ref]trenetics[/ref], i don't share patches now, in old time i shared many :mrgreen:

Share this post


Link to post
Share on other sites

[ref]trenetics[/ref], i don't share patches now, in old time i shared many :mrgreen:

 

Okay i can respect that!, can i upload another run-me from an Q270 chipset in this thread tomorrow that you can patch for me or should i use the DSDT patch request thread?


Is there a thread where there is an tutorial for doing the DSDT patching my self in the future, im eager to learn how??

Share this post


Link to post
Share on other sites

[ref]trenetics[/ref], yes


acpi specs, chipset datasheet, etc

Share this post


Link to post
Share on other sites

[ref]trenetics[/ref], replace, reboot, install wifi kexts again

EFI.zip

 

extract new send_me after reboot

Share this post


Link to post
Share on other sites

Thanks [ref]MaLd0n[/ref], everything is working besides sleep :(


It goes to sleep but wakes again after 2 seconds, with black screens, i can only get it working again after i shut it down.


I have switched off Wake for Ethernet access in Energy Settings and checked the power settings with Hackintool yet still no luck :-/


When i have shut it down it freezes when the Apple logo appears, then it stays there for like 5 seconds then reboots itself and it goes in cycles, i fixed this by removing one of my 2 monitors and reconnect when it has boot into Mojave.


Do you think it's something you know the fix to?

Share this post


Link to post
Share on other sites

[ref]MaLd0n[/ref], wow the latest DSDT bunked it totally... Sleep not fixed same as before, goes to sleep and wakes with black screens after 2 seconds and the mac dies. But now i can't run dual monitors either. i can only boot with one screen and when i connect the other screen both screens go black. If i boot with both screens connected it freezes at the Apple logo for 5 second then reboots and this goes on forever.


*update*


I tested to revert all the way back to the first EFI zip you sent me, now when i boot it also boots with both monitors.. [ref]MaLd0n[/ref], what is the difference between the DSDT from the original first EFI.zip you sent to Pandora-mac-mini and the modified DSDT.aml.zip file you sent me, other than regarding sleep? The only difference i can see is that the startup drive is External in the first package and Internal in the second DSDT?


*update 2*


I got it to boot with the second & latest DSDT you sent me, but only with 1 monitor connected, when i connect the second monitor both screens instantly go black, and even when i disconnect the second monitor i cant get it running again unless i reboot with one monitor connected. When i boot with both monitors it still goes as far as to the Apple logo the freezes for like 5 seconds then reboots (goes on in cycle until i turn off power). It's weird cause the original DSDT from you first EFI.zip works with booting both monitors but then my startup drive looks like and external drive! Can you please fix it m8? It would be nice with sleep but if it's at the expense of these other problems i'd rather skip it.


I attached a new run_me file with the latest DSDT you sent me!

Send me Pandora-Mac-mini.zip

Share this post


Link to post
Share on other sites

[ref]trenetics[/ref], is just a patch in device/properties, create one with hackintool

Share this post


Link to post
Share on other sites

[ref]MaLd0n[/ref], you mean the iGPU?? for the monitor issue??


Cause i corrected the Power settings in Hackintool without any luck.

Share this post


Link to post
Share on other sites

[ref]trenetics[/ref], yes, video is just a hackintool

Share this post


Link to post
Share on other sites

[ref]MaLd0n[/ref], Thanks m8 that fixed my issues! I will request a new DSDT for a new PC but i will do that in the DSDT Patch Request thread.. Thanks alot!!

Share this post


Link to post
Share on other sites

MaLd0n now my dell xps13 l322x run 10.14.6 everything work

1.but when it is sleep then wake display is black how can i fix it?

2.i try install 10.15 another partition(2ND) can i use same efi 10.14.6 ,config,kext ?

Share this post


Link to post
Share on other sites

[ref]sanyaaahtconex[/ref], use hackintool, Displays tab

Share this post


Link to post
Share on other sites

Sleep doesn't work, goes in and out of hibernation all the time, nor does bluetooth because of error in config.plist, kext ?


Bluetooth works in Mojave. Incredibly slow boot during startup again error in config.plist, kext ?



Any help would be greatly appreciated. Send me with your config2.plist booted.




BIOS Version:E179BIMS.312 - 03/15/2018

Realease BIOS for WU & Update CPU microcode 0x84 for Intel-SA-00088 (Meltdown & Spectre) speculative execution side-channel vulnerabilities.


EC firmware Version:179BEMS1.108 - 11/03/2017

ME Firmware Version:11.8.50.3425


BIOS Settings : Loaded Optimized Defaults -->

- XHCI Hand-Off enabled, Attempt Secure Boot disabled, Fast Boot disabled, ERP lot 3 support enabled and Boot mode select UEFI with CSM


macOS Catalina 10.15 beta 5 (19A526h)

Clover_v2.5k_r5033



MSI details:


Intel® Core™ i7 7700HQ processor / HM175

GeForce® GTX 1060 3GB GDDR5

17.3" Full HD (1920x1080), 120 Hz Refresh Rate and 5ms response time panel

Cooler Boost 4 Technology ENHANCED COOLING DESIGN FOR HIGHER POWER

32GB Crucial DDR4 2400MHz SODIMM

NVMe M.2 SSD by PCI-E Gen 3.0 / Samsung 960 EVO 1TB M.2 NVMe SSD & WD Blue 1TB 2.5" SATA SSD

HL-DT-ST GUD0N SATA Int. DVD±RW (±R DL) / DVD-RAM

Realtek RTS5129 Card Reader (SD/SDHC/SDXC)

1x USB 3.1 SuperSpeed+ Type-C reversible plug, 2x TYPE-A USB3.0 & 1x USB2.0

SHIFT technology boosts performance under controlled noise & temperature

Nahimic 2 virtual 7.1 sound / Realtek ALC898

BisonCam, NB Pro Webcam HD type ([email protected])

Audio Boost 2 WITH 3 dedicated headset amplifiers,isolated audio board and gold-plated audio jacks:1x Mic-in & 1x Headphone-out (SPDIF)

Dynaudio speaker system / 4x 2W Speakers & 1x 3W Subwoofer

Keyboard by Steelseries with full color backlighting / PS/2 Keyboard / Synaptics PS/2 & SMBus Multi-Touch Touchpad

Killer Shielded E2500 Gigabit Ethernet + Broadcom BCM94352Z 802.11AC

1x HDMI (HDMI [email protected]) & 1x Mini DisplayPort 1.2. = HDTV/Matrix Display supports 4K output with a resolution up to 3840 x 2160

Edited by Guest

Share this post


Link to post
Share on other sites

[ref]tbrautaset[/ref], DSDT.aml.zip

use Olarila clover folder for ur chipset

 

Hi Daniel,


Your DSDT patches that tells the kernel to ignore my laptop BIOS-supplied table are really good!


How did you make mine without me sending you an F4 dump with native files to EFI / Clover / ACPI / origin ?


Is it enough with those who are generated by "Send me" ?



Most of my hardware works fine in Catalina now :), bluetooth too thanks to headkaze



Have 1 question about brightness control :


Installed acpi support base (0.142-8) acpid (1: 2.0.28-1 + b1) on my Debian 9 partition with apt install acpid -y


Then ran acpi_listen in terminal:


fn + down arrow key = video / brightness BRTDN 00000087 00000000 K

fn + up arrow key = video / brightness BRTUP 00000086 00000000 K



Downloaded RehabMan´s AppleBacklightFixup and made a patch for DSDT :


 

into method label BRTN replace_content
   begin
       // Brightness Down\n
           If ((0x87 == Arg0))
           {
               Notify (\_SB.PCI0.LPCB.PS2K, 0x0405)
           }\n
       // Brightness Up\n
           If ((0x86 == Arg0))
           {
               Notify (\_SB.PCI0.LPCB.PS2K, 0x0406)
           }
   end;



My CLOVER originated from CATALINA Olarila


 

> ACPI
               > patched
                               DSDT.aml
                               SSDT-PNLF.aml
                               SSDT-UIAC-ALL.aml
config.plist
> Boot
               <string>dart=0 nv_disable=1 brcmfx-country=#a</string>

> Audio
                               <key>Inject</key>
                               <integer>13</integer>
                               <string>0x59168086</string>

> Graphics
                               <key>ig-platform-id</key>
                               <string>0x591b0000</string>



> drivers
               > BIOS
                               ApfsDriverLoader.efi
                               FSInject.efi
                               HFSPlus.efi
               > UEFI
                               ApfsDriverLoader.efi
                               AptioMemoryFix.efi
                               FSInject.efi
                               HFSPlus.efi
> kexts
               > Other
                               ACPIBatteryManager.kext
                               AirportBrcmFixup.kext
                               AppleALC.kext
                               AppleBacklightFixup.kext
                               AtherosE2200Ethernet.kext
                               BrcmBluetoothInjector.kext
                               BrcmFirmwareData.kext
                               BrcmPatchRAM2.kext
                               CodecCommander.kext
                               FakeSMC.kext
                               Lilu.kext
                               NoTouchID.kext
                               USBInjectAll.kext
                               VoodooI2C.kext
                               VoodooI2CHID.kext
                               VoodooPS2Controller.kext
                               WhateverGreen.kext

 


Brightness Controll works with the arrow keys as planned, but suddenly my keyboard stops working and I have to restart to correct it.


This only happens when I adjust brightness after a while with the arrow keys, what can this be ?



Have I loaded some wrong kext's or can you see if something is obviously wrong in what I've listed above ?


Screenshot%202019-08-07%20at%2018.27.43_zpszhvu6atz.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...