Jump to content
🎉 [ IMPORTANT ] Premium and Donators users 🎉 ×

The disk you inserted was not readable by this computer


Recommended Posts

On every boot this message pops up

Screen-Shot-2019-05-05-at-14-07-55.png

High Sierra is installed on my 240GB SSD

On the 1TB HDD I have my old Windows and Linux


My bios is Legacy with AHCI enabled.


When I change in bios boot priority with my HDD as first option, grub shows and I can boot to windows or linux.

When first option is my SSD, clover shows with multiple options and after 5 sec automatically boot in High Sierra.


The old HDD is partitioned and formatted by the windows installer. I have 2 ntfs windows partition and 1 ext3 linux partition, windows recovery partition and linux swap partition


Disk utility shows like this

Screen-Shot-2019-05-05-at-22-36-21.png


What can I do to be able to boot windows or linux from clover and to mount my ntfs windows partition in High Sierra in Read/Write mode?

Link to comment
Share on other sites

  • Administrators

[ref]kitaro74[/ref], if u can, format it

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

I need to save first some files I have on drive.

I read about a windows 10 system32 app called mbr2gpt. It is possible to convert the drive without formatting?

MiniTool Partition Wizard also have the option to Convert MBR Disk to GPT Disk.


I will save important files from drive and I will try with MiniTool first. If will fail I will format the drive.

Link to comment
Share on other sites

  • Administrators

[ref]kitaro74[/ref], u can try, i think don't work

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Indeed, didn't worked. The disk partition is GPT now, I can boot windows from EFI partition, but in High Sierra the same message pops up every boot and the disk appear Uninitialized. Yesterday I moved all my important files to an external HDD and today I will format the drive.


Can I format the drive from macOS with Disk Utility? I need 1 partition for Windows, 1 partition for data. I want this Data partiton to be mounted in High Sierra.

What partition should I use for this drive?

Link to comment
Share on other sites

Today I solved the problem.


Formating from High Sierra was not working.

When I try to Erase the disk from Disk Utility It gave me the error "Unable to write the last block"

In windows the disk was visible. I format the disk from windows with GPT and exFat. No errors.

Back to High Sierra the disk remains Uninitialized.


Then i download AppleAHCIPort.kext v328 (file attached) and placed in Library/Extensions and in /EFI/Clover/kexts/Other

After reboot the disk volume showed on dektop. I formated from Disk Utility with ExFat format and GUID Partition Map

This time operation was succesfull.

Now I cand read-write on disk from MacOS and Windows


After this fix I noticed the boot time improved from 2 mins to 20-30 sec

AppleAHCIPort.kext.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...