Jump to content
🎉 [ IMPORTANT ] Premium and Donators users 🎉 ×

Black screen after installing High Sierra


Recommended Posts

Goodmorning everyone,

I just finished installing High Sierra (https://Olarila.com/forum/viewtopic.php?f=51&t=6393) on my Asus K53SV notebook with the config2.plist file.

When the PC restarts, after the end of the installation, after loading the various files, it freezes with a black screen and does nothing else.


Here are the specifications of my pc:

Processor: Intel Core I7 2670QM Sandy Bridge

Motherboard: Asus K53SV HM65

Intel HD Grapihics 3000

Nvidia GeForce GT 540M

Could you give me a hand please?

PS: I am installing the High Sierra because the Mojave told me that the system was not compatible with this macOs installation.


Available for further information

Link to comment
Share on other sites

  • Administrators

[ref]Hackintoniano[/ref], try with -x for disable some drivers

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

WoW, you're my savior !!! I have been trying to install macs on my pc for 3 days and finally succeeded !!! I take this opportunity to ask why you think I could not install mojave ...

Thanks again!


Added in 42 minutes 46 seconds:

Better not to sing victory too soon.

I'm following the end of the guide where he tells me to install clover in the ssd, I follow all the checks regarding the legacy boot but he tells me the installation failed. Why ?

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], why you use legacy boot, i have succeeded using UEFI mode.


Mojave dont work well on intel 3000, not officially supported, required a ton of hacking, not easy. See supported GPU for Mojave.


For installing Clover to SSD boot from flash drive- mount efi and install clover pkg ( https://ufile.io/ntnqp ) , then copy efi/clover folder from flash to ssd and done :)

Link to comment
Share on other sites

I've read around that it's because of the secure mode (-x), but if I start without a safe mode it happens to me that the screen remains black. So how can I proceed?


Added in 1 minute 43 seconds:

I can't mount EFI.

I mount efi through clover configurator, is there another way?


Added in 2 minutes 26 seconds:

also installing clover as UEFI gives me the same error

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], i mount it using hackintool or clover configurator - best


Simplest way - copy EFI from flash to mounted EFI drive 1 to 1

-x is safe mode for MacOS , i think it is same as Windows Safe Mode - nothing with BIOS boot - Legacy / UEFI


So try copy EFI folder from flash to SSD


Btw it BIOS how do you boot - UEFI or Legacy ??

Link to comment
Share on other sites

I can't mount efi in any way, neither with terminal, nor with clover configurator, nor with hackintool, nothing.

I think it's due to the fact that I started mac in safe mode.

I should start mac in normal mode, but if I try so I will still have the black screen on startup


Added in 1 minute 26 seconds:

[ref]Hackintoniano[/ref], i mount it using hackintool or clover configurator - best


Simplest way - copy EFI from flash to mounted EFI drive 1 to 1

-x is safe mode for MacOS , i think it is same as Windows Safe Mode - nothing with BIOS boot - Legacy / UEFI


So try copy EFI folder from flash to SSD


Btw it BIOS how do you boot - UEFI or Legacy ??

 


I don't know how it started if legacy or uefi because I simply used the Olarila high sierra imagery and then loaded with the config2.plist for notebooks with -x

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], change ig-platform-id in Clover options graphich to 0x12345678 to boot without graphics driver and dont use -x to see if it works


Btw with -x how much VRAM do you have ?

 

Not work

https://ibb.co/PMXLfjY


Added in 28 minutes 20 seconds:

ok, I managed to boot without -x (I selected use web driver nvidia).

Now which clover folder should I use for my processor?


EDIT:I explain better how I managed to start it not in safe mode:

When the PC was running in safe mode I updated the nvidia video card drivers, then I turned it off and restarted with the selected web drivers. If the drivers are not updated first in safe mode, the PC will not start even if the web drivers are selected.

Edited by Guest
Link to comment
Share on other sites

[ref]Hackintoniano[/ref], either copy Clover efi which is working from flash drive to SSD (should work also to boot from ssd without flash) or use Clover Notebooks 100 200 300


Either way keep your flash drive so you can boot with it in case anything messes up :)


How much VRAM do you have ?

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], either copy Clover efi which is working from flash drive to SSD (should work also to boot from ssd without flash) or use Clover Notebooks 100 200 300


Either way keep your flash drive so you can boot with it in case anything messes up :)


How much VRAM do you have ?

 

how do i see how much vram i have?

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], I have nvidia 1050TI on my lenovo laptop, which nvidia is not supported neither in mojave, nor in high sierra.

Maybe because of lack of web drivers - NVidia wont works, so you need to use Intel HD Graphics 3000 , which i think will not be supported for Mojave.


Wifi wont work also - you need to change the Wifi-card with Apple compatible Wifi-card or use an external adapter - i use tp-link external adapter -> Apple policy to use their compatible wifi-cards...


For audio you have to install one .efi file in drivers64UEFi in Clover - you can check in clover configurators - drivers, kexts, for audio also... but keep your flash drive - if anything messes up , boot with flash and delete the problem efis and kexts.


You have at least graphics acceleration i see..

I do it somehow by trial and error ... :)


Added in 7 minutes 14 seconds:

Try maybe installing the attached driver in EFI/CLOVER/DRIVERS64UEFI if you boot with UEFI

AudioDxe-64.zip

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], LAN will work most likely - so you can connect to internet via LAN and then with clover configurator should use an audio driver for audio, maybe audio dxe something from the top grid with legacy drivers .. bottom is for uefi, top is for legacy from clover configurator -> drivers tab


Added in 4 minutes 16 seconds:

if you boot with legacy should install the driver to drivers64 folder and NOT drivers64uefi

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], LAN will work most likely - so you can connect to internet via LAN and then with clover configurator should use an audio driver for audio, maybe audio dxe something from the top grid with legacy drivers .. bottom is for uefi, top is for legacy from clover configurator -> drivers tab


Added in 4 minutes 16 seconds:

if you boot with legacy should install the driver to drivers64 folder and NOT drivers64uefi

 

I installed the Audio-Dxe-64 drivers from clover configurator in the EFI of the SSD, but I still didn't get any results.

Furthermore, when the PC starts up, it automatically starts (after 3 seconds) the boot for the MacOs installation and not the actual installation that resides on the SSD.

Link to comment
Share on other sites

I managed to install the drivers by inserting a voodoo kext into the other folder in the EFI partition.

I still have the problem of the automatic start, that is, in the boot of clover at startup after 3 seconds I automatically launch the installation of MacOs and not the system installed on the SSD.

Another question: can my GT 540M card be used?

If so, how?

Otherwise, can it be turned off so that the battery is not consumed?

Thank you

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], in clover configurator there is an option for the startup partition, you can choose the partition with macos to start automatically


"can my GT 540M card be used?" - as far as i know NVIDIA on laptops is not supported and dont know how to use it


In my BIOS I can turn the discrete GPU off, so i can only use integrated video card - best solution if available

Otherwise boot option nv_disable = 1 is the only other option i recall


How you managed to fix your sound - copy some kexts to System Library Extensions, or System Extensions ?

Link to comment
Share on other sites

[ref]Hackintoniano[/ref], for audio installing AppleALC kext + Lilu worked for me.


As for the boot -> see at your screenshot -> Boot tab -> Combo Default Boot Volume, where is LastBootedVolume -> i think you can choose MacOS volume as you renamed it so after clover boot + 3-5 seconds it will boot by default and not Windows

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...