Jump to content
xwajuk

Bios - EFI don't start automatically

Recommended Posts

Hi


I bought new PC and have installed Mojave from Olarilla image. Anything works well expect one thing.


Each time I start my PC it doesn't load Clover automatic. I have to enter Bios (F1) and select Boot (F8) then select EFI partition to start system loading. It is annoying. How to fix it?


Bios configuration is Default. It displays EFI partition as primary to load system but it doesn't load system automatic.


See attached Bios screens:

https://photos.app.goo.gl/vYUwfDms2SyuvMDYA

https://photos.app.goo.gl/mS9ASEYWpSxjFqTs7

https://photos.app.goo.gl/S2bQTPKfLXnrscU77

https://photos.app.goo.gl/V8f8CD9sAjcmyZMh6


Asus TUF Z390-Plus Gaming

i7 8700

16 GB 3200 MHz

Sapphire RX 580 4 GB

Samsung EVO 970 250 GB

Link to comment
Share on other sites

have you installed clover efi boot loader an set smbios to imac 18,3 then runme app http://Olarila.com/files/Utils/RunMe.app.zip an post the send me files


Added in 1 minute 59 seconds:

also disable secure boot keys in the bios

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

Thanks erroruser


File:

https://www.dropbox.com/s/4rfnwozc0cc0hch/Send%20me%20iMac-Krzysztof.zip?dl=0


I also donated by Paypal :)


Added in 9 minutes 52 seconds:

BTW + more information.


Before installation:

I added two files to pendrive

EmuVariableUefi-64

OsxAptioFix2Drv-free2000

deleted 1 file

AptioMemoryFix64

My Asus Z390 has no native support for NVRAM (installation crashed 1 min before finish with no these 2 drivers/kexts)


After installation:

I replaced AppleALC to newer version 1.3.5 to lunch sound. 1.3.4 doesn't support my ALC S1200A.

Link to comment
Share on other sites

all looks good test this clover an for the gpu settings refer to my settings as a reference also https://drive.google.com/open?id=17VtleMnC77xL_W3Ohm9Bi-VXsmmSlpst

CLOVER.zip

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

mount efi with clover config then place dsdt in efi/efi/clover/acpi/patched folder then reboot :D

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

all looks good test this clover an for the gpu settings refer to my settings as a reference also https://drive.google.com/open?id=17VtleMnC77xL_W3Ohm9Bi-VXsmmSlpst

CLOVER.zip

Bios is set as you recommended at screens.

I tested CLOVER files you attached. It didn't help. Still need to enter Bios to select EFI boot disk.


Added in 6 minutes 13 seconds:

[ref]xwajuk[/ref], ur DSDT edited

DSDT.aml.zip

Also didn't help.

Link to comment
Share on other sites

in bios EJ81huP.jpg

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

these are setting that some need changing have a look over

Load Optimized Defaults

If your CPU supports VT-d, disable it

If your system has CFG-Lock, disable it

If your system has Secure Boot Mode, disable it

Set OS Type to Other OS

Set XHCI Handoff to Enabled

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

yes that is correct

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...

Hey! Welcome to Olarila.com  Please Disable Your ADBlocker!

3vHSCmh.png

The popup will be closed in 15 seconds...