Jump to content
flex21

CoffeeLake Q370 - Black Screen

Recommended Posts

Olarila Mojave 10.14.3

HP ProOne 440 g4

Q370, Core i3 8100T

NVME Kingston 240Gb

8Gb DDR 4


Hi all, with this config https://Olarila.com/files/Clover.Folder/CLOVER.SERIES.100.200.300.zip i get black screen beafore installation. After include this option

 

  • ig-platform-id: 0x3E9B0007

  • AAPL,ig-platform-id: 07009B3E

 

i have done installation, but Mac see GPU like - Intel UHD Graphics 630 3mb


What am I doing wrong? :wallbash


Attached RunMe log + Screenshot

Send me iMac-Flex.zip

1026591912_ScreenShot2019-02-19at15_29_12.png.4256d2522c10807b79406c190699038d.png

Edited by Guest
Link to comment
Share on other sites

[ref]flex21[/ref], I have the same problem and the solution lies in using a tool, called Hackintool ( https://www.insanelymac.com/forum/topic/335018-hackintool-v183/ ) to do the framebuffer patching.


I have experimented and discovered, that using fake ids 3D acceleration gets disabled, without them i cannot boot Mojave same as you.


So we should use this Hackintool but for me all fields are empty and i am struggling to discover why?


For better system performance you could request DSDT patch from Maldon - there is a separate thread -> https://Olarila.com/forum/viewtopic.php?t=1131&start=6240


313 by far pages of people sending their logs and Maldon posts DSTS fixes :)


When you discover a solution pls post your solution to help others with similar problem


Added in 1 minute 52 seconds:

PS. DSDT probably wont fix VRAM, but only general system performance, so you should ho through Hackintool :)

Link to comment
Share on other sites

[ref]flex21[/ref], I have the same problem and the solution lies in using a tool, called Hackintool ( https://www.insanelymac.com/forum/topic/335018-hackintool-v183/ ) to do the framebuffer patching.


I have experimented and discovered, that using fake ids 3D acceleration gets disabled, without them i cannot boot Mojave same as you.


So we should use this Hackintool but for me all fields are empty and i am struggling to discover why?


For better system performance you could request DSDT patch from Maldon - there is a separate thread -> https://Olarila.com/forum/viewtopic.php?t=1131&start=6240


313 by far pages of people sending their logs and Maldon posts DSTS fixes :)


When you discover a solution pls post your solution to help others with similar problem


Added in 1 minute 52 seconds:

PS. DSDT probably wont fix VRAM, but only general system performance, so you should ho through Hackintool :)

Thank you for answer ;)

Link to comment
Share on other sites

  • Administrators

[ref]flex21[/ref], DSDT.aml.zip

use hackintool for video patch

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[ref]MaLd0n[/ref], Btw I have found a bug in latest hackintool - all combos are empty no matter what i try. So i found an older version which works for me - 1.8.0.


So far so good, but now the problem - when i patch it i stuck on IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0


With my platform-id i did not stuck, but no acceleration.


What is the correct way to use the generated patch :


I replaced :

PciRoot(0x0)/Pci(0x2,0x0)

...


section and either i cannot boot or i have no acceleration ?


Maybe i do something wrong ?


Added in 1 minute 29 seconds:

there are 3 interesting options => inject intel, fake id and ig_platform_id - which one should i use for Intel HD 630 ?

Hackintool-1.8.0.zip

Hackintool-1.8.2.zip

Link to comment
Share on other sites

[ref]MaLd0n[/ref], Btw I have found a bug in latest hackintool - all combos are empty no matter what i try. So i found an older version which works for me - 1.8.0.


So far so good, but now the problem - when i patch it i stuck on IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0


With my platform-id i did not stuck, but no acceleration.


What is the correct way to use the generated patch :


I replaced :

PciRoot(0x0)/Pci(0x2,0x0)

...


section and either i cannot boot or i have no acceleration ?


Maybe i do something wrong ?


Added in 1 minute 29 seconds:

there are 3 interesting options => inject intel, fake id and ig_platform_id - which one should i use for Intel HD 630 ?

Last Release Hackintool v1.8.3 http://headsoft.com.au/download/mac/Hackintool.zip

Link to comment
Share on other sites

  • Administrators

[ref]Morselina[/ref], no problem here, high sierra in my notebook and mojave in desktop

bPrxiR5.png

EL6McGo.png

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[ref]MaLd0n[/ref], ok when i get patch text i click export -> then choose config.plist and boot again.


But if i boot with ig_platform_id = 0x0000130B which works for me i get 7MB VRAM.

Otherwise if i boot without id , or with 0x591B0000 (Intel HD Graphics 630(Mobile)) i get black screen and stuck on IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0


Do you use inject intel, fake id and ig_platform_id and if yes, what ig_platform_id do you use ?

Link to comment
Share on other sites

  • Administrators

[ref]Morselina[/ref], if u use this patch, don't use injectintel

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

[ref]Morselina[/ref], no idea about it


for me work in all hacks mobiles, hd, uhd

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

[ref]Morselina[/ref], notebook 100 200 300 + hackintool

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[ref]flex21[/ref], can you give more details which clover/config.plist -> i assume you used 1.8.0, got framebuffer patch text, patched framebuffer according to the instruction from Maldon.


Do you use clover 100 200 300 for notebooks (which config.plist should be patched) and do you do some kind of injections - inject intel should not be checked and also fake id and ig_platform_id should be 0x00000000 if i understood Maldon correctly.

Link to comment
Share on other sites

[ref]flex21[/ref], try to plug in HDMI / DP cable to external display to see if you have screen at the external display.


After a lot of testing and trying different configs I have managed to boot Mojave 10.14.3 with 1536 VRAM but the screen goes somehow to DisplayPort which I don't have so i see nothing but black screen on my laptop.


Maybe you have similar issue.

Link to comment
Share on other sites

Next i use Hackintool and setting-up new config (attachment) and again black screen... But after connect to mac on TeamViewer is some information

Help pls, what is wrong?

 

Have you managed to connect to your Hackintosh with Mojave from another PC via TeamViewer and if yes how much VRAM do you have ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...