Jump to content
foliasis

[10.14.1] Realtek USB 2.0 CRW SD Card not working

Recommended Posts

Hi me again.

So I have got almost everything working on my Dell Vostro 3558 with Mojave 10.14.1

Lastly what remains is the SD Card. (Realtek USB 2.0 CRW).

It is shown in System Report but the card is not mounted. What I tried-

1. AnySDCard.kext (changing the id everything)

2. CustomPeripheralDevice.kext

3. AppleStorageDrivers.kext (edited the ids as stated in the thread)


None of them seem to work.

Any help will be appreciated

Link to comment
Share on other sites

  • Administrators

[ref]foliasis[/ref], RunMe.app

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

[ref]foliasis[/ref], dont load, u need check what device card read stay

DSDT.aml.zip

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

[ref]foliasis[/ref], sd card shows in ioreg an loaded

ioreg.jpg.02c4ce94ef02cd895d7c01cb9253883f.jpg

try mac book pro smbios to test

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

but it doesn't mount

it shows without any change in kexts also

If I use AnyCardReader.kext it is identified as Apple Internal Card but does not mount on inserting the sd card


Added in 7 minutes 51 seconds:

Another thing that i have observed is that of I plug in a pen drive in the USB2.0 port it loads as USB 2.0 CRW in the ioreg. May be the card reader is not able to load the correct drivers but I don't know how to do it

Link to comment
Share on other sites

you do not have the usbinjextall kext in the other folder or you never set you kexts to patch in clover i would suggest you go to insanleymac to read the guide of fbpatcher or the other link i post

https://www.insanelymac.com/forum/topic/335018-intel-fb-patcher-v168/

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

[ref]foliasis[/ref], then by unfortunate circumstances you have the rare unsupported sd card reader

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

On 12/31/2018 at 12:20 AM, foliasis said:

but it doesn't mount

it shows without any change in kexts also

If I use AnyCardReader.kext it is identified as Apple Internal Card but does not mount on inserting the sd card

 

Added in 7 minutes 51 seconds:

Another thing that i have observed is that of I plug in a pen drive in the USB2.0 port it loads as USB 2.0 CRW in the ioreg. May be the card reader is not able to load the correct drivers but I don't know how to do it

Did it work for you? Can you please share me your AnyCardReader.kext?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...