Jump to content
meliodasu

Fix sleep/wave help me

Recommended Posts

Hello,


having same problem here. I have tried to boot with yout Intel 8 series folder - but Clover will not load even. Have tried to move the folders (renaming existing folders) into my working clover - still wont boot.

I am using the DSDT.aml that you generated for me - but I cannot get the system to wake from sleep. USB and screen do not seem to wake up (No USB power to my keyboard - and nothing on screen / screen not waking up.

Attached is the file generated from the RunMe.app, could you please point me in the right direction (enjoy the beer!) Thanks

Send me Neales-iMac.zip

Link to comment
Share on other sites

Thanks MaLd0n. I am an impatient type... and while waiting for your answer tried several things. NVidia Web Drivers (the default MacOS drivers work fine for my Asus GeForce GT730 - just not for waking from sleep) tried disabling AppleIntelCPUPM in clover (read it was not required for Haswell Processors) and was not sure that a patch USB3 was applied - so tried to add a kext patch.


In any case, when I tried to wake from sleep with the power button - same thing. If I wake using the USB keyboard - it gets power, but nothing else - and the screen does not turn on. When I use the power button the USB keyboard never gets power.


So it would seem that either the graphics card and / or USB are preventing waking from sleep. I am now going to revert back to how I was when I used the RunMe.app and try waking using the power button again. Pretty sure I did that but it did not work.


I really appreciate your help, how can I go about troubleshooting this - any steps you would recommend. Anything I can look at in the output of the RunMe.app?


When you created the DSDT.aml file for me, I was still trying to get OSX HighSierra installer running - and was not concerned about graphics, but I am so pleased with the setup now - everything is working pretty much flawlessly except the onboard Wi-Fi of my desktop that I have not tried - it is hard wired to Gb ethernet - so that's not a concern for me.


Getting sleep working is my main concern -I appreciate any help / tips you might have. Thanks.

Link to comment
Share on other sites

Not a lot to see in a video. The computer goes to sleep, fans and USB devices off, the power button on my Dell XE2 blinks. Its asleep. Wake it up using power button or USB keyboard - the USB devices wake, the fans turn on, the power button is normal - but the screen does not wake up.

I am completely new to DSDT editing (I'm looking to try to understand) but it seems that maybe I dont have a _GPE method to wkae the graphics cars in the DSDT.aml. Does that make any sense or ave I completely misunderstood? (Probably)

Of course I am using a discrete non EFI Asus Nvidia GeForce GT730 2GB graphics card -metal is supported - so now I have USB waking from sleep (my keyboard backlight lights where it did not before) since enabling SlpSmiAtWake enabled - I think the only think not waking up is the Graphics / display.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...