Jump to content
FCU4ever

Graphics issue Sierra Asus G73sw

Recommended Posts

After succesfull installing Sierra 10.12 on my Asus G73sw I experience a graphics issue with my Nvidia GTX460m graphics card. Without the Nvidiawebdrivers I can only boot with the nvdisable=1 bootflag and with the Nvidiawebdrivers installed I can boot Sierra normally untill I logged in to the system. My screen looks like {censored}, see attached picture. Can someone help me?

CLOVER.zip

IMG_2336.thumb.JPG.9959bd61f75a23636c352ad43cc0fb1b.JPG

Link to comment
Share on other sites

config.plist.zip

 

Many thanks for editing and cleaning up my config.plist.


I downloaded the config.plist copied to the EFI folder and reboot the laptop. Can't complete loading the apple bar. So I changed the SMBios to Macbookpro10,2 can load the apple bar for now but reboot at the end. Added nvdrv=1 to the config.plist and reboot. Now the apple bar loads and the laptop doesn't reboot. Reached the login screen, logged in and....... same error. :shock:


Then I decided to remove the Nvidiawebdrivers and uncheck it in the config.plist. Also removed the nvdrv=1 bootflag. Then I checked Inject Nvidia, Injed EDID, Load vBios and Patch vBios. Reboot and...... YEAH it's working (see attached config.plist) :D


Now I need a patched DSDT. For now I used the patched DSDT I used in El Capitan, with this DSDT my WIFI is working. The guy from this thread (https://www.insanelymac.com/forum/topic/322566-asus-g73sw-macos-sierra-10124/) claimed to have most of all working on his Asus G73sw with his patched DSDT. So I downloaded his DSDT but I'm not able to compile the DSDT.dsl :oops: and can't test if that DSDT is working for me too (without the audio). To fix the audio (ALC269) I found this thread (https://www.tonycrapx86.com/threads/guide-asus-rog-g73jh-using-clover-uefi.242770/) but I'm not able to apply the patch..... yeah I know, I'm a n00b with patching DSDT.


Can someone help me to create a correct patched DSDT with everything working? I extracted my origin files with Clover, See attachment. In the patched folder you can find the DSDT I used for now.


Here's an overview of what is working at the moment:

- Nvidia Geforce GTX460M -> config.plist

- Wifi -> El Capitan DSDT

- USB 2.0

- Batterypercentage -> ACPIBatteryManager.kext

- FNkeys ->AsusNBFnKeys.kext


And what's not working:

- Audi ALC269

- USB3.0

- Brightness FNkey (works only with nv_disabled)

- Backlight keyboard

- Cardreader

- Bluetooth

ACPI.zip

config.zip

Link to comment
Share on other sites

I'll try after work.


Before testing do I need to install 'G73JH.kext(contains dummy HDA)' just like the guy in this thread (same audio but other type of laptop) (https://www.tonycrapx86.com/threads/guide-asus-rog-g73jh-using-clover-uefi.242770/) because I also have the patches in my config.plist. 28861561_Schermafbeelding2018-08-22om08_06_17.png.6548c1bd15f214473881a74cd496ae84.png

 

Or will the audio work with only the patched DSDT without the kext and patches in config.plist?

Link to comment
Share on other sites

remove patches in config.plist

 

I remove it in my config.plist.

 

just inject ids here, save, reboot, test one by one with Lilu + AppleAlc

 

Then I install Lilu + AppleAlc and try (after work) with inject ID 1,2 and 3 and look wich one works.

Link to comment
Share on other sites

The Audio works fine after set Audio inject to detect and installing Lilu + AppleAlc in combination with the first DSDT you send me.


With the second DSDT you send me the Audio and Wifi aren't working.


So what's working for now:

- Nvidia Geforce GTX460M

- Wifi

- Audio

- USB2.0

- Batterypercentage

- AsusFNkeys


And what's not working for now:

- USB3.0

- Cardreader

- Keyboard backlight

- Brigthness FNkeys (only with nv_disabled=1)

- Bluetooth


- LAN (can't test, mine is broken. Guess it works with RealtekRTL8111.kext installed)


Also extracted a new SEND_ME folder.

config.plist.zip

DSDT.zip

Send me mbp-van-koen.home.zip

Link to comment
Share on other sites

  • Administrators

Hello, please help


im having trouble booting up to after installing nvidia web driver high sierra 10.13.6


Asus Rampage IV Extreme board

7-4930K

nvida Gtx 10x

open one topic

here is Asus Notebook

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

usb 3 is non-intel, u need a genericxhci kext, but this kext cause some problem after el capitan

 

You mean installing this kext https://bitbucket.org/RehabMan/os-x-generic-usb3/downloads/?

 

brightness need check for nvidia gpu

 

What do you mean?


The guy from this thread (https://www.insanelymac.com/forum/topic/322566-asus-g73sw-macos-sierra-10124/) has USB3.0 and bluetooth working with his DSDT.


And how to get the backlight and cardreader working?


This morning I tried to generate a SSDT with ssdtPRGen.sh from Piker-Alpha. First I get this error:

IMG_2347.thumb.JPG.481ac9d4261f5f9b2ecc0d0cf9096d70.JPG

 

Changed the SMBios to Macbookpro8,2, reboot, black screen


Changed the SMBios back to Macbookpro10,1, reboot and start the SSDT generator again. Typed y after the error and sees what happend

IMG_2348.thumb.JPG.ac89dcd276f758e7dfc487050c009cd8.JPG

 

0 Errors, 0 warning, 0 remarks, 0 optimizations. Does that mean I can use the generated SSDT even with the board-id error?


In the ssdtPRGen folder I see in the root a ssdt.aml file

IMG_2349.thumb.JPG.6e6eafdfe0bb9052d94f22c3125c4587.JPG

 

And in the ACPI folder I see another SSDT.aml file and a SSDT-1.aml file.

IMG_2350.thumb.JPG.91a215a5c5e50bf05fe9e47ce4b77285.JPG

 

Wich files do I have to copy to the EFI/ACPI/Patched folder??? Do I need to also add something to the config.plist to get te SSDT working?

Link to comment
Share on other sites

only with genericxhci kext, don't appears sin system profiler, but work, take a shot

 

USB3.0 don't work after installing the Genericxhci kext from Rehabman...... other things I can try?


Can I use the SSDT I generated with the error code (Wrong board-ID) or do I need to fix the black screen with the SMBIOS8,2 and re-generate the SSDT?

Wich generated SSDT.aml can I use? Is that the one in the root of the SSDTPRGen folder or in the ACPI folder (inside the SSDTPRGen)


Possible to get the backlight working in combination with the correct FN keys?

Link to comment
Share on other sites

to avoid blackscreen, try it


com.apple.driver.AppleGraphicsDevicePolicy

BA050000 00

BA000000 00

Prevent AGDP from loading

 

Changed the SMBIOS to MacBookPro8,2 and add your lines in KextToPatch

Reboot -> Apple bar won't load

Second try, changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2

Reboot -> Appla bar load but get a blackscreen

Third try, changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 and add your lines in KextToPatch

Reboot -> laptop boots good


Is it a problem to change the productname? Or can I better use MacBookPro10,1 SMBIOS?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...