Jump to content
MaLd0n

Hackintosh Guide - Enable Audio with AppleAlc

Recommended Posts

  • Administrators

Updated Link

https://www.olarila.com/topic/6074-guide-easy-audio-solution-with-applealc-clover-and-opencore/

 

--LIKE - COMMENT - SUBSCRIBE - SHARE--

 

 

-Patches

 

ALZA to HDEF

414c5a41

48444546

 

HDAS to HDEF

48444153

48444546

 

CAVS to HDEF

43415653

48444546

 

AZAL to HDEF

415A414C

48444546

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

DSDT.aml.zip
Thanks MaLd0n, but audio still not working, by the way I'm running Mojave official, I also want send you files but error using runme app, please help


Added in 46 minutes 22 seconds:

By the way are those highlighted files necessary? Cause every time I restart always 3 times boot loop before proper booting.

779681310_ScreenShot2018-10-01at6_59_53AM.png.a09b0fac8d92296de81fea98883bb7b4.png

2091439241_ScreenShot2018-10-01at7_02_47AM.png.f928e0008a13bf624f1105efe1e866e0.png

108806195_ScreenShot2018-10-01at6_57_58PM.png.cd3f572c45758323392bdd2e6c4dfe0e.png

Link to comment
Share on other sites

[ref]steezy[/ref], inject audio via clover


ur codec


Realtek ALC3232 / 292

 

Hi MaLd0n, thank you for being at full support all the time. While waiting your reply, I tried to install the latest AppleALC.kext inside /Library/Extensions/ luckily my audio came back. Once again please accept my deepest gratitude for all support and success on building Hackintosh. :guitar
Link to comment
Share on other sites

I have Realtek Audio ALC 225 codec and am using a tweaked AppleALC kext (1.3.8) in EFI/Clover/kexts/other. I get no devices if AppleALC and Lilu are placed in L/E or S/L/E.


Audio Status with AppleALC kext + Lilu:

  • Headphones work when jack is half inserted. Jack has 1 step and 3 white rings. There is no distortion after sleep-wake. they don't work if the jack is fully inserted.

    Other Audio Aux device connected with 3.5 mm jack doesnt work. The jack has 1 step / 2 black rings

    Internal Speaker works

    USB Audio works. This works without AppleALC too.

    Did not test HDMI Audio as I don't use it.

 

I am using native AppleHDA kext of 10.14.4. The AppleALC kext I am using has been tweaked - ConfigData used in ALC225 item has been taken from a patched AppleHDA (patched for Realtek ALC225). This tweaking eliminated the problem of headphone distortion after wake, but headphone wont work if jack is fully inserted. Other Aux devices don't work at all. Neither with half or fully inserted jack.


Audio Status with AppleHDA kext patching:

[list=]I have tried Mirone's AppleHDA patching v1.9 along with DSDT patching for layout and IRQ. Result - No devices.

I have tried my own patching using the Olarilla guide https://Olarila.com/forum/viewtopic.php?f=28&t=2676&hilit=AppleHDA+Audio+patch. Result - No devices

 


Audio Status with CodecCommander (tweaked to add ALC 225)

Headphones work even when jack is fully inserted, but distortion starts after sleep-wake. ACPI Plug Fix (with hda-verb) is ineffective.


Everything else works. There is no show-stopper issue with my Mojave 10.14.5 installation on my Dell Latitude E5280.


MaLd0n please help me get headphone /3.5 mm Audio to work properly.

debug_24563.zip

Edited by Guest
Link to comment
Share on other sites

Hello there. I'm on High Sierra, installed using your guide.

Managed to get the audio working, using layout id 11.

But every time the system starts the audio output is set to headphones instead of internal speakers.

Can I do something to get the internal speakers to be the default audio output?

I googled everywhere trying to find a solution but I couldn't.

Thanks in advance.

Hardware: MB - Asus B85M-E/BR (Realtek ALC887). CPU - Intel i3 4330. Integrated GPU (Intel hd4600)

Link to comment
Share on other sites

  • Administrators
2 hours ago, rafabsb said:

Hello there. I'm on High Sierra, installed using your guide.

try other layout

https://www.olarila.com/topic/6074-guide-easy-audio-solution-with-applealc-clover-and-opencore/

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Ola Mald0n, 

estou com a seguinte situação: tenho um nitro 5 an515-55-54L9 i5 10 geração, instalei o macOs monterey e o hackintosh esta 99% perfeito o unico problema que estou enfrentando é estar sem audio no combo jack p3. Se utilizar um fone usb funciona perfeito, ou um fone bluetooth tambem, mas o fone p2 ou p3 nao esta funcionando de forma nenhuma.

Tem alguns anos que nao uso hackintosh (desde o inicio do unibeast) entao estou bem enferrujado....

pode me ajudar?

 

 

Hello Mald0n,

I have the following situation: I have a nitro 5 an515-55-54L9 i5 10 generation, I installed macOs monterey and hackintosh this 99% perfect the only problem I'm facing is being without audio on the p3 combo jack. If you use a usb phone it works perfect, or a bluetooth phone too, but the p2 or p3 phone is not working at all.

I haven't used hackintosh for a few years (since unibeast started) so I'm pretty rusty....

can you help me?

Edited by Roxmann
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...