Jump to content
castrorec

El Capitan em Lenovo Ideapad z400 - CONFIG FINAL

Recommended Posts

Galera, bom dia.

Recentemente fiz o hack no meu notebook Lenovo Ideapad z400. Utilizei a imagem raw que encontrei para download aqui, criei o disquete de boot com clover efi e fui. Instalação tudo ok, montei o bootloader usando o clover e clover configurator (muito bom), consegui que meu audio, video e ethernet funcionassem ok. Consegui corrigir inclusive alguns bugs como o icone de bateria que não aparecia na barra de menu, e o ruido no audio, tava "perfeitinho".

Usei o sistema por dois dias, editei uns video e tal, tava tudo indo muito bem até que resolvi ver um video em uma tv hdmi e percebi que o hdmi audio estava com falhas, fui tentar resolver e dei kernel panic, forçando a refazer todo processo denovo.

Re-instalei o el capitan seguindo todos os mesmos processos, bootloader etc etc, e tudo praticamente como estava antes, rolando legal. (interando a comunidade com o meu processo de instalação)


Porém após re-instalar tudo, permaneço sem o icone de bateria na barra de menu, e o audio hdmi falhando (este em particular resolvi colocando um cabo na entrada de audio do monitor)


Eu não achei de forma nenhuma o processo/fonte exata que havia utilizado na instalação anterior para corrigir o erro do icone de bateria, os dois arquivos que eu havia baixado estavam na pasta "transferencias" quando deu kernel panic e eu tive que refazer a instalação toda. Lembro que utilizei dois arquivos apenas, um processo bem simples seguido de uma reiniciada e pronto, tava fuincionando.

Achei alguns topicos na rede a respeito do VOODOO battery e AppleACPIPlataform para corrigir este problema, tenho quase certeza de que foi este metodo que utilizei na primeira instalação, mas agora ao instalar a kext "acpiplataform", meu sistema nao inicia mais, para na tela do loader com a mensagem "System Uptime in nanoseconds: ........" e eu tenho que fazer o processo de instalação todo novamente.

Alguém ai tem uma luz do que possa ser?


E, aproveitando o topico também, gostaria de saber se após instalação, configuração de bootloader, instalação de kext gerais e especificas e etc, se tem mais alguma etapa pra realmente finalizar o processo, algo como instalação de chipset de placa mae, ou seja lá o que for que otimize ainda mais o sistema após tudo feito e funcionand.


Obrigado e desculpa o livro para ler, pelo menos assim vocês sabem mais detalhadamente do processo/erro que occrre!

Link to comment
Share on other sites

olá


nunca é boa ideia trocar appleacpiplatform por uma de outra versão


precisas de edição de dsdt para que a bateria funcione


teus problemas vem dai .. troca da acpiplatform


bom hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

olá


nunca é boa ideia trocar appleacpiplatform por uma de outra versão


precisas de edição de dsdt para que a bateria funcione


teus problemas vem dai .. troca da acpiplatform


bom hack

Bom dia Artur.

Pois é cara, só tem dado Pau aqui quando troca a appleacpiplatform...

O que tá me deixando maluco, eh que já tinha conseguido fazer funcionar na primeira instalação... Perdi as fontes e os arquivos que usei, quando deu kernel panic na primeira instalação....

Link to comment
Share on other sites

RESOLVIDO problema com icone de bateria.. SEM USAR DSDT EDIT...

Achei um pkg de um modelo de lenovo na internet e resolveu, funcionando perfeito agora...


Proximo passo é estudar um pouso dobre DSDT, edição patch e etc, pra tentar fazer a DSDT do meu notebook com audio hdmi, leitor de cartao, brighteness e tudo mais que tiver direito resolvido...


Se alguem tiver uma dica ai, só soltar aqui..



VALEU!

Link to comment
Share on other sites

Olá,

Você poderia me passar como fez o seu Boot USB, eu quero instalar no meu Lenovo Ideapad Z400.

Segue a configuração dele:

Sistema operativo
    Windows 10 Pro 64-bit
CPU
    Intel Core i7 3520M @ 2.90GHz    77 ºC
    Ivy Bridge 22nm Tecnologia
RAM
    8,00GB Duplo-Channel DDR3 @ 790MHz (11-11-11-28)
Placa mãe
    LENOVO INVALID (U3E1)
Gráficas
    Generic PnP Monitor (1366x768@60Hz)
    PHILIPS (1920x1080@59Hz)
    Intel HD Graphics 4000 (Lenovo)
    2047 MBNVIDIA GeForce GT 635M (Lenovo)    80 ºC
    Versão ForceWare: 391.35
    SLI desactivado
Storage
    476GB S3SSDC512 (SATA (SSD))    40 ºC
Audio
    Áudio Intel para telas

 

Eu pretendo utilizar para programação Node e React.

Se puder me ajudar eu agradeço, ou até mesmo uma consultoria.

Maurício Rocha

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...