Jump to content
andreJPBR

Audio ALC892 sem DSDT patch

Recommended Posts

Instalei o OSX 10.11 com Clover UEFI seguindo as instruções do Mendietinha. Até agora o sistema está estável, sem nenhum KP.

Mas não tenho audio e nem DSDT instalada. Para placas mais novas, li em outros tópicos, que DSDT é dispensável. Nos repositórios não existe ainda patche para GA Z97M D3H. E realmente o sistema parece não estar sentindo falta nenhuma de uma DSDT.

Só que meu layout-id da ALC892 está como <00 00 00 00> e preciso colocar este layout-id igual a <01 00 00 00> para ativar o audio via DummyHDA ou através do audio_cloverALC-100.command

Como conseguir layout-id=1 sem DSDT?


 

1874878851_ScreenShot2015-10-13at8_19_33AM.thumb.png.2654e025a1b8aa7eb4fd09ad27ce20d7.png

1402054259_ScreenShot2015-10-13at8_22_18AM.thumb.png.f98960aa383cf3ba61ff16962bc5d5d4.png

456741342_ScreenShot2015-10-13at8_25_07AM.thumb.png.9c82d48b19e829ae46435a21cb31f627.png

GA-Z97M-D3H | Intel Z97 | I5 4460 3.2 | GeForce GTX 750 ti | 8 GB DDR3 1666 | Realtek GbE Lan Chip | Audio ALC892 | Samsung EVO 850 120GB El Captan | Samsung EVO 850 120GB Backup | Seagate 1TB Win10 | Dell U2414H | DVD SATA | Teclado Mouse Cam USB

Link to comment
Share on other sites

 

Nao resolve. Infelizmente lá mesmo diz que funciona quando a DSDT define Device HDEF.

A priori nao vou usar DSDT neste Hack, mesmo porque não existe patch para esta placa. E eu não sei patchear uma placa por completo e ficar fazendo remendos pode bagunçar coisas que estão funcionando perfeitamente.

Preciso apenas descobrir como mudar o layout-id de <00 00 00 00> para <01 00 00 00> sem uso de DSDT.

Tenho que editar direto na kext? Tipo, com plistEditor mesmo?

Porque sem mudar para layout-id=1, por exemplo, audio_cloverALC-110_v1.0b.command não vai funcionar.

GA-Z97M-D3H | Intel Z97 | I5 4460 3.2 | GeForce GTX 750 ti | 8 GB DDR3 1666 | Realtek GbE Lan Chip | Audio ALC892 | Samsung EVO 850 120GB El Captan | Samsung EVO 850 120GB Backup | Seagate 1TB Win10 | Dell U2414H | DVD SATA | Teclado Mouse Cam USB

Link to comment
Share on other sites

Pelo fato do seu IOREG mostrar HDEF@1B suponho que o device está definido na DSDT, deveria funcionar.


Você testou? Mostra como ficou o config.plist

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Obtive êxito agora Pernacabeluda!

1295590832_ScreenShot2015-10-14at11_54_28AM.thumb.png.7cb156e6af9992497687c039b6271480.png

764935740_ScreenShot2015-10-14at11_57_40AM.thumb.png.4eaedbc3a5cb0b75cbe99ace092d7ecd.png

544240118_ScreenShot2015-10-14at11_58_12AM.thumb.png.5b98fbda29de453f89624e07dbd9b0e8.png

 

Como funcionou? Não sei. Repeti o procedimento diversas vezes e sempre retornava <00 00 00 00>

A unica coisa diferente, é que desta vez foi feito sem a flag kext-dev-mode=1

Seria esta a causa de não estar aparecendo pra mim <01 00 00 00>???????


Logo mais vou ver se o script do Toleda faz o audio rodar. Obrigado

GA-Z97M-D3H | Intel Z97 | I5 4460 3.2 | GeForce GTX 750 ti | 8 GB DDR3 1666 | Realtek GbE Lan Chip | Audio ALC892 | Samsung EVO 850 120GB El Captan | Samsung EVO 850 120GB Backup | Seagate 1TB Win10 | Dell U2414H | DVD SATA | Teclado Mouse Cam USB

Link to comment
Share on other sites

Optei pelo script do Toleda **audio_cloverALC-110.command_v1.0b** e o audio esta funcionando.

Entao agora tenho uma appleHDA funcional e patcheada que é pré-requisito para Clover patching-on-the-fly.

Assim o audio passa a sobreviver aos updates.

 

1280990924_ScreenShot2015-10-14at7_26_16PM.thumb.png.1e9e97177b645fac1d8714e625fefd60.png

GA-Z97M-D3H | Intel Z97 | I5 4460 3.2 | GeForce GTX 750 ti | 8 GB DDR3 1666 | Realtek GbE Lan Chip | Audio ALC892 | Samsung EVO 850 120GB El Captan | Samsung EVO 850 120GB Backup | Seagate 1TB Win10 | Dell U2414H | DVD SATA | Teclado Mouse Cam USB

Link to comment
Share on other sites

Quase tudo 100%

Fui testar a USB 3 lê e grava mas corta o audio.

GA-Z97M-D3H | Intel Z97 | I5 4460 3.2 | GeForce GTX 750 ti | 8 GB DDR3 1666 | Realtek GbE Lan Chip | Audio ALC892 | Samsung EVO 850 120GB El Captan | Samsung EVO 850 120GB Backup | Seagate 1TB Win10 | Dell U2414H | DVD SATA | Teclado Mouse Cam USB

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...