Jump to content
rakusson

got 'invalid object type for reserved name' error

Recommended Posts

hi,

My laptop is:

Acer eMachines E730G

Intel core i3-350M, 3GB DDR3, 320GB

ATI Mobility Radeon HD5470 512MB


Initially, I get 8 errors but after clicking 'fix errors', I do get only 1 error. The error says "Invalid object type for reserved name(found Zero requires Package)".


I have installed Lion 11A51 with working wifi (atheros), sound (VoodooHDA), batterymanager but not graphics. I am using usb mouse coz my trackpad (Elan tech) does not work but its ok. The only problem is due to my graphics card. It did worked once but after restart it didn't work. I tried many things but in vain. I think may be it is due to my DSDT. I even did EDID injection.


Interesting thing is that when I boot with Chameleon 1083 (using usb drive), I only get 1024 x 768 resolution with 3 mb but when I use Chameleon 752, I do get 1366 x 768 resolution with 4 mb memory!! I really don't understand what is the problem here.


Anyway, I would highly appreciate if you take a look on my DSDT.


I extracted this DSDT in my Windows 7 system. I have installed Lion in another partition

DSDT.zip

eMachines E730G

Intel Core i3-350M, 3 GB DDR3, ATI Mobility Radeon HD5470,Broadcom Netlink Gigabit Ethernet BCM 5788, Realtek ALC272, Elantech PS/2 TouchPad

Link to comment
Share on other sites

hi,

My laptop is:

Acer eMachines E730G

Intel core i3-350M, 3GB DDR3, 320GB

ATI Mobility Radeon HD5470 512MB


Initially, I get 8 errors but after clicking 'fix errors', I do get only 1 error. The error says "Invalid object type for reserved name(found Zero requires Package)".


I have installed Lion 11A51 with working wifi (atheros), sound (VoodooHDA), batterymanager but not graphics. I am using usb mouse coz my trackpad (Elan tech) does not work but its ok. The only problem is due to my graphics card. It did worked once but after restart it didn't work. I tried many things but in vain. I think may be it is due to my DSDT. I even did EDID injection.


Interesting thing is that when I boot with Chameleon 1083 (using usb drive), I only get 1024 x 768 resolution with 3 mb but when I use Chameleon 752, I do get 1366 x 768 resolution with 4 mb memory!! I really don't understand what is the problem here.


Anyway, I would highly appreciate if you take a look on my DSDT.


I extracted this DSDT in my Windows 7 system. I have installed Lion in another partition

 

hi,

in lion and in snow 10.6.8 should work


use last chameleon


in in org.chameleon.boot.plist use


AtiConfig

Hoolock

GraphicsEnabler

Yes



i have same card and is working with forced EDID


http://puu.sh/5HM1

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites


hi,

in lion and in snow 10.6.8 should work


use last chameleon


in in org.chameleon.boot.plist use


AtiConfig

Hoolock

GraphicsEnabler

Yes



i have same card and is working with forced EDID


http://puu.sh/5HM1

hi,

Thanks for the reply. Actually, I am trying this for almost a month now. If my graphics card does not work then it is very difficult to use Lion. Are you using the same ATI kexts that comes with Lion or did u use some other kexts? what about DSDT? I can boot my computer without DSDT too but does not know if the problem is due to DSDT or not? Which Chameleon are you using to run your Lion? Hope to hear from you soon.

eMachines E730G

Intel Core i3-350M, 3 GB DDR3, ATI Mobility Radeon HD5470,Broadcom Netlink Gigabit Ethernet BCM 5788, Realtek ALC272, Elantech PS/2 TouchPad

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[attachment=0]dsdt.rakusson.zip[/attachment]

Thanks mald0n. I will try and let you know. Hope for the best.

eMachines E730G

Intel Core i3-350M, 3 GB DDR3, ATI Mobility Radeon HD5470,Broadcom Netlink Gigabit Ethernet BCM 5788, Realtek ALC272, Elantech PS/2 TouchPad

Link to comment
Share on other sites

hi,

Thanks for the reply. Actually, I am trying this for almost a month now. If my graphics card does not work then it is very difficult to use Lion. Are you using the same ATI kexts that comes with Lion or did u use some other kexts? what about DSDT? I can boot my computer without DSDT too but does not know if the problem is due to DSDT or not? Which Chameleon are you using to run your Lion? Hope to hear from you soon.

 


hello,


i'm using ati kexts from the system in lion and in snow 10.6.8


only thing i use is forced EDID, and in DSDT nothing for the graphics .


now i'm using chimera 1.5.4 for the boot


do the boot with -v and see if chameleon show your gpu using the keys in boot.plist


i think is not a problem of the boot loader because last chameleons and all chimeras are working for me


use forced EDID .

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×
  • Create New...
The popup will be closed in 15 seconds...