Jump to content
Jahworks

Problema VTDecoderXPCService e NVDA_channel timeout.

Recommended Posts

Olá gente! Eu tenho alguns problemas quando uso a Smbios correta para o meu sistema MacbookPro9,1. Tenho um i7 3610QM funcionando com todas as states ssdt mas sempre que vou editar algum vídeo ele têm problemas:


8t3Zr.jpg



Esse é o mais clássico dos problemas. Toda vez que estou usando a Smbios correta e vou abrir algum vídeo com o preview do quicktime no finder tenho essa tela e em seguida NVDA(OpenGL): Channel timeout! e tenho que reiniciar. Estou usando um comando para gerar minhas states criado por oldnapalm:

 

sudo cp /System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources/MacBookPro8_2.plist /System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources/MacBookPro9_1.plist ; sudo perl -pi -e 's|MacBookPro8,2|MacBookPro9,1|g' /System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources/MacBookPro9_1.plist ; sudo touch /System/Library/Extensions

 

Mas aí quando uso o Smbios Imac13,1 ele não têm nenhum dos problemas citados mas perco todos os States e fico apenas com x23 e o bench menor que a smbios MacbookPro9,1


8zdFS.png


Gostaria de saber se existe alguma solução para ter todos os States com a Smbios Imac13,1?!!


Existe um tópico aberto no insanelymac para quem tiver interesse:


http://www.insanelymac.com/forum/topic/293165-vtdecoderxpcservice-quit-unexpectedly/



obrigado.

Edited by Guest

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

Talvez o MacBookPro8_2.plist não seja o melhor para o teu caso.


Acho que também é importante usar o mesmo control-id para GPU em MacBookPro9_1.plist e na AGPM


http://Olarila.com/forum/viewtopic.php?f=3&t=629


Tenta com estes arquivos, só coloca o device ID do teu vídeo na LegacyAGPM (Vendor10deDeviceXXXX)

Arquivo Comprimido.zip

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Talvez o MacBookPro8_2.plist não seja o melhor para o teu caso.


Acho que também é importante usar o mesmo control-id para GPU em MacBookPro9_1.plist e na AGPM


http://Olarila.com/forum/viewtopic.php?f=3&t=629


Tenta com estes arquivos, só coloca o device ID do teu vídeo na LegacyAGPM (Vendor10deDeviceXXXX)

[attachment=0]Arquivo Comprimido.zip[/attachment]

 

-------------->


Então, Perna. Eu coloquei o meu dev id na LegacyAGPM.kext como está descrito na foto:


8AB4e.jpg


O segundo arquivo que você me enviou foi a: MacBookPro9_1.plist:


8ABhw.jpg


O que faço com ela? Obrigado!!

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

Substitui o arquivo criado pelos comandos que você postou, repara permissões e atualiza o kernelcache.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Funciona bem o MacbookPro9,1. Ele me dá todos os States e a kext AGPM aparece carregada mas não consigo fazer preview em nenhum vídeo com o quicktime e a tecla espaço. Fica tudo rosa como na foto postada. Acho que a Smbios que causa isso. Quando uso a Smbios Imac13,1 eu não tenho nenhum problema mas perco os states ficando apenas x12 e x23. Gostaria de saber se tem como eu ter todos os states com essa Smbios Imac13,1 e ter agpm também,pois é a melhor forma de eu ver e editar meus vídeos.

Obrigadoo!

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

O que acontece se você usar SMBIOS de MacBookPro9,1 sem criar o arquivo MacBookPro9_1.plist?


Acho que para ter os states com iMac13,1 você precisa criar o arquivo iMac13_1.plist baseado num modelo com mesmo CPU.


Se ao criar o plist acontecer o mesmo problema de vídeo, tenta remover as partes referentes a GPU, por exemplo

MacBookPro9_1.plist.zip

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

O que acontece se você usar SMBIOS de MacBookPro9,1 sem criar o arquivo MacBookPro9_1.plist?


Acho que para ter os states com iMac13,1 você precisa criar o arquivo iMac13_1.plist baseado num modelo com mesmo CPU.



Se ao criar o plist acontecer o mesmo problema de vídeo, tenta remover as partes referentes a GPU, por exemplo

[attachment=0]MacBookPro9_1.plist.zip[/attachment]

 

Estou chegando e irei testar. Vlw pernacabeluda!

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

O que acontece se você usar SMBIOS de MacBookPro9,1 sem criar o arquivo MacBookPro9_1.plist?


Acho que para ter os states com iMac13,1 você precisa criar o arquivo iMac13_1.plist baseado num modelo com mesmo CPU.


Se ao criar o plist acontecer o mesmo problema de vídeo, tenta remover as partes referentes a GPU, por exemplo

[attachment=0]MacBookPro9_1.plist.zip[/attachment]

 


-------


O que acontece sem criar a plist Smbios MacbookPro9,1? O sistema trava do mesmo jeito.

A referida plist. me dá todos os states mas não consigo abrir um vídeo com o preview (tecla espaço) que o OS trava. Que estranho.

Alguma outra indicação? Só não trava com Imac13,1.

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

Tenta com iMac13,1 e cria o plist correspondente para ver se ativa os states sem causar problema no vídeo.


Só não me pergunta como fazer isso porque eu não sei. Acho que só na tentativa e erro, baseado nos existentes com mesmo CPU, ou tem que tentar compreender o que faz cada chave do plist.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Tenta com iMac13,1 e cria o plist correspondente para ver se ativa os states sem causar problema no vídeo.


Só não me pergunta como fazer isso porque eu não sei. Acho que só na tentativa e erro, baseado nos existentes com mesmo CPU, ou tem que tentar compreender o que faz cada chave do plist.

 

Entendi pernacabeluda. Eu não tenho essa conhecimento todo para criar essa .plist para funcionamento dos states.

Acho que vou me contentar até sair a nova versão do Mavericks pra instalar com o Clover e ver se ele consegue solucionar esse problema da GPU. Eu tenho o notebook funcionando perfeito com MacbookPro9,1 pra navegação menos para edição e visualização dos arquivos de vídeo. Quando vou editar ou ver alguns vídeos estou colocando Imac13,1

Teria como a legacyagpm funcionar com Imac13,1? obrigado.

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

Eu não tenho essa conhecimento todo para criar essa .plist para funcionamento dos states.

Lá no início você postou comandos que copiam e modificam um plist. Um teste simples seria mudar o destino para iMac13,1 e variar a origem. Também pode fazer o mesmo usando o Finder e um editor de plist ou de texto mesmo.

 

Teria como a legacyagpm funcionar com Imac13,1?

Só testando para saber. Como não tenho esse hardware não posso te responder.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Lá no início você postou comandos que copiam e modificam um plist. Um teste simples seria mudar o destino para iMac13,1 e variar a origem. Também pode fazer o mesmo usando o Finder e um editor de plist ou de texto mesmo.



Só testando para saber. Como não tenho esse hardware não posso te responder.

 

Como faço pra testar? Já tem um modelo de AGPM para Imac13,1? Encontrei falando que isso acontece desde o 10.5 https://discussions.apple.com/message/10214209?messageID=10214209#10214209 mas muito radical.

Vou tentar posteriormente com o 10.8.2.

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

rapaz, que bela maquina. boa sorte.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

rapaz, que bela maquina. boa sorte.

 

Hmm! Obrigado. Ela funcionou bem no ML 10.8.2. Se continuar a ter problemas ate o 10.9.3 irei voltar para o ML.


Pernacabeluda aqui vai o OpenGL com o Imac13,1 sem legacyAGPM:


8B2Hk.jpg

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

No caso de laptop acho que o que mais interessa no AGPM não é a performance, que pode ser igual com ou sem a kext, mas sim se a placa volta para o state mais baixo quando ociosa, pois se ficar sempre no máximo vai esquentar muito, ventoinha girando sempre a toda e bateria drenada em minutos.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

No caso de laptop acho que o que mais interessa no AGPM não é a performance, que pode ser igual com ou sem a kext, mas sim se a placa volta para o state mais baixo quando ociosa, pois se ficar sempre no máximo vai esquentar muito, ventoinha girando sempre a toda e bateria drenada em minutos.

 

E como faço pra saber se ele está voltando pra o state mais baixo? Agora estou usando Imac11,1 e estou tendo todas as tabelas funcionando normalmente. =)

E até agora sem freezes!

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

No link sobre AGPM que eu indiquei explica como.


Também pode usar o HWMonitor com o plugin para GPU.

 


Valeu perna. Irei tentar a LegacyAGPM.kext mas o sistema mesmo sem LegacyAGPM carrega a com.apple.driver.AGPM como na foto:



8CkzO.jpg


Essa é uma foto do HwMonitor funcionando com States corretos usando Imac11,1:


8CkEh.jpg


mas estou sem legacyAGPM.kext . Como faço pra saber se é preciso usá-la ?


O meu GeekBench ficou igual ao MacbookPro9,1 quando alterei a Smbios para Imac11,1:


8CkJ4.jpg

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

Estava tendo problema de NVDA_channel timeout.

procurei bastante na internet, e muita gente tem esse problema, acabei encontrando uma possível solução, um aplicativo chamado freezefix.app


Acabei de rodar aqui no hack, não vou poder testar muito pq já esta tarde...

vc pode testar ai tbm...

freezefix.app.zip

 

lembrando que se funcionar, tem que colocar ele para iniciar automático... boa sorte...

Link to comment
Share on other sites

Estava tendo problema de NVDA_channel timeout.

procurei bastante na internet, e muita gente tem esse problema, acabei encontrando uma possível solução, um aplicativo chamado freezefix.app


Acabei de rodar aqui no hack, não vou poder testar muito pq já esta tarde...

vc pode testar ai tbm...

[attachment=0]freezefix.app.zip[/attachment]

 

lembrando que se funcionar, tem que colocar ele para iniciar automático... boa sorte...

 

Obrigado eu já uso o freezefix. Ele funciona muito bem para mim. O meu problema é que com Smbios MacbookPro9,1 eu ainda tenho freezes e essa telas rosas. Eu tive que mudar o SMBIOS para Imac11,1 porque nele não tem Intelhd4000 para eu fugir do problema Nvda_channel timeout. Combinando a Smbios Imac11,1 eu tenho ssdt e não tenho mais freeze. É isso! =)

Valeuu!

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

O freezefix app, não resolveu para mim...

 

[attachment=0]Captura de Tela 2014-05-12 às 15.47.55.png[/attachment]

 

Mudei meu sábios para iMac 10,1 para ter AGPM, coloquei uma legacyagpm, o AGPM é carregado, e o problema continua, como posso resolver?

Obrigado.

 


Olá, você tem que por ao app Freezefix para iniciar junto com o sistema e mudar a smbios para Imac11,1 ou Imac12,2.

Apenas isso. Aqui funciona pra mim.

ASUS G75VW-RS72 • CPU: Intel Core i7- 3610QM 2.29GHz • RAM: 12 GB DDR 3 ELPIDA • HD: 240GB CORSAIR GS SSD (MAC OS) HD 2 750GB (Win 8) • GPU: GeForce GTX 670M 3GB 1920x1080 • OS: Mac OS X 10.10. (14A389) • BIOS: 223.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...