Jump to content
dubss

Ativação QE CI na Intel HD 4000

Recommended Posts

Ultimamente, não estou conseguindo ativar a minha intel hd 4000

Já tentei seguir vários procedimentos, mas o principal fator é o modo de não rodar as 3 kexts da intel:

AppleIntelHD4000Graphics, AppleIntelFramebufferCapri e AGPM

Alguém pode me ajudar?

Share this post


Link to post
Share on other sites

vc precisa usar uma smbios de macbook pro 9,2, o string correto e GraphicsEnabler=No


veja se suas kexts estão intocadas, pois se instalar retirando elas do pendrive, as do sistema ficam sem info.plist e não funcionam.

Edited by Guest

Share this post


Link to post
Share on other sites
vc precisa usar uma smbios de macbook pro 9,2, o string correto e GraphicsEnabler=No


veja se suas kexts estão intocadas, pois se instalar retirando elas do pendrive, as do sistema ficam em info.plist e não funcionam.

mas conforme eu vi em um tópico daqui, meu not é MacBook Air 5,2 pelo fato de ter Core i5 de 3 geração, de qualquer jeito devo mudar pro macbook pro 9,2? e q string devo usar?

Share this post


Link to post
Share on other sites
no tópico que postei tem algumas pra mobile, veja qual funciona melhor pro seu caso. teste.

 

posso colocar meu not como macbook pro 9,2 no chameleon wizard e colocar graphicsenabler=no e reiniciar o pc

e logo após instalar as 3 kexts pelo kext utility e reiniciar o pc?

Share this post


Link to post
Share on other sites

sim, mas antes tem que colocar a string no chameleon wizard mesmo, na caixa lá embaixo.


e as kexts já estão no sistema, se for instalar kexts que achou por ai pode ter problemas diferentes e fica dificil de ajudar.

Share this post


Link to post
Share on other sites


posso colocar meu not como macbook pro 9,2 no chameleon wizard e colocar graphicsenabler=no e reiniciar o pc

e logo após instalar as 3 kexts pelo kext utility e reiniciar o pc?

 

Deixa as kexts originais em seu devido lugar, não é necessário modifica-las ou removê-las.

Lembrando que a ig-platform-id pode ser diferente.

Share this post


Link to post
Share on other sites
sim, mas antes tem que colocar a string no chameleon wizard mesmo, na caixa lá embaixo.


e as kexts já estão no sistema, se for instalar kexts que achou por ai pode ter problemas diferentes e fica dificil de ajudar.

 

as kexts que estavam no sistema eu tive que excluir para conseguir rodar, porem baixei elas novamente.

Share this post


Link to post
Share on other sites


Deixa as kexts originais em seu devido lugar, não é necessário modifica-las ou removê-las.

Lembrando que a ig-platform-id pode ser diferente.

 

como havia dito, tive que excluir as kexts para conseguir rodar, pq travava no boot, então seguirei os seguintes passos:

1 colocar o notbook como macbook pro 9,2 e reiniciar

2 ir no chameleon e desativar o GraphicsEnabler=Yes

3 tentar rodas as 3 kexts


to certo?

Share this post


Link to post
Share on other sites
e inserir o string correto.

 

Mesmo com minha smbios como MacBook Pro 9,2 ; e com graphicsenabler=no, eu não consigo rodar as 3 kexts da Intel, fica dando can't load no boot

Share this post


Link to post
Share on other sites

Eu e o dubss utilizamos o mesmo notbook, e sermão com o mesmo problema, que é rodar as 3 kexts da Intel, se conseguir isso, acho que consiguirei a ativação.

Share this post


Link to post
Share on other sites

Ultimamente estou tentando ativar minha Intel HD 4000, mas estou tento muitos problemas, e o principal é não conseguir carregar as 3 kexts (AppleIntelHD4000Graphics, AppleIntelFramebufferCapri, e AppleGraphicsPowerManagement). Injeto elas pelo kext utility, mas quando reinício o pc da erro.

Share this post


Link to post
Share on other sites
Eu e o dubss utilizamos o mesmo notbook, e sermão com o mesmo problema, que é rodar as 3 kexts da Intel, se conseguir isso, acho que consiguirei a ativação.

 

Instalei o Mavericks sem remover nenhuma kexts de video, bastei subir a instalação no safe mode, caso queira ter a resolução nativa, acrescente IntelCapriFB=3 GraphicsEnabler=Yes.


Estão fazendo errado. Já tem DSDT? Se não, extraiam e anexe aqui.


PS: Lembrando que a flag IntelCapriFB o valor dela pode ser de 0,1,2,3,4,8,9,A,B. Estas strings que vocês devem testar, uma por uma.

Edited by Guest

Share this post


Link to post
Share on other sites

olha, reinstala tudo. só retira a framebuffercapri e depois de instalar coloca ela de volta no lugar da que vai estar lá.


então depois de estar com o boot pelo hd configurado, retire o graphics enabler, coloque smbios de mbp 9,2 e insira o string no device proprieties do chameleon wizard. veja no tópico os strings prontos um deles é o correto. postei o que funcionava pra mim nesse mesmo tópico, tente esse primeiro.

Share this post


Link to post
Share on other sites
Ultimamente estou tentando ativar minha Intel HD 4000, mas estou tento muitos problemas, e o principal é não conseguir carregar as 3 kexts (AppleIntelHD4000Graphics, AppleIntelFramebufferCapri, e AppleGraphicsPowerManagement). Injeto elas pelo kext utility, mas quando reinício o pc da erro.

Como falei no outro tópico, você precisa saber o valor da string de sua HD 4000.


Mova as kexts para sua pasta original /System/Library/Extensions e dê rebuid e permissions e/ou touch /System/Library/Extensions pelo Terminal.


Reinicie o seu notebook, no boot do Chameleon inicie com as flags:

-v -f IntelCapriFB=X GraphicsEnabler=Yes

 

Onde X deverá ser os seguintes valores, 0,1,2,3,4,6,8,A,B. Vai testando um por vez até achar a correta.

No meu caso funcionou com 3, tente você e poste o seu resultado.


Caso alguma delas tenha funcionado, insira no org.chameleon.Boot.plist:

	<key>IntelCapriFB</key>
<string>3</string>

 

Pela DSDT, neste tópico abaixo. Caso não sabia como fazer, poste sua DSDT que já adiciono com Brightness e Backlight.

http://Olarila.com/forum/viewtopic.php?f=3&t=1583

Share this post


Link to post
Share on other sites

Como falei no outro tópico, você precisa saber o valor da string de sua HD 4000.


Mova as kexts para sua pasta original /System/Library/Extensions e dê rebuid e permissions e/ou touch /System/Library/Extensions pelo Terminal.


Reinicie o seu notebook, no boot do Chameleon inicie com as flags:

-v -f IntelCapriFB=X GraphicsEnabler=Yes

 

Onde X deverá ser os seguintes valores, 0,1,2,3,4,6,8,A,B. Vai testando um por vez até achar a correta.

No meu caso funcionou com 3, tente você e poste o seu resultado.


Caso alguma delas tenha funcionado, insira no org.chameleon.Boot.plist:

	<key>IntelCapriFB</key>
<string>3</string>

 

Pela DSDT, neste tópico abaixo. Caso não sabia como fazer, poste sua DSDT que já adiciono com Brightness e Backlight.

http://Olarila.com/forum/viewtopic.php?f=3&t=1583

 

Ok amigo, vou tentar esse processo e posto o resultado. E sobre DSDT, eu não entendo muito...

Outra coisa: quando você diz para mover para pasta original é para utilizar o Kext Utility?

Share this post


Link to post
Share on other sites

Até agora tentei com 3 e não mudou nada, e já estou com as 3 kexts, agora tentarei com outro numero...

Share this post


Link to post
Share on other sites

Amigo, tentei com todos, um de cada vez, minha SMBios ta como mbp 9,2 e ativei o GraphicsEnabler, mas mesmo reiniciando com um número de cada vez, não deu certo

Share this post


Link to post
Share on other sites

você está dando boot direto do hd ou pelo pendrive?


não adianta se estiver dando boot pelo pendrive.


como já disse, reinstale o sistema removendo somente a framebuffercapri, depois de instalado e dando boot pelo hd, sem pendrive, reinstale a framebuffercapri que retirou antes e tente as soluções aqui propostas.

Share this post


Link to post
Share on other sites
você está dando boot direto do hd ou pelo pendrive?


não adianta se estiver dando boot pelo pendrive.


como já disse, reinstale o sistema removendo somente a framebuffercapri, depois de instalado e dando boot pelo hd, sem pendrive, reinstale a framebuffercapri que retirou antes e tente as soluções aqui propostas.

 

estou dando boot pelo hd mesmo, sem o pen drive, e tens certeza q precisar reinstalar todo o mac? :cry:

Share this post


Link to post
Share on other sites


estou dando boot pelo hd mesmo, sem o pen drive, e tens certeza q precisar reinstalar todo o mac? :cry:

De onde foram tiradas estas kexts?

E também posta uma foto quando para de carregar o sistema.

Share this post


Link to post
Share on other sites

De onde foram tiradas estas kexts?

E também posta uma foto quando para de carregar o sistema.

 

então amigo, as kexts agora estão rodando normal. tirei elas se n me engano de um tópico daqui do fórum mesmo, e o sistema carrega normal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...