Jump to content
edgaredgar

[Ajuda] Falhas em imagens com Intel HD 3000

Recommended Posts

Olá!


Estou com meu hackintosh em quase perfeito estado, exceto por essas linhas brancas que aleatoriamente aparecem na tela e tendem a aumentar quan utilizo programas como Handbrake ou iMovies.


fc0i.jpg



Informações:

Uso chameleon

Tenho DSDT patcheada

Modifiquei appleSNBgraphics.kext para obter saída VGA

Minha DSDT apresentou erros de compilação ao usar DSDT editor (utilizei chameleon wizard para isso)

Tais linhas vêm desde antes de patchear a DSDT

Outras specs na assinatura


Agradeço desde já! :D

Edited by Guest

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Sem mudanças com Graphics Enabler=No.


Aqui está DSDT extraída pelo DSDT editor enquanto chameleon estava sem DSDT:

https://www.dropbox.com/sh/b3537adkyt1v06v/plk3nfAAD-/DSDT.dsl


Em relação ao AGPM, nunca editei nada, mas vi que essa kext é carregada.

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Avanços! :P

Gerei minha SSDT de modo que as linhas quase sumiram, elas continuam aparecendo quando abro algum aplicativo, mas tendem a sumir após um tempo.

Ainda vou apagar Nullpowermanagement, mas somente após criar um backup (Afinal, eu posso mesmo fazer isso?)

Edited by Guest

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Olá! :D

Testei sua DSDT, porém não houveram alterações nessas linhas. Entretanto, depois de gerar minha SSDT (uso chameleon) de patchear AppleIntelCPUPowerManagement.kext e de apagar NullCPUPowerManagement.kext elas passaram a aparecer só em uso extremo.

Ainda há alguma coisa que eu possa fazer?



---Edit---


Acho que ficou um pouco pior... :lol:

Mas voltou ao normal após reinício


2ru0.png

Edited by Guest

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

É... Parece que não há solução. :cry:

Vi em outras páginas pessoas com o mesmo problema com esse chipset 7 series e intel hd 3000(desculpem, esqueci de falar sobre isso).


Mas ainda vou continuar no Mac, mesmo com essas falhas Mac ainda é muito melhor que aquele Windows 8 ridículo. :vomit:



Valeu pela atenção, Mirone

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Você tentou editar a chave IOPCIPrimaryMatch dentro de AppleIntelMEIDriver na kext AppleIntelSNBGraphicsFB?


Parece que o padrão nos Macs com HD 3000 é ter o chipset 6 Series e nos com HD 4000 o chipset 7 Series.


AppleIntelSNBGraphicsFB.kext - 0x1C3A8086 - 6 Series/C200 Series Chipset Family MEI Controller


AppleIntelFramebufferCapri.kext - 0x1E3A8086 - 7 Series/C210 Series Chipset Family MEI Controller

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Sim, mas mudei também AppleIntelFramebufferCapri.kext


Ficando assim:

AppleIntelSNBGraphicsFB.kext - 0x1E3A8086


AppleIntelFramebufferCapri.kext - 0x1C3A8086



---Edit---

Só para constar:

Modelo do chipset: HM65 (Uso Notebook)

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Ao menos vou tentar ajudar:


Tentei várias combinações de configurações e cheguei a tais configurações:


Se você tem um Acer Aspire E1-571 tente assim:

Primeiro, não use iAtkos, use isso (http://Olarila.com/forum/viewtopic.php?f=27&t=3101)

Fake SMC Na versão 4.2 (testei várias, eu acho que essa foi a melhor)

DSDT Com os patches Notebook Core i Sandy Bridge deste tópico (http://Olarila.com/forum/patches.php)

SSDT Gerada, Caso use Chameleon (http://Olarila.com/forum/viewtopic.php?f=18&t=1703)

AICPM patcheada (http://Olarila.com/forum/viewtopic.php?f=9&t=1003)

Edite a chave IOPCIPrimaryMatch dentro de AppleIntelMEIDriver nas kexts AppleIntelSNBGraphicsFB e AppleIntelSNBGraphicsFB

Delete NullCPUPowerManagment.kext (depois de patchear AICPM, claro)

Use Elan Touchpad (http://forum.osxlatitude.com/index.php?/topic/1948-elan-touchpad-driver-mac-os-x/)

Wifi? Só se trocar a Mini-Pci, que se encontra ao abrir essa gaveta que ele tem embaixo

Recomendo pôr mais RAM, 2GB é triste...


OBS: Desative a troca automática de Wallpaper, isso não é pra você.

Edited by Guest

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Solução: Fazer essas alterações na AGPM.kext, pois, no meu caso, AGPM controller reportava unknownplatform.

0jzd.jpg


OBS: Antes veja se AGPM controller reporta unknownplatform, se seu Dev id é 0126 e se seu SMBIOS é o do Mac Pro 8,1


Comigo isso solucionou!


Obrigado à todos.

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Olá


Isso vai ajudar a muitos com certeza. ;)


Geralmente falhas gráficas com HD 3000 é referente a Chipset como era teu caso.

CPU: Intel i7 2600 | Mobo: IPMH61R1 | Memória: 8Gb| Áudio: VT1705| Gráfica: GeForce GT 610 | HD: 500GB, 80GB | SO: Windows 7/OS X Mavericks 10.9

Não Damos Suporte as ferramentas de tonycrap

We don't give support tonycrap's tools

Link to comment
Share on other sites

Uma pequena dica, alguém tendo o mesmo problema recomendo trocar "IGPU" por "GFX0" ao invés do "Vendor8086Device0126" que disse antes. Desse jeito nunca tive problemas. Como também não aparece feedback da [ AGMP controller ] (esse é o ideal, correto?)


Só mais uma coisa, vocês não acham que seria uma boa colocar uma observação sobre isso aqui: http://Olarila.com/forum/viewtopic.php?f=3&t=1339 ?

My specs:

Notebook Asus E-571

i5 2450M sandybridge e intel HD 3000 (0x0126)

Clover UEFI Bootloader

Mavericks 10.9 + Windows 8.1

Link to comment
Share on other sites

Solução: Fazer essas alterações na AGPM.kext, pois, no meu caso, AGPM controller reportava unknownplatform.

0jzd.jpg


OBS: Antes veja se AGPM controller reporta unknownplatform, se seu Dev id é 0126 e se seu SMBIOS é o do Mac Pro 8,1


Comigo isso solucionou!


Obrigado à todos.

 

Olá como você corrigiu? A imagem não aparece para aplicar a mesma configuração.

Link to comment
Share on other sites

Normalmente a edição da AGPM (AppleGraphicsPowerManagement.kext) consiste em inserir o ID do dispositivo (no caso dele Vendor8086Device0126) na parte referente ao SMBIOS usado.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...