Jump to content
nmz1

alc269 does not work

Recommended Posts

 

Mirone


There is a group of us trying to get Acer V5-171 11.6" laptop working. Everything seems to work now except Sound and Sleep. We think we need a DSDT but no-one understands how to and how to edit kext for our ALC269. Could you PLEASE help? PLEASE?


DSDT for BIOS 2.13 attached. I will promise to test AND respond (unlike last poster!)

dsdt.7z

Link to comment
Share on other sites


Mirone


There is a group of us trying to get Acer V5-171 11.6" laptop working. Everything seems to work now except Sound and Sleep. We think we need a DSDT but no-one understands how to and how to edit kext for our ALC269. Could you PLEASE help? PLEASE?


DSDT for BIOS 2.13 attached. I will promise to test AND respond (unlike last poster!)

I need your codec_dump extracted through Linux.

and your DSDT.

btn_donate_SM.gif
Link to comment
Share on other sites


http://www.insanelymac.com/forum/topic/46378-how-to-get-a-linux-codec-dump/ - I followed this process and there were two codecs... Attached with DSDT in single 7zip


No edits done to DSDT (no idea how!)


Thanks for your help and prompt response

here's your DSDT + AppleHDA corrected

try and let me know if it worked for you.

http://www.sendspace.com/file/9pi87d

btn_donate_SM.gif
Link to comment
Share on other sites

I tried and my internal speaker worked. Thanks so much Mirone. I haven't tried internal mic yet as I faced another issue: my USB ports and webcam camera, which had worked OOB, didn't work anymore.


I guess it could be the dsdt.aml. I have extracted dsdt.aml for my laptop before I tried the one you gave me. Could you help adding stuffs to my extracted dsdt.aml? Thanks.

Fujitsu_dsdt.zip

Link to comment
Share on other sites

I tried and my internal speaker worked. Thanks so much Mirone. I haven't tried internal mic yet as I faced another issue: my USB ports and webcam camera, which had worked OOB, didn't work anymore.


I guess it could be the dsdt.aml. I have extracted dsdt.aml for my laptop before I tried the one you gave me. Could you help adding stuffs to my extracted dsdt.aml? Thanks.

what's your setup?

pass me the specs of your notebook.

btn_donate_SM.gif
Link to comment
Share on other sites

My notebook is Fujitsu LH532: Core i5-3210M CPU, HD4000, FJ Webcam, ALC269, Ralink RT3290LE (I'm ordering an Atheros AR9280 AR5BHB92) and Realtek PCIe GBE Gigabit LAN. Among those, HD4000, ALC269 and Ralink RT don't work. So I added a hex string in boot.plist for HD4000, and used the patch you gave me for ALC269.


It has ML10.8 and Windows 8 dual boot.


Update 1:

- I copy this method from DSDT.aml file you sent to me to my DSDT's HDEF section


Method (_DSM, 4, NotSerialized)

{

Store (Package (0x06)

{

"hda-gfx",

Buffer (0x0A)

{

"onboard-1"

},

"layout-id",

Buffer (0x04)

{

0x0C, 0x00, 0x00, 0x00

},

"PinConfigurations",

Buffer (Zero) {}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}


My ML is now working ok; webcam, USB work with no kernel panic.


Update 2:

Internal Speaker and headphone worked. Internal mic and external mic didn't work. The system recognized external mic when I plugged it in and turned back to internal mic when external mic was plugged out. However, I couldn't see any signal for mic.


Is there any solution for my mic? Thanks.

Link to comment
Share on other sites

My notebook is Fujitsu LH532: Core i5-3210M CPU, HD4000, FJ Webcam, ALC269, Ralink RT3290LE (I'm ordering an Atheros AR9280 AR5BHB92) and Realtek PCIe GBE Gigabit LAN. Among those, HD4000, ALC269 and Ralink RT don't work. So I added a hex string in boot.plist for HD4000, and used the patch you gave me for ALC269.


It has ML10.8 and Windows 8 dual boot.


Update 1:

- I copy this method from DSDT.aml file you sent to me to my DSDT's HDEF section


Method (_DSM, 4, NotSerialized)

{

Store (Package (0x06)

{

"hda-gfx",

Buffer (0x0A)

{

"onboard-1"

},

"layout-id",

Buffer (0x04)

{

0x0C, 0x00, 0x00, 0x00

},

"PinConfigurations",

Buffer (Zero) {}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}


My ML is now working ok; webcam, USB work with no kernel panic.


Update 2:

Internal Speaker and headphone worked. Internal mic and external mic didn't work. The system recognized external mic when I plugged it in and turned back to internal mic when external mic was plugged out. However, I couldn't see any signal for mic.


Is there any solution for my mic? Thanks.

Try this: http://www.sendspace.com/file/d8loes

btn_donate_SM.gif
Link to comment
Share on other sites

Thank Mirone for your work. The second kext didn't work. It was even worse.

My OSx86 indicated no input.

1046682.png


With the previous kext, it recognized Internal Microphone

1046684.png


and Line in.

1046686.png


When I plugged in or plugged out a line in, I could see signal bar changing.

1046688.png


The only problem was that the microphone or a line in couldn't pick up any signal when I spoke to it.

Link to comment
Share on other sites

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...