Jump to content
RBFraphael

[Ajuda] EFI Clover r5114 funcionando quase tudo, OpenCore 0.6.2 e 0.6.9 não

Recommended Posts

Boas!

Estou tentando economizar uma grana não comprando um hardware próprio para montar um hackintosh rs... Então, estou tentando fazer um hackintosh funcional no meu notebook Lenovo G40-80. Tenho uma EFI Clover que não lembro onde consegui (nem se fui eu mesmo que montei rsrs), que tem praticamente tudo funcionando, inclusive a placa wifi. Contudo, quero subir do Catalina para o Big Sur, então preciso migrar para o OpenCore.

Encontrei uma EFI do OpenCore no GitHub, porém está na versão 0.6.2 e queria deixar o mais atualizado possível... Então comecei a montar uma EFI do zero seguindo o guia de instalação do OpenCore. Cheguei num resultado quase ideal, usando a versão mais recente do OpenCore (até o momento, a 0.6.9). Só o que ficou faltando fazer funcionar é o wifi (que não me importo se não funcionar, já que minha surpresa é funcionar no Clover, então já pensava em pegar outro adaptador wifi que seja compatível com macOS) e o teclado e touchpad (esse não estou entendendo por que não funciona)...

Minha "build" do OpeCore foi basicamente pegando os SSDTs SSDT-HPET.aml e SSDT-BATT.aml da build que encontrei no GitHub, e o resto montando tudo do zero (inclusive montei os próprios SSDTs, sem pegar nenhum prebuilt que o guia do OpenCore disponibiliza).

As configs do notebook são as seguintes:

Processador: Intel Core i5 5200U
iGPU: Intel HD Graphics 5500
dGPU: AMD Radeon R5 M230 (não funciona no macOS, já esperado então nem é relevante)
RAM: 2x8GB DDR3L Kazuk 1600MHz
Áudio: Conexant CX20751/2
Wifi: Atheros AR9565
Ethernet: Realtek RTL8105E
Touchpad: ELAN PS2
Teclado: PS2

O mais crítico pra mim nesse momento é fazer o teclado e touchpad funcionarem... Tentei o VoodooPS2Controller do Acidanthera e do RehabMan e nenhum deles funcionou, sabe lá Deus por quê... Muito estranho, porque na build do Clover R5114 funciona perfeitamente.

A rede Wifi que funciona na build do Clover é por causa de um kext IO80211_ATH que tem no Clover, e não deixa nem o macOS dar boot no OpenCore.

Estou deixando aqui os links para as EFIs que eu tenho (a do Clover R5114, a do OpenCore 0.6.2 do GitHub e a do OpenCore 0.6.9 que estou fazendo), identificando os problemas de cada uma delas.

Clover r5114 - https://bit.ly/2SQLdg3
    
Tudo funcionando, exceto áudio no HDMI.

OpenCore 0.6.2 (GitHub) - https://bit.ly/2RVudp8
    Teclado, touchpad, wifi e áudio no HDMI não funcionam.

Meu OpenCore 0.6.9 - https://bit.ly/3wMJZkO
    Teclado, touchpad, wifi e áudio no HDMI não funcionam.

Como disse, o principal é o teclado e o touchpad... Mas, se conseguir resolver o áudio no HDMI e o wifi também, seria perfeito rsrs...

Se alguém puder me ajudar por favor a deixar esse OpenCore 0.6.9 funcionando, ficarei muito agradecido! :D

Obrigado!

Link to comment
Share on other sites

  • Administrators

Check Olarila Tutorials and Useful Links!

-OpenCore Vanilla Guide
https://tinyurl.com/w3d4yrk

-Clover Vanilla Guide
https://tinyurl.com/hxu2v9wm

-Useful Links
https://tinyurl.com/43t5m6d4

-Premium Users
https://tinyurl.com/ecmhv5ke

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

11 minutes ago, MaLd0n said:

Check Olarila Tutorials and Useful Links!

-OpenCore Vanilla Guide
https://tinyurl.com/w3d4yrk

-Clover Vanilla Guide
https://tinyurl.com/hxu2v9wm

-Useful Links
https://tinyurl.com/43t5m6d4

-Premium Users
https://tinyurl.com/ecmhv5ke

Hi @MaLd0n! Thanks for your reply.

 

I've already followed OpenCore Vanilla Guide, and checked on Clover Vanilla Guide and on Useful Links, looking for useful information about why VoodooPS2 can't work properly, but I can't find anything useful about that.

I just found a topic about my wifi card (Atheros AR9565), which will be very useful! So, thank you for that!

Have you some other topic about VoodooPS2? I've already searched here and there, in Google and DuckDuckGo and can't find anything that worked for me...

Thanks!

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

UPDATE:

I've trying some other versions of VoodooPS2Controller, and I've noticed my keyboard is working, but touchpad no... BUT, my keyboard works ONLY IF I don't try to use touchpad... If I try to use touchad, keyboard stops working instantly.

Checking kexts with kextstat | grep voodoo, all kexts related to VoodooPS2Controller (Input, Controller, Mouse, Keyboard and Trackpad) are loaded properly...

Since my touchpad is ELAN, I've also tried to inject VoodooPS2Controller and VoodooSMBus together, but still not working as expected.

Can someone help me? I really want my touchpad and keyboard working, and can't understand why it's not working...

Thanks!

Link to comment
Share on other sites

UPDATE:

I finally got it! The problem was the SSDT-BATT.aml that I copy from GitHub's build... For some reason, this SSDT is an full DSDT, with some overrides, like PS2M and PS2K (those are my touchpad and keyboard, respectively). All solved just removing it from config.plist.

Now, next steps:

  • Fix trackpad (even though touchpad is working, with two-fingers vertical/horizontal scroll, physical buttons click and three-finger gestures, macOS isn't detecting it as a trackpad, and touch-click and two-fingers click for right button aren't working)
  • Fix wifi (I've found some tutorials on internet about AR9565.. I will check them)
  • Fix HDMI audio
  • Check if battery is recognized well since I've removed the SSDT-BATT (this will be more complicated, since my laptop have no battery for a while, and I'm not miss)

Every news I will post here! I think this will be very helpful for anyone that has this laptop too, and wants to make a hackintosh.

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...