Jump to content
Foravl

Acer Swift 3 sf314-57-58VL

Recommended Posts

Hello! 

I have a notebook Acer Swift 3 sf314-57-58VL with following specifications:

  • Intel i5 1035G1¬†
  • Intel UHD Graphics
  • Killer Wi-Fi 6 AX1650i 160MHz Wireless Network¬†Adapter (201NGW)¬†Wi-Fi 6 (802.11ax), 802.11 ac/a/b/g/n
  • Bluetooth 5.0 (Intel)
  • Smart Sound Technology Audio Controller
  • Intel NVMe¬†SSD 660P Series 1TB
  • RAM 8GB LPDDR4
  • 1xUSB 3.1 Gen 2 Typ-C, 1x USB 3.1 Gen 1 Typ-A, 1x USB 2.0, 1x HDMI, 1x Headset/Mic Combiplug
  • Touchpad (Syna)

 

I successfully installed Big Sur 11.2.3 with 

--NOTEBOOKS ICELAKE

https://tinyurl.com/y25ju7xp

 

After that I added AirportItlwm.kext, IntelBluetoothFirmware.kext, IntelBluetoothInjector.kext.

SMBIOS is MacBookPro16,2

Following works:

  • Bluetooth
  • Wi-Fi
  • Battery State
  • Brightness Slider
  • USB-ports

Not working:

  • Touchpad
  • Sleep
  • Brightness buttons
  • Sound
  • Display flashes on starting
  • Processor plug and stepping

Could you please help me to patch DSDT and all the things.

I attached the output of the run_me.app (AirportItlwm.kext and IntelbluetoothFirmware.kext deleted because of size).

Thank you in advance.

 

Best regards

 

 

Send me MBP.zip

Link to comment
Share on other sites

  • Administrators

remove ssdts

DSDT.aml.zip

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Thank you Maldon!

I tried this DSDT with the following results:

  • Touchpad works fine
  • Brightness Buttons works¬†
  • CPU SpeedStep works
  • Also iGPU is there
  • Webcam
  • The hw will be shown in info

Further does not work:

  • Sound at all (no output no input)
  • HDMI
  • Sleep (Display turns off, the whole system hangs and no longer responds to anything)
  • Display flashes on start. Short after apple loading I see the desktop for 1 second, then black screen for 3-5 seconds, after that working desktop

Could I provide some additional info or EFI?

Thanks in advance

Link to comment
Share on other sites

  • Administrators

extract new sendme

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Thank you! I added the device-id=C8340000 and layout-id=0C000000. After restart oh wonder audio devices are there :) But it works only with headphone/mic combo. The speakers on the laptop and mic on the laptop remain mute.

Should I try the patch from AppleALC patch for not native devices?! 

Link to comment
Share on other sites

  • Administrators

use only alcid=3 for example

check all layout available to ur audio codec and start test

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

the only available layout for explored codec cx8400 is 12. with this layout works headset (incl. mic on headset) but no sound on laptop. 

the codec on my laptop is cx11970, that unfortunately is not in AppleALC. what could I do?

Other big issue is the sleep, the display switches off and nothing can be done, I have to hard reset.

 

 

there is also empty pin configuration

Screenshot 2021-04-10 –≤ 18.25.30.png.zip

Link to comment
Share on other sites

  • Administrators

check what cause sleep problem

Quote

log show --style syslog | fgrep "Wake reason"

about audio use good and old voodoohda

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

that the output of log:

2021-04-05 11:34:17.484672+0200  localhost powerd[77]: [powerd:sleepWake] Wake reason: "<private>"  identity: "<private>"

2021-04-05 11:40:23.459790+0200  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: PWRB XDCI (User)

2021-04-05 11:40:23.459791+0200  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: PWRB XDCI (User)

2021-04-05 12:06:32.568375+0200  localhost powerd[78]: [powerd:sleepWake] Wake reason: "<private>"  identity: "<private>"

2025-01-01 01:20:03.965046+0100  localhost powerd[80]: [powerd:sleepWake] Wake reason: "<private>"  identity: "<private>"

2025-01-01 01:20:21.518466+0100  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI

2025-01-01 01:20:21.518467+0100  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI

2025-01-01 01:26:21.764921+0100  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI

Link to comment
Share on other sites

  • Administrators

wake from lan is disable?

 

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

correct.

It seems the notebook goes to sleep mode, but only display is off, the keyboard lightning and fans are working, but I can't wake up, have to reset hard and after that, the notebook is not booting, every time goes to the same state (display off and nothing react). I reset then hard (very hard), so that the Bios resets to default. After reconfiguration of bios I can start normal.

Link to comment
Share on other sites

  • Administrators

seems like some device connected cause this problem

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

u have some hub or other usb device?

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

strange problem

no idea what happens in this case

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

The strange thing is that the keyboard is lit and the notebook appears to be still running. I suspect that it goes into a kind of sleep mode, because after the reset the values are read from NVRAM and switch to this mode. Only when the BIOS is reset, and with it NVRAM, will MacOS start normally.

What else can you do with the flashing display when starting up? When the computer starts and the apple logo can be seen, it flashes several times and there are strange stripes (artifacts), shortly before the login occurs, the login appears and the display switches off for 2-4 seconds (also the lighting keyboard) and then it comes back. Could it be that the wrong device ID is being used, or that other parameters need to be changed?

Link to comment
Share on other sites

Could you please check my EFI folder and config.plist, there may be any inconsistencies.
In addition, when I try to deploy the newer (last) version of VirtualSMC and Whatevergreen, I can no longer boot.

 

EFI.zip

removed to kext Airportitlwf and IntelBluetoothFirmware, due to size limit

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Thank you Maldon!
It's gotten a little different. When going to sleep, the laptop is switched off for a second, then it wakes up and is in the state I described before.
So that I can only get it working with BIOS reset.

Link to comment
Share on other sites





×
  • Create New...